Kodi Community Forum

Full Version: Asrock ION 330 HT remote doesnt work.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I cant seem to get the asrock ion 330 remote working. I have tried almost all the instructions posted in the forum and really cant seem to get a workaround.

I have a clean installation of Ubuntu 10.04, and installed XBMC from the XBMCWIKI.

I recently saw in the ASROCK website about a new driver and decided to give it a shot.

I followed ASROCK instructions included below:

1. Install Ubuntu 10.04
2. Update kernel to 2.6.32-23(install "linux" in Synaptic Package Manager).
Then reboot. (Important)
3. Update kernel header 2.6.32-23-generic(verison is 2.6.32-23.37)
4. Install lirc
5. Install "lirc-nct677x-1.0.4-ubuntu10.04_kernel2.6.32-23.deb" (For 32bit OS)
6. If you had installed source package of lirc(lirc-modules-source),
please remove it in Synaptic Package Manager. (Important for kernel 2.6.32-23)

I still see a lot of fails and only one OK in the terminal.

The weird thing for me is that the power button on the remote works to power on the ASROCK, but everything else fails.

Can someone help as i really need to get this over with, its been a real pain to deal with this. I managed to set up everything perfectly and this is the only thing left.

If you would like an output of anything please tell me and i will post it, but please tell me how to get the output as i am not an advanced ubuntu user. I only switched from windows to get VDPAU.

Thanks in advance.
anyone can shed some light or has found a solution for this?
I only can say week ago reinstall my ubu 10.04, upgraded kernel to 2.6.32-24, install newest drivers from asrock site
Code:
http://europe.asrock.com/downloadsite/drivers/Nettop/Ubuntu/IR(10.04)kernel2.6.32-23.zip
and its working.
i reall dont know what is going wrong. I followed all the steps correctly
The procedure in this guide works for me.
i still havent managed to get it working.

except the lirc driver is there anything else i remove in order to have a clean version to try again?

also do i have to be root to make it working or not? because i am logged in as my user, and from what i've read it doesnt matter if you are not because the user you installed is automatically root.

One more thing i noticed...dont know if this is related.

My ASRock randomly boots itself. This has happened 2-3 now that i am writing. Dont know why but it just boots up.

Thanks in advance
Well, the power on and off was due to the adapter being faulty. i changed it and its fine.

I have still not managed to get the remote working. i have browsed over 100 pages and threads for its installation and something seem to be wrong. I dont know what else to do.

I have marked the lirc driver for complete removal, and reinstalled 1000 times but still nothing. It always give me the error of to choose the correct kernel from hardware.conf.

As i checked though its fine.

i am using the new driver form asrock website labelled "new kernel" and have followed all the steps in the text file and pdf file.

please guys i really need your help
I'm running Lucid 10.04 LTS from a minimal install, kernel 2.6.32-24. I followed the Asrock procdeure and it simply didn't work.

This worked for me. In a terminal -

1. Remove all lirc stuff:

Code:
sudo apt-get purge lirc

The lirc config screen may appear. Enter 'None' & 'None' for receiver & transmitter.

2. The I ran apt update.

Code:
sudo apt-get update

3. re-install lirc

Code:
sudo apt-get install lirc

when the lirc configuration appears enter 'None' & 'None' for receiver & transmitter.

4. Install the driver.

Code:
sudo dpkg -i lirc-nct677x-1.0.4-ubuntu10.04_kernel2.6.32-23.deb

When the lirc config screen appears select [Nuvoton Transceivers/Remotes] for the receiver and [None] for transmitter.

After the lirc config screen disapears there will be more output from dpkg that should show as lirc being loaded OK, but irexec may show as 'fail'. That's OK.

Do not install anything else. Apt may install dependencies but do not install any 'suggested' packages. I don't think you need to reboot - but I did anyway, and the remote worked in XBMC.

FYI the remote will turn the 330HT on as it's hardwired this way.
@ Balthazaar

Thanks for the reply.

I tried it but still the same. I dont know what the hell is going on.

A simple remote and it is such a pain in the ass....i am really stuck now.
Setting up LIRC is not for the novice. Get one of the Asrock ION builds. This same thread with the same problems comes up almost every other week. It's not easy to set it up. You can find notes from other people by searching or you can get a Asrock ION XBMC copy.

When you want to use other then release versions, it's best to experiment with different versions of source. You can search online and find out which versions of LIRC are borke with your version of kernel. I had a simlilar problem about 6 months ago which was cured by building a slightly older then SVN version of the kernel and SVN source from the tip of the LIRC build.

I'm not trying to be a dick and tell you to search... But you've been looking for information since the beginning of the month. I'm sure we've had another Asrock ION remote thread since you started this one.
rossoneri711 Wrote:@ Balthazaar

Thanks for the reply.

I tried it but still the same. I dont know what the hell is going on.

A simple remote and it is such a pain in the ass....i am really stuck now.

I have the same problem Sad
I'm using a different remote (HP mceusb) on r33122 and it doesn't work either.
That is to say it works for everything except xbmc, I'm sure they'll have it sorted in a newer SVN.

In the mean time, a few commands to let you know to what extent your remote works or doesn't.
Code:
irw
Leaves you with a blinking curser in terminal and when you press a button on your remote, displays which button was pressed, the lirc-name of your remote and the key code. This way you know which buttons are set up correctly in lirc.

If all the buttons are registering correctly, your lirc is working properly.

The next step is to check your remote with xbmc:
Copied shamelessly from a post by "lx cool j"
http://forum.xbmc.org/showthread.php?tid...MCE+remote

Here we find a few helpful commands.

Open xbmc then open a terminal
Code:
cat /home/[xbmc-user]/.xbmc/temp/xbmc.log | grep remote.xml
(type in your username where it says [xbmc-user])

this will tell you if your keymaps loaded successfully by returning something like this
Code:
21:11:00 T:3041413008 M:1477832704    INFO: Loading special://xbmc/system/keymaps/remote.xml
21:11:00 T:3041413008 M:1477832704    INFO: Loading special://profile/keymaps/remote.xml
now enter
Code:
cat /home/[xbmc-user]/.xbmc/temp/xbmc.log | grep Lircmap.xml
this will tell you if your Lircmap.xml loaded successfully by returning something like this
Code:
21:11:00 T:3041413008 M:1477832704    INFO: Loading special://xbmc/system/Lircmap.xml
21:11:00 T:3041413008 M:1477832704    INFO: Loading special://profile/Lircmap.xml

if these loaded correctly go on to the next command
Code:
tail -f /home/[xbmc-user]/.xbmc/temp/xbmc.log
this should display some text from your "xbmc.log" and display which remote button registers in xbmc. Try the buttons one at a time to see which are detected correctly.

If you still get no joy, you may need to map the buttons on your remote. A bit involved but not rocket science. A good How-To by Temar can be found here
http://forum.xbmc.org/showthread.php?tid...mce+remote

Sad to say if lirc is setup correctly, you mapped your buttons correctly (no "remote.xml" or "Lircmap.xml" loading errors in your xbmc.log found in ~home/.xbmc/temp) and still have no xbmc remote, you may have to wait for a newer SVN to solve the problem.
this is what i get when i enter "irw" in the terminal:

Quote:[email protected]:~$ irw
connect: No such file or directory

Quote:[email protected]:/home/rossoneri711# irw
connect: No such file or directory
sudo dpkg-reconfigure lirc
After running "sudo dpkg-reconfigure lirc ", choosing nuvoton in the first window and none in the other, here what i get below:

Quote:[email protected]:~$ sudo dpkg-reconfigure lirc
[sudo] password for rossoneri711:
* Stopping execution daemon: irexec [fail]
* Stopping remote control daemon(s): LIRC [fail]
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service udev reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload udev
* Loading LIRC modules [ OK ]
* Unable to load LIRC kernel modules. Verify your
* selected kernel modules in /etc/lirc/hardware.conf
* Starting execution daemon: irexec [fail]

and i still get the same error as above