Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Alright, thanks again! I use this plugin like crazy, it's pretty much the only thing I'm ever watching these days. Including the ability to surf through "related videos" was a great idea...
I was able to fix my login problems in 2.1.2 on both my systems, but I don't know enough about how this stuff works to say why.

What I did was:
1. Switch accounts to one that does NOT use two-factor authentication. Still unable to view folders/playlists with the one factor account.
2. Restart XBMC
3. Still unable to view folders/playlists with the one factor account.
4. Switch accounts to two-factor, using my normal, non-app-specific password.
5. Click Login
6. Enter two-factor code in the title-less box that pops up.
7. Success!

Both of my systems can now log in. One is a 64bit Win7 Enterprise, the other is a 64 bit Win2008R2.

I imagine that merely deleting whatever file contains the login info would probably do the trick as well, but I wouldn't know where that is Big Grin
wizardpc Wrote:I was able to fix my login problems in 2.1.2 on both my systems, but I don't know enough about how this stuff works to say why.

What I did was:
1. Switch accounts to one that does NOT use two-factor authentication. Still unable to view folders/playlists with the one factor account.
2. Restart XBMC
3. Still unable to view folders/playlists with the one factor account.
4. Switch accounts to two-factor, using my normal, non-app-specific password.
5. Click Login
6. Enter two-factor code in the title-less box that pops up.
7. Success!

Both of my systems can now log in. One is a 64bit Win7 Enterprise, the other is a 64 bit Win2008R2.

I imagine that merely deleting whatever file contains the login info would probably do the trick as well, but I wouldn't know where that is Big Grin

Yeah, while login should be fixed some other errors cropped out. We are currently investigating backporting 2.7.0 to Dharma instead of trying to maintain the 2.1.X codebranch.
Glad to see youtube using again videos files views instead of library views!
First off great plugin, huge improvement from the previous plugin. I'd love use the youtube top 100 playlist as my "goto" for music, but I cannot find a way to get the videos to play back to back without adding them individually to my queue. Is there a way I can manually add enqueue all or better yet a randomized enqueue all to the context menu? Thanks for a great skin and the help! Big Grin
youngsilver Wrote:First off great plugin, huge improvement from the previous plugin. I'd love use the youtube top 100 playlist as my "goto" for music, but I cannot find a way to get the videos to play back to back without adding them individually to my queue. Is there a way I can manually add enqueue all or better yet a randomized enqueue all to the context menu? Thanks for a great skin and the help! Big Grin

If you are running the beta you should have access to "Play all" and "Shuffle and Play all" in the context menu's.

See second picture here.
http://code.google.com/p/youtubexbmc/wik...BetaPlugin
is there any way to save a youtube folder as a playlist, for quick access from the startup screen

when i save it, it saves as a myfolder.m3u file

the youtube videos load up in the saved playlist, but when you click to watch nothing happens

any ideasHuh

thanks
when i go to view my subscriptions the script gives me a error, but everything else seems to work fine. I can see My favorites and playlists and contact but subscriptions nope.

script error: plugin.youtube.com

any ideas? this is eden and script is 2.7.0

log file

Code:
23:43:31 T:7760  NOTICE: [CommonFunctions-0.8] _fetchPage : 'connecting to server... '
23:43:32 T:7760  NOTICE: [CommonFunctions-0.8] _fetchPage : 'done'
23:43:32 T:7760   ERROR: Error Type: <type 'exceptions.IndexError'>
23:43:32 T:7760   ERROR: Error Contents: list index out of range
23:43:32 T:7760   ERROR: Traceback (most recent call last):
                                              File "c:\XBMC\portable_data\addons\plugin.video.youtube\default.py", line 102, in <module>
                                                navigation.listMenu(params)
                                              File "c:\XBMC\portable_data\addons\plugin.video.youtube\YouTubeNavigation.py", line 120, in listMenu
                                                return self.list(params)
                                              File "c:\XBMC\portable_data\addons\plugin.video.youtube\YouTubeNavigation.py", line 200, in list
                                                (results , status) = self.feeds.list(params)
                                              File "c:\XBMC\portable_data\addons\plugin.video.youtube\YouTubeFeeds.py", line 129, in list
                                                return self.listFolder(params)
                                              File "c:\XBMC\portable_data\addons\plugin.video.youtube\YouTubeFeeds.py", line 225, in listFolder
                                                result = self.listAll(params)
                                              File "c:\XBMC\portable_data\addons\plugin.video.youtube\YouTubeFeeds.py", line 308, in listAll
                                                next = temp_objects[len(temp_objects)-1].get("next","false")
                                            IndexError: list index out of range
23:43:32 T:2580   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.youtube/?path=/root/subscriptions&user_feed=subscriptions&login=true&folder=true&
23:43:32 T:2580   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/?path=/root/subscriptions&user_feed=subscriptions&login=true&folder=true&) failed
23:43:32 T:7464  NOTICE: -->Python Interpreter Initialized<--
23:43:32 T:7464  NOTICE: YouTube-2.7.0
23:44:30 T:2580   ERROR: Python script "script.tvtunes" does not exist
23:44:34 T:4800  NOTICE: -->Python Interpreter Initialized<--
23:44:34 T:4800  NOTICE: YouTube-2.7.0
23:44:34 T:4800  NOTICE: [CommonFunctions-0.8] login : ''
23:44:49 T:4800  NOTICE: [CommonFunctions-0.8] login : 'refreshing token: False'
23:44:49 T:4800  NOTICE: [CommonFunctions-0.8] _oRefreshToken : ''
23:44:49 T:4800  NOTICE: [CommonFunctions-0.8] _fetchPage : 'called for : 'https://accounts.google.com/o/oauth2/token''
23:44:49 T:4800  NOTICE: [CommonFunctions-0.8] _fetchPage : 'connecting to server... '
23:44:50 T:4800  NOTICE: [CommonFunctions-0.8] _fetchPage : 'done'
23:44:50 T:4800  NOTICE: [CommonFunctions-0.8] _oRefreshToken : '- returning, got result a: {u'access_token': u'ya29.AHES6ZTRADJPUnmD1maFnksJk8bZH_-rs29Iojef-MzYNDTlx30ql7I', u'token_type': u'Bearer', u'expires_in': 3600}'
23:44:50 T:4800  NOTICE: [CommonFunctions-0.8] _oRefreshToken : 'Success'
23:44:50 T:7692  NOTICE: -->Python Interpreter Initialized<--
23:44:50 T:7692  NOTICE: YouTube-2.7.0
23:44:50 T:2580   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.youtube/?path=/root/settings&action=settings&
23:44:50 T:2580   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/?path=/root/settings&action=settings&) failed
23:44:50 T:4660  NOTICE: -->Python Interpreter Initialized<--
23:44:50 T:4660  NOTICE: YouTube-2.7.0
23:44:55 T:2580   ERROR: Window Translator: Can't find window scriptsdebuginfo
23:44:55 T:2580   ERROR: Window Translator: Can't find window pluginsettings
23:44:57 T:2580 WARNING: Skin has invalid include: ScrollOffsetLabel
23:44:57 T:2580 WARNING: Previous line repeats 1 times.
23:44:57 T:2580 WARNING: Skin has invalid include: FullWidthList
23:44:57 T:2580 WARNING: Previous line repeats 1 times.
23:44:57 T:2580   ERROR: Window Translator: Can't find window scriptsdebuginfo
23:44:57 T:2580   ERROR: Window Translator: Can't find window pluginsettings
TobiasTheCommie Wrote:If you are running the beta you should have access to "Play all" and "Shuffle and Play all" in the context menu's.

See second picture here.
http://code.google.com/p/youtubexbmc/wik...BetaPlugin

WOOT! I will update when I get home. Thanks!
NaDs Wrote:is there any way to save a youtube folder as a playlist, for quick access from the startup screen

when i save it, it saves as a myfolder.m3u file

the youtube videos load up in the saved playlist, but when you click to watch nothing happens

any ideasHuh

thanks

Could you upload the content of a myfolder.m3u that fails?
DR9x Wrote:when i go to view my subscriptions the script gives me a error, but everything else seems to work fine. I can see My favorites and playlists and contact but subscriptions nope.

script error: plugin.youtube.com

any ideas? this is eden and script is 2.7.0

It works for me ™.

Could you try the following:
1) Change your username and/or password to something that is wrong, and try to login
2) Change your username and/or password back to the correct values and try to login again.
3) Enter your subscriptions
4) Post the ENTIRE debug log(not just a snippet).
TobiasTheCommie Wrote:It works for me ™.

Could you try the following:
1) Change your username and/or password to something that is wrong, and try to login
2) Change your username and/or password back to the correct values and try to login again.
3) Enter your subscriptions
4) Post the ENTIRE debug log(not just a snippet).

did steps 1-3, samething cant access, error. Here is the full log file

http://pastebin.com/WM7L7NE1
TobiasTheCommie Wrote:If you are running the beta you should have access to "Play all" and "Shuffle and Play all" in the context menu's.

See second picture here.
http://code.google.com/p/youtubexbmc/wik...BetaPlugin

I updated and tested it last night. Play all appears if I hit context menu on a playlist of mine, but not top 100 playlist, I guess it sees it as a folder.

I could go into youtube and add the top 100 as a playlist but I'm afraid the playlist wont dynamically update through time; Wouldn't be an issue but I'm gifting this machine to my computer-retarded sister for christmas haha. I'll look through the code in the morning and see if I can figure anything out a work around.
DR9x Wrote:did steps 1-3, samething cant access, error. Here is the full log file

http://pastebin.com/WM7L7NE1

Ok, i see something wrong. Weird i'm not hitting this bug.

We will fix it for the next release.

ETA: You might be able to solve this problem by adding/removing a few subscription. I don't know, but you can give it a go.
youngsilver Wrote:I updated and tested it last night. Play all appears if I hit context menu on a playlist of mine, but not top 100 playlist, I guess it sees it as a folder.

I could go into youtube and add the top 100 as a playlist but I'm afraid the playlist wont dynamically update through time; Wouldn't be an issue but I'm gifting this machine to my computer-retarded sister for christmas haha. I'll look through the code in the morning and see if I can figure anything out a work around.

This has been implemented in our trunk. It should work in the next release.