Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
"tab"
ppic Wrote:"tab"

when using a MCE remote what button would the "tab" button be ....


-=Jason=-
i think you have to map it in keymap or try the "display" button.
sorry but it doesn't work with xbmc 9.11 and windows 7
it says installation script fail
yuo need dharma for it.
Nektarios Wrote:Does the seek work properly? I tried it and when I do a seek while playing it waits until it downloads all of the stream up until the seek point.

Can this be solved?

The plugin just hands over a url to xbmc, and its then xbmc's player core that takes over from there. The caching strategy and seek behavior that xbmc chooses for web based content is entirely out of our control as mere mortal plugin developers. But I am curious as to what video you experience this with as seeking has been almost instantaneous for me.. Huh (just tested it again, and yup, no wait or lag when seeking through a 720p video stream), although i could expect playback to behave differently on rtmpe streams, though i don't believe we had that problem ourselves.
greensheep Wrote:sorry but it doesn't work with xbmc 9.11 and windows 7
it says installation script fail

Wow.. Just wow..

From the Home Page:

In order to use this plugin you will need the upcoming Dharma release of XBMC. The latest stable 9.11 version will not work.

It's only like the first line of text on that page.. Big Grin
http://code.google.com/p/youtubexbmc/
TobiasTheCommie Wrote:Could you give me another log to look at, with another video if possible?

I had another go at reproducing the problem, and, well; I did say it was inconsistant!! Rolleyes

First of all, I'd like to take back what I said about it "never" playing the age restricted videos without logging in through settings first, because it certainly managed it tonight!

In the first session I went and played the M.I.A. video I mentioned in my previous post, and it took quite a while to start the video, but it did play. I then went on to play one of the videos I'd tried previously and playback failed with an "uncaught error" message.

log: http://pastebin.com/8sWp7wLE

In the next session everything played fine, although there was a fair wait between selecting the video and playback starting. Videos that I played include the M.I.A. video, and 3 different videos from 4oD which I'd previously been having problems with. A link to the log from that session is below:

http://pastebin.com/zhauLvCs

I'm really sorry that i haven't been able to provide you with a consistant set of logs and errors. It might be difficult to pinpoint what goes wrong (when it does go wrong) if it doesn't happen consistantly. If I'm able to reproduce the playback error consistantly I'll post a decent set of logs for you, but I'm afraid that's the best I can do for now
procrastinator Wrote:I had another go at reproducing the problem, and, well; I did say it was inconsistant!! Rolleyes
It is fine. Honestly, don't spend time hunting them down, just give me a debug log when it happens.

I'll look at those log in a bit.
Hi!
I have the last T3ch Build ...It doesn't work on xbox??
It says "script error"
Sad
Ironkekko Wrote:Hi!
I have the last T3ch Build ...It doesn't work on xbox??
It says "script error"
Sad

The only xbox version of our plugin is this one

mighty_bombero Wrote:For those anxious to try on Xbox. Here a patched up version. I had to disable open settings but with some more time I'm positive this can be fixed up too. Will hopefully clean this up soon and provide patches upstream.

http://ul.to/y9hxhw

@henrik & Tobias: Hope you don't mind me providing this version?

MB


Which is not supported by me or henrik.

mighty_bombero, if you can make some good patches i am more than willing to add them to our build so there only is one version.
Release YouTube 1.8.0

This should be used with Dharma-beta1 or later.

Changelog:
- Solved confusion cause by multiple licens files (removed GPL v2 license and renamed GPL v3 to LICENSE.txt)
- Version bump to replace old YouTube plugin
- Name change from plugin.video.youtube.beta to plugin.video.youtube
- Name change from You Tube Beta to You Tube

We have send a pull request so hopefully this should get into the addon repository soonish.

NOTE: Because of the DMCA we have had to disable RTMP support in the addon repo.

RTMP support is still enabled in svn and in the releases supplied here.

http://code.google.com/p/youtubexbmc/downloads/list

Upgrade procedure:
- If you have previously installed ANY version of our plugin, you should remove it/delete it before installing this version.
- Restart XBMC
- Install new plugin
- If you have a plugin called "You Tube Beta" you should double check that you have properly removed the old plugin, and restart XBMC.
Great work! Big Grin
1.Can somebody help me to get icons setting in "list view" mode by default in this plugin?
2. And is it possible to get videos from playlist to play continuosly?
boki99 Wrote:Great work! Big Grin
1.Can somebody help me to get icons setting in "list view" mode by default in this plugin?
2. And is it possible to get videos from playlist to play continuosly?

1) This is in the works, but some changes in XBMC are needed for that to be implemented. This is not going to be in the plugin for the Dharma release. But once XBMC supports it, so will we.

2) In the context menu you can "Queue Folder" and "Queue Video"
TobiasTheCommie Wrote:In the context menu you can "Queue Folder" and "Queue Video"

This is unnesessery thing. Also anoying. Why should I make same playlist twice or more timesHuh Please fix this.Huh