Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
jimmymcmahon Wrote:Hey guys i think the update to 2.9 or some of its dependancies may have caused Justin.tv plug in to break.


The following script error started after
-youtube update 2.9.0
-common plugin update
-simple downloader update

14:12:27 T:2896272240 ERROR: Error Type: <type 'exceptions.ValueError'>
14:12:27 T:2896272240 ERROR: Error Contents: No JSON object could be decoded
14:12:27 T:2896272240 ERROR: Traceback (most recent call last):
File "/storage/.xbmc/addons/plugin.video.jtv.archives/default.py", line 559, in <module>
Categories()
File "/storage/.xbmc/addons/plugin.video.jtv.archives/default.py", line 117, in Categories
data = json.loads(result[0])
File "/usr/lib/python2.7/json/__init__.py", line 326, in loads
return _default_decoder.decode(s)
File "/usr/lib/python2.7/json/decoder.py", line 366, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "/usr/lib/python2.7/json/decoder.py", line 384, in raw_decode
raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
14:12:27 T:3018414800 ERROR: GetDirectory - Error getting plugin://plugin.video.jtv.archives
14:12:27 T:3018414800 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.jtv.archives) failed
14:12:27 T:2896272240 NOTICE: Thread Background Loader start, auto delete: false
14:12:36 T:2896272240 NOTICE: Thread XBPyThread start, auto delete: false
14:12:36 T:3018414800 ERROR: Control 1 in window 10099 has been asked to focus, but it can't

I fail to see how this can have anything to do with the YouTube plugin.

If JustinTV uses parseDOM or the common cache, it probably needs to be updated to the new versions before it works.
Hirs Wrote:Hi,

Thank you for updating the plugin, just a little thing, I use two step login, and I'm asked for my pin on every single video I play, well I have disabled two step for the moment, but it would be great to have it back.
I can't confirm this. I use 2-factor on all my systems.

Hirs Wrote:On the other hand, may be I'm missing something obvious, but, how can I invert the order for "watch later" videos? rigth now latest videos are at the end, so I have to click more videos to get to the latest (and this will grow every time I add a new video)
Hm, yeah, we probably forgot to add it. Whoops Smile
Got a very odd problem. I just updated to eden beta 2, and suddenly instead of seeing youtube version 2.8 which it always was, or updating to the recent 2.9, i'm suddenly on version 2.1.4, which i only is for dharma. I have no idea what just happened. I know i downloaded the correct file. Ofcourse, needless to say, youtube is not working for me. WHen i press login, the popup bx shows up, with my username and password, but after i press enter the box goes away and nothing happens. Wont even show the regular login failed.
TobiasTheCommie Wrote:Full log to pastebin please.

Here you are: http://pastebin.com/yYD8MqJy
Ok, I have now tried everything (official update to 2.9.0 in atv, uninstall and install of the plugin, using the zip file mentioned in this thread etc) but I still get script error. Any other option how to make it work? Thank you

here is the log
http://pastebin.com/c7B7fm9W
nmirza Wrote:Got a very odd problem. I just updated to eden beta 2, and suddenly instead of seeing youtube version 2.8 which it always was, or updating to the recent 2.9, i'm suddenly on version 2.1.4, which i only is for dharma. I have no idea what just happened. I know i downloaded the correct file. Ofcourse, needless to say, youtube is not working for me. WHen i press login, the popup bx shows up, with my username and password, but after i press enter the box goes away and nothing happens. Wont even show the regular login failed.

Ok thriugh some combination of restarting xbmc dozens of times, reinstlling plugin, etc, im now at 2.9 but another old bug seems to have reared its ugly head. The default view is back to icon, so even though i switch to list, every time i change a subscription, or go out and back into the same one, its back to icon view no matter how many times i change to list view. I used to have this issue back a few days ago when you guys made the plugin, and not sure what the solution was. Well no the issue is back.
Hi there,

The plugin is working again. Thanks.

Surfing my playlists, it only displays 50 videos at most. In other sections (like a subscription) it displays more than 50 intems by selecting "more results" at the end. I tried updating, re-ording, adding new videos, etc with no results.

Is it a plugin restriction? a bug?

Thanks
Hi,

I found problem exploring YouTube. Categories are not displayed (error: No Results! is displayed when "YouTube Categories" is pressed).
Log is:
ERROR: GetDirectory - Error getting plugin://plugin.video.youtube/?path=/root/explore/categories&scraper=categories&login=false&
ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/?path=/root/explore/categories&scraper=categories&login=false&) failed


I use Dharma, ver. 2.1.4 plugin.

Thanks
igorz Wrote:Hi,

I found problem exploring YouTube. Categories are not displayed (error: No Results! is displayed when "YouTube Categories" is pressed).
Log is:
ERROR: GetDirectory - Error getting plugin://plugin.video.youtube/?path=/root/explore/categories&scraper=categories&login=false&
ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/?path=/root/explore/categories&scraper=categories&login=false&) failed


I use Dharma, ver. 2.1.4 plugin.

Thanks
http://wiki.xbmc.org/index.php?title=Add..._debug_log
Killer-JoeBR Wrote:Hi there,

The plugin is working again. Thanks.

Surfing my playlists, it only displays 50 videos at most. In other sections (like a subscription) it displays more than 50 intems by selecting "more results" at the end. I tried updating, re-ording, adding new videos, etc with no results.

Is it a plugin restriction? a bug?

Thanks

Ah crap, more of those. We will look into it
nmirza Wrote:Ok thriugh some combination of restarting xbmc dozens of times, reinstlling plugin, etc, im now at 2.9 but another old bug seems to have reared its ugly head. The default view is back to icon, so even though i switch to list, every time i change a subscription, or go out and back into the same one, its back to icon view no matter how many times i change to list view. I used to have this issue back a few days ago when you guys made the plugin, and not sure what the solution was. Well no the issue is back.

A) Sounds like you should really make a clean reinstall of XBMC
B) You can toggle the view mode in the plugin settings.
minaka Wrote:Ok, I have now tried everything (official update to 2.9.0 in atv, uninstall and install of the plugin, using the zip file mentioned in this thread etc) but I still get script error. Any other option how to make it work? Thank you

here is the log
http://pastebin.com/c7B7fm9W

You should undo what that zip did and reinstall from the repository.

If you still encounter the error, configure the Simple Downloader and set a timeout(It should default to 5seconds, but apparently it isn't doing that for you)
TobiasTheCommie Wrote:You should undo what that zip did and reinstall from the repository.

If you still encounter the error, configure the Simple Downloader and set a timeout(It should default to 5seconds, but apparently it isn't doing that for you)

Tobias, thank you for your prompt reply. I doubt that I have Simple Dowloader installed on my atv (unless it is installed automatically with the youtube plugin). Could this be the problem? Youtube plugin does not work without the Simple Downloader add-on?
minaka Wrote:Tobias, thank you for your prompt reply. I doubt that I have Simple Dowloader installed on my atv (unless it is installed automatically with the youtube plugin). Could this be the problem? Youtube plugin does not work without the Simple Downloader add-on?

It's a dependency and is installed automatically.

I got the impression it was also in the zip you got.