Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
A stupide question, is there something to configure on the depandancy "common plugin cache" and "simple downloader for xbmc plugins" ?
(2012-09-30, 17:25)nabsboss Wrote: [ -> ]Hi,

i remove xbmc with profil folder.
I made a fresh install of xbmc in english. I installed youtube only and same issue with utf-8.

also i have this issue on 2 windows plateform (windows 7 home edition 64 and windows ultimate 32).

AAArrrrgggggg i'm going to loose my haire ........

Any idea Huh
I didn't see any problem at all. At least, your XBMC seems fine. Huh
You may wanna ask the developer or people share the same problem as yours.
(2012-09-28, 03:55)artrafael Wrote: [ -> ]
(2012-09-28, 03:39)Fragarach Wrote: [ -> ]
(2012-09-23, 20:20)Alethenorio Wrote: [ -> ]You shouldn't need to download the files anymore. Version 3.2.0 which you can download from within xbmc is released and should fix the issue.

From where in XBMC? The only ones I can find are v2.0 and v2.9.0, neither of which work...................

Am I missing something?

Add-ons should update automatically from the repositories, unless you have that option disabled. In which, case:
System/Settings > Add-ons > Available updates

Option is not disabled. Everything else is updating fine AFAIK.

(2012-09-29, 18:37)johngalt007 Wrote: [ -> ]I had Dharma XBMCUbunut and a few days ago I noticed that the youtube plug in stopped working (could not extract url error). So, I updated it to Eden XBMCUbuntu from Live CD and the youtube add on still does not work. I have automatic updates enabled and when I go to youtube add on from the Settings, I see that it is at version 2.1.4. I uninstalled it and reinstalled. It is still at 2.1.4. How do I get version 3.2.0? The update button in the addon is disabled.

I also tried installing the patch provided by a kind member here after this plugin broke and they report dependency errors.

This is exactly what is happening to me as well. Eden v11 XBMCbuntu from the Live CD as well. Version 2.1.4 is listed for me alsol. I tried a force refresh of the XBMC.org repo but it still only lists v2.1.4...................update button disabled as well.

Also uninstalled and reinstalled from the patch in this thread and also getting the dependency errors message.

(2012-09-29, 18:37)johngalt007 Wrote: [ -> ]I had Dharma XBMCUbunut and a few days ago I noticed that the youtube plug in stopped working (could not extract url error). So, I updated it to Eden XBMCUbuntu from Live CD and the youtube add on still does not work. I have automatic updates enabled and when I go to youtube add on from the Settings, I see that it is at version 2.1.4. I uninstalled it and reinstalled. It is still at 2.1.4. How do I get version 3.2.0? The update button in the addon is disabled.

I also tried installing the patch provided by a kind member here after this plugin broke and they report dependency errors.

Exactly the same problem here with same error message.

On Dharma - stuck at version 2.1.4.
(2012-10-01, 03:05)ailingcoot Wrote: [ -> ]
(2012-09-30, 17:25)nabsboss Wrote: [ -> ]Hi,

i remove xbmc with profil folder.
I made a fresh install of xbmc in english. I installed youtube only and same issue with utf-8.

also i have this issue on 2 windows plateform (windows 7 home edition 64 and windows ultimate 32).

AAArrrrgggggg i'm going to loose my haire ........

Any idea Huh
I didn't see any problem at all. At least, your XBMC seems fine. Huh
You may wanna ask the developer or people share the same problem as yours.

I did it 4 days ago with a pastbin but no reply Sad
http://code.google.com/p/youtubexbmc/iss...d=46&can=1

Hello
I have a suggestion.
Would it be possible to make it so i can pair the youtube addon whit my xbmc android app, like i can do on http://www.youtube.com/leanback
That would be great!!!

/ koffe
(2012-10-01, 21:27)koffe Wrote: [ -> ]Hello
I have a suggestion.
Would it be possible to make it so i can pair the youtube addon whit my xbmc android app, like i can do on http://www.youtube.com/leanback
That would be great!!!

/ koffe

The xbmc android app adds a "Play on XBMC" option on the share menu which allows you to go to the android youtube app, choose a video and tell it to be played on Android. Doesn't get much better than that Smile
I was having issues with the latest 3.2.0 youtube script with:
18:49:27 T:1907972976 ERROR: Error Type: <type 'exceptions.IndexError'>
18:49:27 T:1907972976 ERROR: Error Contents: string index out of range
and the patch someone posted here worked to solve a lot of my issues:
https://code.google.com/p/youtubexbmc/is...tail?id=47

I'd rather see the developers put out a fixed version but if there's enough interest I'll put out a new packaged zip to get people working again.
(2012-10-01, 22:26)Alethenorio Wrote: [ -> ]
(2012-10-01, 21:27)koffe Wrote: [ -> ]Hello
I have a suggestion.
Would it be possible to make it so i can pair the youtube addon whit my xbmc android app, like i can do on http://www.youtube.com/leanback
That would be great!!!

/ koffe

The xbmc android app adds a "Play on XBMC" option on the share menu which allows you to go to the android youtube app, choose a video and tell it to be played on Android. Doesn't get much better than that Smile

hi.thanks for your quick reply.
I know that the xbmc android app adds a "Play on XBMC" option, I use it allot, but i have had problem whit my xios ds media player whit xbmc linux.
It wont play the youtube files, it worked whit the android version but not the linux. (it works from a computer).
so when i was trying to see if there was something i´ve done wrong, I stumbled "youtube leanback" and i really liked how it worked and i just thought that it maybe could be done whit xbmc.

not a big deal, "Play on XBMC" works really good (when it works).

/koffe
Latest update is working for me, but introduced the age verification issue again. So I took an older YouTubeCore.py version I had from an old backup and now I can watch age restricted videos again.

The 'My watch later' feature seems a little buggy now, but atleast I can watch all videos again. What a mess...
I can only seem to download version 2.9.0. Doesn't give the option to update from within the official XBMC app and I am having a hard time finding a .zip of the 3.1.0 version. Any thoughts?
(2012-10-02, 23:34)dustin782 Wrote: [ -> ]I can only seem to download version 2.9.0. Doesn't give the option to update from within the official XBMC app and I am having a hard time finding a .zip of the 3.1.0 version. Any thoughts?

A few of us are also having this issue................there are zips posted further back in this thread. I tried installing from them but get a "Dependencies Not Met" error message. Find them and give it a try and see if you get the same. Are you running XBMCbuntu with Eden v11??

(2012-10-02, 22:44)Jete246 Wrote: [ -> ]Latest update is working for me, but introduced the age verification issue again. So I took an older YouTubeCore.py version I had from an old backup and now I can watch age restricted videos again.

The 'My watch later' feature seems a little buggy now, but atleast I can watch all videos again. What a mess...

Can you post your YouTubeCore.py so that I can get rid of this problem on 3.2

(2012-10-03, 09:20)timwall Wrote: [ -> ]
(2012-10-02, 22:44)Jete246 Wrote: [ -> ]Latest update is working for me, but introduced the age verification issue again. So I took an older YouTubeCore.py version I had from an old backup and now I can watch age restricted videos again.

The 'My watch later' feature seems a little buggy now, but atleast I can watch all videos again. What a mess...

Can you post your YouTubeCore.py so that I can get rid of this problem on 3.2
Sure, but be warned that it might/probably will break other functions in the plugin:
http://pastebin.com/LGS1ZS1d
Anyone know how to make the presidential debate play Huh?