Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
hi guys!

Youtube plug in is now working after applying dbohdan's fix. However, i am unable to login into youtube using the plugin in xbmc... how do i fix thisHuh
That is still not fixed, this fix just fixes what broke yesterday.
Okay, got a problem...YouTube plugin crashes, and xmbc.log says the problem is in lines 107 and 110 of default.py:

C:\Users\Steve\AppData\Roaming\XBMC\addons\plugin.video.youtube\default.py
...
104 if (not sys.argv[2]):
105 navigation.listMenu()
106 else:
107 params = common.getParameters(sys.argv[2])
108 get = params.get
109 if (get("action")):
110 navigation.executeAction(params)
111 elif (get("path")):
112 navigation.listMenu(params)
113 else:
114 print plugin + " ARGV Nothing done.. verify params " + repr(params)
115
...
Any suggestions?
I am getting the same error using XBMCbuntu with eden. It was working fine up until yesterday. I have done some searching and i tried the fix using the "data = re.findall('="(ttsurl=.*?)"', data change in YouTubePlayer.py however that line isnt in my YouTubePlayer.py file.
I am getting the Script Failed: Plugin.video.youtube error
Log is the same as StrangeCrunchy1
I can confirm that it now works under Ubuntu 11.04 / Linux Mint 12 (Lisa). Repo Version of XBMC.

According to this fix:
http://forum.xbmc.org/showthread.php?tid...pid1279612

In file:
~/.xbmc/addons/script.module.parsedom/lib/CommonFunctions.py

Only change this in line 102:
Code:
<     version = float(version)
---
>     version = float(version.split()[0])


Many many thanks!!
Fixed worked perfectly on Windows 7, using XBMC version 11.0

Thanks for the help!
Yep that worked for me on XBMCBuntu.

Thanks Guys.
Confirmed under Windows 7 64-bit!!! Big Grin Changing line 102 of CommonFunctions.py does indeed restore functionality! I can watch my trailers again! ^_^

Thank you for that link and snippet, binwiederda Smile And a big thanks to the users over at XBMC.org!
Thank you SO much!! I have Windows 7 and if worked perfectly with the following:
-Apply the fix by opening C:\Users\<YourUserName>\AppData\Roaming\XBMC\addons\script.module.parsedom\lib\CommonFunction​s.py with your text editor of choice.
-Once you've done that find line:
version = float(version)
-and change to:
version = float(version.split()[0])
-and save.

Then go back into Youtube add-on and all fixed.

Thank you dbohdan!! Big Grin
Hmmm...I wonder if this works for skins :p
Uh...this post never happened.
Worked on Ubuntu like a charm. Without restarting XMBC.
Thanks, dbohdan!!
Has this been fixed for atv1?
On Windows XP running Frodo RC2, opened CommonFunctions.py and I'm unable to find that line anywhere. Am I doing it wrong?
Fixed for me on Apple TV 2!
(Use Cyberduck to download file, make changes (see Bytemi's post above) and uploaded file back to Apple TV).

On Apple TV you will find the relevant file here:
var/mobile/library/preferences/XBMC/addons/script.module.parsedom/lib/CommonFunction​s.py

Thanks for the solution dbohdan!