Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Most seems to be working for me with latest version and Frodo RC3.

However, my most used feature is not working: Youtube top 100 Music Chart.

Whenever I select it i get a script failed error.

Is this a known issue or shall i post a debug log?

Thanks
script errors all over the place with version 4.x on Frodo RC3.
Did rollback to 3.3.0 and it seems ok now.
Is anyone actually testing releases before they are put into GA? 0.o
(2013-01-09, 13:28)ghizzu Wrote: [ -> ]Try this:
in YouTubeStorage.py find this line:
Code:
return key.encode("utf-8","ignore")
and replace it with this one:
Code:
return key.decode("utf-8").encode("utf-8","ignore")

It should work (don't ask me why)

Nice catch, thanks!
(2013-01-09, 13:28)ghizzu Wrote: [ -> ]
(2013-01-09, 02:44)MadPriest Wrote: [ -> ]this is from a message i posted 3 days ago
noone got the answers?
Code:
19:15:47 T:2750528320   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.UnicodeDecodeError'>
                                            Error Contents: 'ascii' codec can't decode byte 0xd1 in position 7: ordinal not in range(128)
                                            Traceback (most recent call last):
                                              File "/home/igalsc/.xbmc/addons/plugin.video.youtube/default.py", line 111, in <module>
                                                navigation.listMenu(params)
                                              File "/home/igalsc/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 109, in listMenu
                                                return self.list(params)
                                              File "/home/igalsc/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 184, in list
                                                (results, status) = self.storage.list(params)
                                              File "/home/igalsc/.xbmc/addons/plugin.video.youtube/YouTubeStorage.py", line 53, in list
                                                return self.getStoredSearches(params)
                                              File "/home/igalsc/.xbmc/addons/plugin.video.youtube/YouTubeStorage.py", line 112, in getStoredSearches
                                                thumbnail = self.retrieveSettings(params, "thumbnail", item)
                                              File "/home/igalsc/.xbmc/addons/plugin.video.youtube/YouTubeStorage.py", line 476, in retrieveSettings
                                                key = self.getStorageKey(params, type, item)
                                              File "/home/igalsc/.xbmc/addons/plugin.video.youtube/YouTubeStorage.py", line 249, in getStorageKey
                                                return self._getThumbnailStorageKey(params, item)
                                              File "/home/igalsc/.xbmc/addons/plugin.video.youtube/YouTubeStorage.py", line 299, in _getThumbnailStorageKey
                                                return key.encode("utf-8","ignore")
                                            UnicodeDecodeError: 'ascii' codec can't decode byte 0xd1 in position 7: ordinal not in range(128)
                                            -->End of Python script error report<--

Try this:
in YouTubeStorage.py find this line:
Code:
return key.encode("utf-8","ignore")
and replace it with this one:
Code:
return key.decode("utf-8").encode("utf-8","ignore")

It should work (don't ask me why)

Hi,

I had the same problem. I have implemented following lines right after import statements in default.py:

Code:
reload(sys);
sys.setdefaultencoding("utf-8");

This should prevent all this kind of unicode ascii errors in future in all modules. Please implement it in master.
What it does is that it will reload sys module which seems to be loaded with ascii as default encoding even though it will print "utf-8" if you try print(sys.getdefaultencoding()) before this lines. I had the same problem in my plugins and this solved the issue when localizing them without rewriting lots of code.
(2013-01-21, 21:46)martinLB Wrote: [ -> ]
(2013-01-20, 21:23)BillDino Wrote: [ -> ]Apple TV 2 XBMC wont "Play All/Play and Shuffle All" on youtube. Any help? Tried downgrading to 3.3.0 youtube but still no luck. Here is my debug. Thank you!
http://pastebin.com/wEupKUBA

where did you get the 3.3.0 version? i am having the same problem as you but i think i can make it work with a 3.3.0

Any updates?
I can not see any more video and I can not stream music to my xbmc. Any Updates? I have 4.4.1
(2013-01-17, 07:33)nihilist Wrote: [ -> ]
(2013-01-17, 02:35)debennett2 Wrote: [ -> ]I have had this problem in the very recent past (month or two) and just deleted the youtube plugin folder and reinstalled but now reddit, bestofyt, and youtube itself are doing it again:

i already did this, but no effect.

I have the feeling that it stopped working around the time that youtube got its new layout, but i have
no real evidence for that.

Try deleting both plugin folders. I found there are two (at least) for each plugin. I think deleting the one in userdata did the trick. I just tried it and it is back to normal.
Release 4.1.1 on Frodo RC2 suffering the Login False errors again. Checked the referral links it spat out on the PC and forwarded nicely, and I can confirm I do not utilise a 2-step login system

Pastebin: http://pastebin.com/c7QXMeMk
(2013-01-23, 07:29)BillDino Wrote: [ -> ]
(2013-01-21, 21:46)martinLB Wrote: [ -> ]
(2013-01-20, 21:23)BillDino Wrote: [ -> ]Apple TV 2 XBMC wont "Play All/Play and Shuffle All" on youtube. Any help? Tried downgrading to 3.3.0 youtube but still no luck. Here is my debug. Thank you!
http://pastebin.com/wEupKUBA

where did you get the 3.3.0 version? i am having the same problem as you but i think i can make it work with a 3.3.0

Any updates?

nothing man, i cant rollback to 3.3.0 i tried to replace youtubeplaylistcontrol.py on 4.4.1 and doesnt seem to work, it only worked on 3.3.0

can anyone help please?! !!!
(2013-01-15, 19:02)folkg Wrote: [ -> ]Q: Can someone confirm that live YouTube streams don't work? YouTube streams some live sports that I would love to be able to receive through XBMC, but currently the plugin says that the video stream doesn't exist. I have to access the videos through my browser. Is this a known limitation? Or am I missing something important?

Having the same issue right now (just started using XBMC). Regular Youtube vids work, but attempting to watch the League of Legends Championship Qualifiers livestream is failing Undecided Says "couldn't locate video url". Fails both when I click on it using my remote, and use "Send to XBMC" from my browser.

For that matter, the livestreams are not showing up on the user's channel in my subscriptions either.

Attempting to fix myself but drugged up after wisdom teeth extraction (same reason I'm watching it from my couch in the first place heh) so not going so well
Sorry, this addon don't work for me. Every time I click Search, script error is thrown:

http://pastebin.com/1qLhVtfb

I use 3.4.1 version - there is no any newer available in xbmc repository. I use xbmc 11 on Linux (there are no plans to update to 12). So, what's wrong? Some encoding issues?
Is anyone able to help, I am really really new to this, I have installed XBian XBMC and I am trying to display the add-ons as icons rather than just as the text view in the menu.
So for example when I scroll to videos, I would be able to see the YouTube icon and click on the icon instead of scrolling through the text links
I have had a search but cant seem to find what I am looking for, but that may be because I have no idea what exactly it is I should be searching for.
I am running in the default Confluence skin.
I hope someone can help as I am extremely excited about getting this all configured and runningHuh
(2013-01-25, 21:20)giaur Wrote: [ -> ]Sorry, this addon don't work for me. Every time I click Search, script error is thrown:

http://pastebin.com/1qLhVtfb

I use 3.4.1 version - there is no any newer available in xbmc repository. I use xbmc 11 on Linux (there are no plans to update to 12). So, what's wrong? Some encoding issues?

I'm having the same problem, but I'm using 4.4.1. That's what you meant, isn't it?
I'll look on older posts. Maybe there's already a solution...
Just like I thought... look at this post. It's working for me:
http://forum.xbmc.org/showthread.php?tid...pid1292056
Ok, I don't want to go thorough pages to get the answer, but can this plugin work with Googles' 2 step authentication?