Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I can login and see most of my channel , but some channel with "non-english" as channel/user name can't show , Why ?

Anyone know to make xbmc youtube addon to show youtube subscriptions when the channel use "non-english" as channel name ? Example : japanese or chinese ? I am able to subscribe on the web version of youtube , but it woun't show / play on xbmc youtube plugin ? Why and how to Fix it ?

Example :

I have same issue as you. Please refer Post 3133 for details.
Please let me know if you find a solution.
(2013-04-04, 08:45)k4fros Wrote: [ -> ]
(2013-04-03, 22:43)k4fros Wrote: [ -> ]
(2013-04-03, 20:53)adelos Wrote: [ -> ]hi all, just wondering if only a few users have problems with live youtube videos, or it's more wide spread
normal videos work fine but live stations do not work reporting codec error
uninstalled and re installed few times and cleared cache
win 8 12.1 4.4.4

Yeap! My xbmc YT debug log is available here (Linux/12.1/4.4.4)


Btw, is it me or all live station streams that fail contain a '-' in the video id?


False alarm...

It turns out the problem is related to ffmpegs ffh264 codec shipped on XBMC 12.1, reverting back to 12.0 solves it.

(2013-04-04, 18:41)k4fros Wrote: [ -> ]False alarm...

It turns out the problem is related to ffmpegs ffh264 codec shipped on XBMC 12.1, reverting back to 12.0 solves it.


here is what i get in the log right after the utube link
12:52:55 T:3860 ERROR: CDVDPlayer::OpenDemuxStream - Error creating demuxer

i'll revert too after i backup my setup, thanks for the hint
i updated to 12.1 in the same time as the utube site change

EDIT: yep, 12.0 works but i noticed video quality doped in other plugins so i'm going back to 12.1 and i'll use a browser until things workout and i know that is not simple and straight forward all the time.
(2013-03-26, 02:05)Topfjoer Wrote: [ -> ]Just updated to v4.4.4 (on Ubuntu 12.04 with XBMC 12.1). All is well when I search and play videos directly from the addon itself. However, the plugin now often causes XBMC to crash (hangs - becomes unresponsive) when I send a link over the network, for instance using the Yatse Remote or my OS X Dashboard Remote. This especially happens (i.e. most easy to reproduce) when a video is already playing and I then send another link to the plugin, but it also happens when nothing's playing yet.

Is anyone else experiencing similar issues?
Yes. I am seeing the exact same thing and it happens very often. Undecided

Also videos added to the queue (with the Yatse Queue plugin for example) won't play. I've checked that they end up in the Now playing queue (and they do), but playback just stops and the queue is emtied (as far as I can tell).
After much searching I found that disabling IPV6 on my network cards made my computers able to play youtube video's. However, I need IPv6 on my computers.
How can I disable IPv6 for this?

I tried in advancedsettings.xml

(2013-03-27, 02:39)KingsCross Wrote: [ -> ]
(2013-03-26, 19:50)psburley Wrote: [ -> ]You tube plug in been working fine till recently (noticed this week) now when I use the plug in it cant log in to you tube with my user name and password I get a message saying name and password correct but no longer supports log in via user name........ so i cant access all my you tube favorites etc .

I uninstalled the plug in and associated files and re installed no better..

Anyone had this and can help me??


Try logging in with registered youtube email instead of username.
yes, but now it crashes XBMC(after script failed on subscriptions) with git version on gentooHuh
Fatal Python error: ceval: orphan tstate

------ Window Init (DialogBusy.xml) ------
DEBUG: Window DialogBusy.xml was already loaded
DEBUG: Alloc resources: 0.00m
ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                Error Type: <type 'exceptions.AttributeError'>
                Error Contents: StorageServer instance has no attribute 'curs'
                Traceback (most recent call last):
                  File "/home/user/.xbmc/addons/script.common.plugin.cache/default.py", line 40, in <module>
                  File "/home/user/.xbmc/addons/script.common.plugin.cache/default.py", line 35, in run
                  File "/home/user/.xbmc/addons/script.common.plugin.cache/lib/StorageServer.py", line 232, in run
                  File "/home/user/.xbmc/addons/script.common.plugin.cache/lib/StorageServer.py", line 164, in _runCommand
                    res = self._sqlGet(data["table"], data["name"])
                  File "/home/user/.xbmc/addons/script.common.plugin.cache/lib/StorageServer.py", line 428, in _sqlGet
                    for row in self.curs:
                AttributeError: StorageServer instance has no attribute 'curs'
                -->End of Python script error report<--
(2013-04-02, 16:32)MediaPi Wrote: [ -> ]This is my first post. Firstly thankyou for the add on. Me and my family use it everyday and I can't express how much joy we get out of using it. Now I have a question if someone will kindly help me with. When I download a video from youtube add on. I try to add the source to my music Library. But when I try, the directory is empty. But the directory shows when I go through System->File manager->Storage->Music
I'm not sure how to proceed.
bump please can someone spare some time and explain this to me
Source is added at the directory level, so individual files within a folder are not shown when you use the "Add Videos..." option and browse through your file structure to select and add a source.
what code can i use in favorites.xml to set a favorite to open the Youtube addon, so i can set a custom menu to launch the addon from XBMC home screen ?
I have a weird problem that I hope someone can help me with.

I have been using xbmc on windows 7 for several months now and since I upgraded to frodo a little while back I have this issue when using the xbmc addon.

What happens is that I can watch videos fine but every so often I will be watching a youtube videos and for some reason the stream will stop. If I try to continue the stream everything just sits there.

Other investigation I have performed has shown that at the same time the above behaviour occurs I appear to lost connectivity to the internet however I can still access my local network without any problems.

I have not seen this occur with any other addons only the youtube addon, for instance I can stream for hours on end and not see this occur with the twitch or iplayer

I have enabled the debug logging after the 3rd time this happened in 30 minutes and copied it below


A reboot of the entire machine does fix this for a while but it does keep reoccuring.

This one has me a bit stumped so I would appreciate any advice that any one can give me on how to rectify this as it is getting annoying rebooting.
The issue regarding the download feature getting stuck at 'preparing download' is extremely common. It can be fixed by clearing the cache but it will happen again. Are the guys working on the plug-in aware of this and understand why this keeps happening?

I know the thread probably reads like a list of complaints but the app is fantastic and I'm sure we all appreciate the work that all the developers do here. Smile
(2013-04-01, 00:53)wiper2 Wrote: [ -> ]I have problem with YouTube plugin with private playlist. Standalone video from playlist is working fine, but "Reverse Playlist, Play All, Shuffle.." doesn't work. When I chagne playlist status to public everything is ok.

AH! You've actually solved a problem for me. I was coming in to ask why selecting "Context Menu" and then "Play From Here" wasn't working - at all - and I was wondering why. As it turns out, I changed my Playlist to "Public" and now, it plays fine.

Unfortunately, it's certainly not a perfect fix - but it'll do until it's fixed.
Could anyone help me? When I search video items in Youtube addon I don't see preview thumbnails of found videos in search listing. I think listing of all searches.
In the Edens beginning were preview thumbnails there (without "common plugin cache" addon). When common plugin cache installed (automatic) - preview thumbnail change to lens thumbnail (default). I uninstalled "common plugin cache" and previews were display right until restarting PC. After restart PC common plugin cache was installing automatically and preview was lost again.

This problem is in all platfoms (Win, Linux - Fedora, Ubuntu) and from Eden (with common plugin cache) to Frodo

I use XBMCbuntu with default skin (Confluence) and XBMC on Windows 7 with same skin .

Sorry for my English.
I hope that you understand my English.

Than you for your help.
Sorry if this has been posted before, but I have a problem and my youtube doesn't play my private videos. It says it cannot locate URL. Any solution?