Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hinz

HenrikDK Wrote:Hmm, I can understand the confusion that might create, but im not really fond of adding another "xbmc legacy" context menu item as the menu's all ready quite full Sad.

Well, I'm not talking about a full context menu. Just "Now playing", and it apears everywhere else in the plugin but those two places. At least add "Now playing" on video files. Otherwise it's: Queue a couple files...play queue? Ah go up to .. or go back in the tree to find a place that has Now Playing.
Hinz Wrote:Well, I'm not talking about a full context menu. Just "Now playing", and it apears everywhere else in the plugin but those two places. At least add "Now playing" on video files. Otherwise it's: Queue a couple files...play queue? Ah go up to .. or go back in the tree to find a place that has Now Playing.
The context menu for video items, is already the one with the most options, and it's quickly becoming unwieldy. so I wanted to avoid adding more "legacy" xbmc functions that are otherwise available through the "standard" xbmc remote keymaps. But for now I've added it to all context menu's in the plugin, if in the future we are in need of more space on the context menu, I might remove the option again (the same goes for the queue, and video info buttons).
HenrikDK Wrote:Have you tried playing other web streams og web sourced content from within xbmc?

You could also try removing as many layers between xbmc and your internet router as possible.. I can't really imagine that it's not related to some network or system configuration problem as the error came from within xbmc player core. Could you also try enabling debug in xbmc's settings and uploading a new log?, maybe that will help specify the error Huh. Also remember to update to the latest beta.. Smile

Yes there seems to be an issue with the xbmc dvdplayer. dunno why though. Here's a log when trying to play a clip with the youtube addon which ends in playback failure -> http://pastebin.com/iatDq5iq

Here's a log when playing a youtube clip that's been downloaded with the addon. I downloaded the clip to my downloaded folder, exited the addon and played the clip as I would normally play a movie. -> http://pastebin.com/kJAQhDTL
The weird thing is that this method actually works, the downloaded clip plays fine! though i would like to be able to stream videos directly from the addon.

I should mention that I did a fresh ubuntu 10.04 installation and I'm currently on dharma beta4 and using the latest youtube 1.9.3 addon.
My computer is an asrock ion330.
plumser Wrote:Yes there seems to be an issue with the xbmc dvdplayer. dunno why though. Here's a log when trying to play a clip with the youtube addon which ends in playback failure -> http://pastebin.com/iatDq5iq

Here's a log when playing a youtube clip that's been downloaded with the addon. I downloaded the clip to my downloaded folder, exited the addon and played the clip as I would normally play a movie. -> http://pastebin.com/kJAQhDTL
The weird thing is that this method actually works, the downloaded clip plays fine! though i would like to be able to stream videos directly from the addon.

I should mention that I did a fresh ubuntu 10.04 installation and I'm currently on dharma beta4 and using the latest youtube 1.9.3 addon.
My computer is an asrock ion330.

Well that log file wasn't really that much more usefull Sad It's still a curl error:

Code:
09:54:40 T:2745166704 M:1523929088 WARNING: FillBuffer: curl failed with code 28
09:54:40 T:2745166704 M:1523929088   ERROR: CFileCurl::CReadState::Open, didn't get any data from stream.
a quick search on the interwebs reveals that code 28 is a timeout.. No reason given why though :|. Did you try plugin you isp's network connection directly into your xbmc box?

The reason why you can use the download option is that we don't go through xbmc's core to provide that functionality, instead we establish the connection from python and just dump the filestream to disk.
Thx for the quick reply!
i've been fiddling with curl for about an hour with no results. I also tried putting the xbmc machine in a demilitarized zone on the router which should put the router out of the equation.
i still get the problem with curl timing out..
HenrikDK Wrote:Hi, it's pretty hard to tell what's wrong without a debug log (remember to enable debug in the plugin settings) Wink

Of course, I thought there might be known issues.

Here is my log: http://pastebin.com/XFzj0q0W
(login attempt is right in the end)


Might this (see below) be the problem? I am running openelec 4432, might there be a problem with the SSL implementation?

Btw, love your plugin. Smile

Thanks in advance!

Code:
12:39:26 T:2836290416 M:1943486464  NOTICE: ERROR: YouTubeCore::login (98) - <urlopen error unknown url type: https>
12:39:26 T:2836290416 M:1943486464  NOTICE: CLASS:
12:39:26 T:2836290416 M:1943486464  NOTICE: URLError
12:39:26 T:2836290416 M:1943486464  NOTICE: ID:
12:39:26 T:2836290416 M:1943486464  NOTICE: 160779300
12:39:26 T:2836290416 M:1943486464  NOTICE: TYPE:
12:39:26 T:2836290416 M:1943486464  NOTICE: <class 'urllib2.URLError'>
12:39:26 T:2836290416 M:1943486464  NOTICE: VALUE:
12:39:26 T:2836290416 M:1943486464  NOTICE: URLError('unknown url type: https',)
12:39:26 T:2836290416 M:1943486464  NOTICE: CALLABLE:
12:39:26 T:2836290416 M:1943486464  NOTICE: No
12:39:26 T:2836290416 M:1943486464  NOTICE: None
12:39:26 T:2836290416 M:1943486464  NOTICE: YouTube-1.9.3 login pre sleep
12:39:29 T:2836290416 M:1943490560  NOTICE: YouTube-1.9.3 login post sleep
12:39:29 T:2836290416 M:1943490560  NOTICE: YouTube-1.9.3 login - errors: 5
12:39:29 T:2836290416 M:1943490560  NOTICE: YouTube-1.9.3 login failed, hit ioerror except2: : URLError('unknown url type: https',)
counter Wrote:Of course, I thought there might be known issues.

Here is my log: http://pastebin.com/XFzj0q0W
(login attempt is right in the end)


Might this (see below) be the problem? I am running openelec 4432, might there be a problem with the SSL implementation?

Btw, love your plugin. Smile

Thanks in advance!

Code:
12:39:26 T:2836290416 M:1943486464  NOTICE: ERROR: YouTubeCore::login (98) - <urlopen error unknown url type: https>
12:39:26 T:2836290416 M:1943486464  NOTICE: CLASS:
12:39:26 T:2836290416 M:1943486464  NOTICE: URLError
12:39:26 T:2836290416 M:1943486464  NOTICE: ID:
12:39:26 T:2836290416 M:1943486464  NOTICE: 160779300
12:39:26 T:2836290416 M:1943486464  NOTICE: TYPE:
12:39:26 T:2836290416 M:1943486464  NOTICE: <class 'urllib2.URLError'>
12:39:26 T:2836290416 M:1943486464  NOTICE: VALUE:
12:39:26 T:2836290416 M:1943486464  NOTICE: URLError('unknown url type: https',)
12:39:26 T:2836290416 M:1943486464  NOTICE: CALLABLE:
12:39:26 T:2836290416 M:1943486464  NOTICE: No
12:39:26 T:2836290416 M:1943486464  NOTICE: None
12:39:26 T:2836290416 M:1943486464  NOTICE: YouTube-1.9.3 login pre sleep
12:39:29 T:2836290416 M:1943490560  NOTICE: YouTube-1.9.3 login post sleep
12:39:29 T:2836290416 M:1943490560  NOTICE: YouTube-1.9.3 login - errors: 5
12:39:29 T:2836290416 M:1943490560  NOTICE: YouTube-1.9.3 login failed, hit ioerror except2: : URLError('unknown url type: https',)

Certainly seems to be a problem with the build of xbmc: "Reason: SSL is not supported in Python installation."
http://www.xinotes.org/notes/note/628/

Think you need to raise this with the openelec.tv guys since theres nothing we can do from our end, youtube requires SSL to do authentication Sad (we wouldn't want passwords sent over clear text. Nerd).

=============== EDIT ==============
Ok just read up on their distribution, seems they do a very compact installation of xbmc, so it's not unlikely that they removed the ssl compile directive from their xbmc builds to save on space.. I would say its highly likely they can fix it.
HenrikDK Wrote:Certainly seems to be a problem with the build of xbmc: "Reason: SSL is not supported in Python installation."
http://www.xinotes.org/notes/note/628/

Think you need to raise this with the openelec.tv guys since theres nothing we can do from our end, youtube requires SSL to do authentication Sad (we wouldn't want passwords sent over clear text. Nerd).

=============== EDIT ==============
Ok just read up on their distribution, seems they do a very compact installation of xbmc, so it's not unlikely that they removed the ssl compile directive from their xbmc builds to save on space.. I would say its highly likely they can fix it.

Thanks you, that was what I suspected. Keep up the good work!
Hi counter,

counter Wrote:Thanks you, that was what I suspected. Keep up the good work!

have fixed this this night, was an issue with our python build. for testing use this image:

http://sources.openelec.tv/tmp/image/Ope...80.tar.bz2

cowbalt has already tested this, and it seems to work now :-) if you need help ask me in #openelec IRC channel
openelec.tv Wrote:have fixed this this night

Man, you are quick! Will test it tonight, probably late. Will let you know the results.

Many Thanks!
openelec.tv Wrote:have fixed this this night, was an issue with our python build. for testing use this image:

http://sources.openelec.tv/tmp/image/Ope...80.tar.bz2

Works perfectly, good job! Smile

Cheers,
counter
Hi. About the YouTube plugin: How can you queue and play all videos on a YouTube Playlist? I imagine making a playlist of cool music videos that I can just set to play using this plugin, but this doesn't seem to work like I expected.
Is it possible right now? If not, can this feature be implemented? I mean, it'd be really cool to play entire youtube playlists from XBMC, right?
Thanks, Artur
ameinild Wrote:Hi. About the YouTube plugin: How can you queue and play all videos on a YouTube Playlist? I imagine making a playlist of cool music videos that I can just set to play using this plugin, but this doesn't seem to work like I expected.
Is it possible right now? If not, can this feature be implemented? I mean, it'd be really cool to play entire youtube playlists from XBMC, right?
Thanks, Artur

It "can" be done, but its kinda cumbersome, playlist should have a queue folder option, if you first play a video and then queue the folder, xbmc should continue playing. I agree that this is an inadequate solution, but it's all thats available with the current plugin interfaces Sad. We will probably create a couple of trac tickets to see if we can't get some dev's to help out expanding the functionality of xbmc in this area, as we have more some ideas for youtube playlist manipulation that are impossible with the current plugin api.
Thanks Henrik, I will try that out... Smile But yeah, a better implementation would be cool, where you can also shuffle the playlist like on YouTube (which I guess you can't do now?)...
ameinild Wrote:Thanks Henrik, I will try that out... Smile But yeah, a better implementation would be cool, where you can also shuffle the playlist like on YouTube (which I guess you can't do now?)...

That is possible but again it's kind of cumbersome, you first need to create a playlist using the method i mentioned in the previous post, and then press the button on your remote that allows you to view the playlist, then access the menu (in confluence its located to the left) and enable the shuffle option..

Again not a very pretty solution.. Sad