Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Help me, I haven't been able to download anything for months now. Here's my pastebin log: http://pastebin.com/KuQRbwHR

I also made a Reddit post: http://www.reddit.com/r/xbmc/comments/1q..._download/

I'm just stuck at Preparing Download. Thanks in advance!
It would be good to share my experience in the hope that someone else had the same issue, and, hopefully can help me FIX it.

After installing SuperRepo, I noticed the version of Youtube plugin changed from 4.4.6 to 4.4.6nu3, and I was not able to loginto MyYoutube channels any longer, giving me some fears of phishing, furthermore some russian text appeared

I tried re-installing the Youtube plugin again, removing SuperRepo, without any luck.
As I also have XBMC running on Windows, I finally copied all the files within plugin.youtube folder under Windows, into Android

That worked. I managed to loginto my Youtube account and the version of the plugin was 4.4.6

Half hour later I turned the power off the box and started it again, due to hanging of the box.
The result was that XBMC was not booting any longer - Black screen.
After cleaning the cache files of the XBMC APP in android Youtube is now back to version 4.4.6nu3 and I am not able to login

Any thoughts on how to fix this going forward?
Hello, XBMC is SUPER Media Center software, but i have problem login to youtube acount with YouTube plugin now.

I tested this practise...
http://forum.xbmc.org/showthread.php?pid...pid1550122
... but do not work correctly for me :-(

I tested my [email protected] , but do not work correctly for me :-(
I tested my standart google login accout, but do not work correctly for me :-(

xbmc.log here...
http://pastebin.com/rKHWqFJV

Help me ??
Some Idea ??

Best regards, Josef
I have not been able to log in since Youtube changed their commenting engine to use Google Plus commenting. Here is the error from the log. I've tracked that the two-factor authentication step-2 form has been changed, and the plugin is no longer able to submit the form, but I don't know how to fix it. Any suggestions?

By the way, I deleted the cookiejar file before attempting to login so that the debug log would have a clean slate to work with.

Code:
09:12:35 T:2823506752  NOTICE: [YouTube-4.4.6] authorize : 'token not refresh, or new uname or password'
09:12:35 T:2823506752  NOTICE: [YouTube-4.4.6] _httpLogin : ''
09:12:35 T:2823506752  NOTICE: [YouTube-4.4.6] _httpLogin : 'Step : 0'
09:12:35 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'called for : {'link': 'http://www.youtube.com/'}'
09:12:35 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'got default: http://www.youtube.com/'
09:12:35 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'connecting to server... http://www.youtube.com/'
09:12:36 T:3008689984   DEBUG: SECTION:UnloadDelayed(DLL: special://xbmcbin/system/ImageLib-i486-linux.so)
09:12:36 T:3008689984   DEBUG: Unloading: ImageLib-i486-linux.so
09:12:36 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'done'
09:12:36 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : ''
09:12:36 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : '1'
09:12:36 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : '2'
09:12:37 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : '4'
09:12:37 T:2823506752  NOTICE: [YouTube-4.4.6] _httpLogin : 'Part A : {'referer': 'http://www.youtube.com/', 'link': u'https://accounts.google.com/ServiceLogin?passive=true&service=youtube&uilel=3&hl=en&continue=https%3A%2F%2Fwww.youtube.com%2Fsignin%3Faction_handle_signin%3Dtrue%26app%3Ddesktop%26feature%3Dsign_in_button%26hl%3Den%26next%3D%252F'}'
09:12:37 T:2823506752  NOTICE: [YouTube-4.4.6] _httpLogin : 'Step : 1'
09:12:37 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'called for : {'referer': 'http://www.youtube.com/', 'link': u'https://accounts.google.com/ServiceLogin?passive=true&service=youtube&uilel=3&hl=en&continue=https%3A%2F%2Fwww.youtube.com%2Fsignin%3Faction_handle_signin%3Dtrue%26app%3Ddesktop%26feature%3Dsign_in_button%26hl%3Den%26next%3D%252F'}'
09:12:37 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'got default: https://accounts.google.com/ServiceLogin?passive=true&service=youtube&uilel=3&hl=en&continue=https%3A%2F%2Fwww.youtube.com%2Fsignin%3Faction_handle_signin%3Dtrue%26app%3Ddesktop%26feature%3Dsign_in_button%26hl%3Den%26next%3D%252F'
09:12:37 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'Added referer: http://www.youtube.com/'
09:12:37 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'connecting to server... https://accounts.google.com/ServiceLogin?passive=true&service=youtube&uilel=3&hl=en&continue=https%3A%2F%2Fwww.youtube.com%2Fsignin%3Faction_handle_signin%3Dtrue%26app%3Ddesktop%26feature%3Dsign_in_button%26hl%3Den%26next%3D%252F'
09:12:39 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'done'
09:12:39 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : ''
09:12:39 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : '1'
09:12:39 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : '2'
09:12:39 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : '4'
09:12:39 T:2823506752  NOTICE: [YouTube-4.4.6] _fillLoginInfo : ''
09:12:39 T:2794453824   DEBUG: Thread Jobworker 2794453824 terminating (autodelete)
09:12:39 T:2831899456   DEBUG: Thread Jobworker 2831899456 terminating (autodelete)
09:12:40 T:2823506752  NOTICE: [YouTube-4.4.6] _fillLoginInfo : 'Extracted url_data: {u'PersistentCookie': u'yes', u'rmShown': u'1', u'dnConn': u'', u'pstMsg': u'0', u'service': u'youtube', u'GALX': u'34_O0DqO8Ds', u'signIn': u'Sign in', u'continue': u'https://www.youtube.com/signin?action_handle_signin=true&app=desktop&feature=sign_in_button&hl=en&next=%2F', u'hl': u'en', u'checkedDomains': u'youtube', u'bgresponse': u'js_disabled', u'_utf8': u'☃', u'Email': u'', u'checkConnection': u''}'
09:12:40 T:2823506752  NOTICE: [YouTube-4.4.6] _fillLoginInfo : 'Done'
09:12:40 T:2823506752  NOTICE: [YouTube-4.4.6] _httpLogin : 'Part B'
09:12:40 T:2823506752  NOTICE: [YouTube-4.4.6] _httpLogin : 'Step : 2'
09:12:40 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'called for : {'referer': u'https://accounts.google.com/ServiceLogin?passive=true&service=youtube&uilel=3&hl=en&continue=https%3A%2F%2Fwww.youtube.com%2Fsignin%3Faction_handle_signin%3Dtrue%26app%3Ddesktop%26feature%3Dsign_in_button%26hl%3Den%26next%3D%252F', 'hidden': 'true', 'link': u'https://accounts.google.com/ServiceLoginAuth', 'url_data': {u'PersistentCookie': u'yes', u'rmShown': u'1', u'dnConn': u'', u'pstMsg': u'0', u'service': u'youtube', 'Passwd': '[~~~ PASSWORD MASKED ~~~]', u'GALX': u'34_O0DqO8Ds', u'signIn': u'Sign in', u'continue': u'https://www.youtube.com/signin?action_handle_signin=true&app=desktop&feature=sign_in_button&hl=en&next=%2F', u'hl': u'en', u'checkedDomains': u'youtube', u'bgresponse': u'js_disabled', u'_utf8': u'☃', u'Email': '[~~~ USERNAME MASKED ~~~]', u'checkConnection': u''}}'
09:12:40 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'Added referer: https://accounts.google.com/ServiceLogin?passive=true&service=youtube&uilel=3&hl=en&continue=https%3A%2F%2Fwww.youtube.com%2Fsignin%3Faction_handle_signin%3Dtrue%26app%3Ddesktop%26feature%3Dsign_in_button%26hl%3Den%26next%3D%252F'
09:12:40 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'connecting to server... https://accounts.google.com/ServiceLoginAuth'
09:12:41 T:2823506752  NOTICE: [YouTube-4.4.6] _fetchPage : 'done'
09:12:41 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : ''
09:12:41 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : '1'
09:12:41 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : '2'
09:12:41 T:2823506752  NOTICE: [YouTube-4.4.6] _findErrors : '4'
09:12:41 T:2823506752  NOTICE: [YouTube-4.4.6] _fillUserPin : ''
09:12:41 T:2823506752  NOTICE: [YouTube-4.4.6] _fillUserPin : 'url_data: []'
09:12:41 T:3008689984    INFO: Loading skin file: DialogNumeric.xml, load type: KEEP_IN_MEMORY
09:12:41 T:3008689984   DEBUG: Load DialogNumeric.xml: 178.60ms
09:12:41 T:3008689984   DEBUG: Alloc resources: 260.06ms  (178.98 ms skin load)
09:12:41 T:3008689984   DEBUG: ------ Window Init (DialogNumeric.xml) ------
09:12:41 T:3008689984   DEBUG: Window DialogNumeric.xml was already loaded
09:12:41 T:3008689984   DEBUG: Alloc resources: 0.01m
09:12:41 T:3008689984   DEBUG: CAnnouncementManager - Announcement: OnInputRequested from xbmc
09:12:41 T:3008689984   DEBUG: GOT ANNOUNCEMENT, type: 128, from xbmc, message OnInputRequested
09:12:45 T:2941377344   DEBUG: Suspended the Sink
09:12:53 T:2941377344    INFO: CAESinkALSA::Initialize - Attempting to open device "iec958:CARD=Intel,DEV=0,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00"
09:12:53 T:2941377344    INFO: CAESinkALSA::Initialize - Opened device "iec958:CARD=Intel,DEV=0,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00"
09:12:53 T:2941377344   DEBUG: CAESinkALSA::InitializeHW - Request: periodSize 2048, bufferSize 8192
09:12:53 T:2941377344   DEBUG: CAESinkALSA::InitializeHW - Got: periodSize 2048, bufferSize 8192
09:12:53 T:2941377344   DEBUG: CAESinkALSA::InitializeHW - Setting timeout to 186 ms
09:12:53 T:2941377344   DEBUG: Resumed the Sink
09:13:04 T:3008689984   DEBUG: ------ Window Deinit (DialogNumeric.xml) ------
09:13:04 T:3008689984   DEBUG: CAnnouncementManager - Announcement: OnInputFinished from xbmc
09:13:04 T:3008689984   DEBUG: GOT ANNOUNCEMENT, type: 128, from xbmc, message OnInputFinished
09:13:04 T:2823506752  NOTICE: [YouTube-4.4.6] _fillUserPin : 'Done: {'smsUserPin': '716107'}'
09:13:04 T:2823506752   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.IndexError'>
                                            Error Contents: list index out of range
                                            Traceback (most recent call last):
                                              File "/home/atv/.xbmc/addons/plugin.video.youtube/default.py", line 120, in <module>
                                                navigation.executeAction(params)
                                              File "/home/atv/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 122, in executeAction
                                                self.login.login(params)
                                              File "/home/atv/.xbmc/addons/plugin.video.youtube/YouTubeLogin.py", line 75, in login
                                                result, status = self.authorize()
                                              File "/home/atv/.xbmc/addons/plugin.video.youtube/YouTubeLogin.py", line 85, in authorize
                                                (result, status) = self._httpLogin({"new": "true"})
                                              File "/home/atv/.xbmc/addons/plugin.video.youtube/YouTubeLogin.py", line 239, in _httpLogin
                                                fetch_options = {"link": new_part[0].replace("&amp;", "&"), "url_data": url_data, "referer": ret["location"]}
                                            IndexError: list index out of range
                                            -->End of Python script error report<--
09:13:04 T:3008689984   DEBUG: ------ Window Init (DialogKaiToast.xml) ------
(2013-11-14, 07:30)Kr0nZ Wrote: [ -> ]If anyone is still having problems getting this addon to work with g+, you just need to update your username.
When you moved to a g+ account, google changed the username you need.

I made this infograph on how to find it, its just listed on your google account settings page

http://i.imgur.com/vVRFyCg.png

you might also need to delete the settings.xml file in ".xbmc/userdata/addon_data/plugin.video.youtube",
which I needed to do because the cookie info is saved here so it wont log you in with the new email untill it expires
Thanks for the explanation. Unfortunately I just found out that this feature is not available for everyone. According to Google it does not work with Google Apps accounts (me) and people under 18.

Will the plugin ever have the same function as the YT app on iOS (probably Android as well), where you can select your account when signing in with Google? The plugin has implemented 2-factor authentication (very cool!), so I imagine that this advanced feature might be on the horizon as well. Otherwise I'll just have to resort to mirroring my subscriptions on my main Google account
I've been having issues since the google+ comments update, but I think my logs differ a bit. I'm also using a Google apps account, so I cannot follow instructions to get my "legacy" username/password. It successfully logs in, but subscriptions, history, and watch later always return zero results. Suggestions and searching videos work fine. The log below is what happens when I select my subscriptions.

Code:
20:06:48 T:3001023296  NOTICE: Thread XBPyThread start, auto delete: false
20:06:48 T:3001023296  NOTICE: -->Python Interpreter Initialized<--
20:06:48 T:3001023296  NOTICE: Loading cookies from :'/home/fluffy/.xbmc/userdata/addon_data/plugin.video.youtube/yt-cookiejar.txt'
20:06:48 T:3001023296  NOTICE: YouTube-4.4.6
20:06:48 T:3001023296  NOTICE: CommonFunctions-2.5.1
20:06:49 T:3078412608   ERROR: GetDirectory - Error getting plugin://plugin.video.youtube/?folder=true&login=true&path=%2froot%2fsubscriptions&user_feed=subscriptions
20:06:49 T:3078412608   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/?folder=true&login=true&path=%2froot%2fsubscriptions&user_feed=subscriptions) failed
20:06:49 T:3001023296  NOTICE: Thread XBPyThread start, auto delete: false
20:06:49 T:3001023296  NOTICE: -->Python Interpreter Initialized<--
20:06:49 T:3001023296  NOTICE: Loading cookies from :'/home/fluffy/.xbmc/userdata/addon_data/plugin.video.youtube/yt-cookiejar.txt'
20:06:49 T:3001023296  NOTICE: YouTube-4.4.6
20:06:49 T:3001023296  NOTICE: CommonFunctions-2.5.1
20:06:49 T:2975845184  NOTICE: Thread Background Loader start, auto delete: false
20:06:49 T:3078412608   ERROR: ClearBlock: Trying to clear non existent block /home/fluffy/.xbmc/addons/screensaver.xbmc.slideshow
Login issues with non-ASCII characters?
followed this guide here: http://code.google.com/p/youtubexbmc/wik...oginIssues

YouTube-4.4.6, from official repository
XBMC (12.2 Git:unknown), Platform: Windows 7 SP1 64-bit, build 7601. Built on May 20 2013 (compiler 1600)

The error message:
Code:
07:35:04 T:4624   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
     - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
    Error Type: <type 'exceptions.UnicodeEncodeError'>
    Error Contents: 'ascii' codec can't encode characters in position 12-13: ordinal not in range(128)
    Traceback (most recent call last):
      File "C:\Users\Gordon\AppData\Roaming\XBMC\addons\plugin.video.youtube\default.py", line 120, in <module>
        navigation.executeAction(params)
      File "C:\Users\Gordon\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeNavigation.py", line 122, in executeAction
        self.login.login(params)
      File "C:\Users\Gordon\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeLogin.py", line 75, in login
        result, status = self.authorize()
      File "C:\Users\Gordon\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeLogin.py", line 85, in authorize
        (result, status) = self._httpLogin({"new": "true"})
      File "C:\Users\Gordon\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeLogin.py", line 183, in _httpLogin
        ret = self.core._fetchPage(fetch_options)
      File "C:\Users\Gordon\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeCore.py", line 400, in _fetchPage
        request = urllib2.Request(link, urllib.urlencode(get("url_data")))
      File "C:\MyPrograms\Media\Players\XBMC\system\python\Lib\urllib.py", line 1269, in urlencode
        v = quote_plus(str(v))
    UnicodeEncodeError: 'ascii' codec can't encode characters in position 12-13: ordinal not in range(128)
    -->End of Python script error report<--
I'm logging in using my google account email address as user name (checked login and pw was correct using browser). I checked that the "username" "user_password" values in settings.xml was identical to my login (email) and password. In my email address the 12-13 character seems to be the @ (at) character. I also tried logging in using my YouTube user name in my web browser, which returned a message saying that logging in using YouTube user names has been removed/disabled, so that is no longer an option.

Full log: http://xbmclogs.com/show.php?id=89948
(I censored the login and password by scrambling/replacing the alphanumeric characters, keeping any special characters in the same position)
(2013-11-25, 03:13)watermark Wrote: [ -> ]I've been having issues since the google+ comments update, but I think my logs differ a bit. I'm also using a Google apps account, so I cannot follow instructions to get my "legacy" username/password. It successfully logs in, but subscriptions, history, and watch later always return zero results. Suggestions and searching videos work fine. The log below is what happens when I select my subscriptions.

Code:
20:06:48 T:3001023296  NOTICE: Thread XBPyThread start, auto delete: false
20:06:48 T:3001023296  NOTICE: -->Python Interpreter Initialized<--
20:06:48 T:3001023296  NOTICE: Loading cookies from :'/home/fluffy/.xbmc/userdata/addon_data/plugin.video.youtube/yt-cookiejar.txt'
20:06:48 T:3001023296  NOTICE: YouTube-4.4.6
20:06:48 T:3001023296  NOTICE: CommonFunctions-2.5.1
20:06:49 T:3078412608   ERROR: GetDirectory - Error getting plugin://plugin.video.youtube/?folder=true&login=true&path=%2froot%2fsubscriptions&user_feed=subscriptions
20:06:49 T:3078412608   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/?folder=true&login=true&path=%2froot%2fsubscriptions&user_feed=subscriptions) failed
20:06:49 T:3001023296  NOTICE: Thread XBPyThread start, auto delete: false
20:06:49 T:3001023296  NOTICE: -->Python Interpreter Initialized<--
20:06:49 T:3001023296  NOTICE: Loading cookies from :'/home/fluffy/.xbmc/userdata/addon_data/plugin.video.youtube/yt-cookiejar.txt'
20:06:49 T:3001023296  NOTICE: YouTube-4.4.6
20:06:49 T:3001023296  NOTICE: CommonFunctions-2.5.1
20:06:49 T:2975845184  NOTICE: Thread Background Loader start, auto delete: false
20:06:49 T:3078412608   ERROR: ClearBlock: Trying to clear non existent block /home/fluffy/.xbmc/addons/screensaver.xbmc.slideshow

I'm having the exact same issue
(2013-10-22, 05:35)quaternio Wrote: [ -> ]I found a solution for my inability to login to Youtube through the plugin (and boy, was it a pain!). This is for people who have already attached their Youtube account to a Google+ ACCOUNT (as opposed to a Google+ page). Basically, we will be detaching your YT account from your G+ account, and then we will reattach said YT account to a G+ page. Thanks to taliz's post, which helped me deduce what was necessary for this fix.

If you are sure that your YT is not associated with a G+ account, my solution probably won't help you (unless maybe if you choose to create a G+ account, then create a page to associate with your YT account). If you are sure that your YT account is already associated with a G+ PAGE, just skip to step #8 and this should work for you.

This solution will not require deleting your G+ account or any pages already associated with it. Warning: after 14 days, your YT account will be permanently associated with said page (or so the warning dialog claims after doing this).

1) Login to Youtube on a web browser.
2) Click your account in the top right area, then select "Youtube settings" under the YouTube column.
3) In overview, select Advanced (or go to youtube.com/account_advanced)
4) Here, there should be an option to disconnect your channel from your Google+ account, click that and click okay/accept on the next page.
5) Go back to youtube.com/account_advanced as described before.
6) Click the button that says "Connect with a Google+ Page"
7) Choose an existing page or create a new page (DO NOT associate it with your ACCOUNT; and remember, this may be permanent, so choose a page name with which you will be happy)
*At this point, you should be given a login name with a format like <page-name><unique#>@pages.plusgoogle.com ; if not, you should receive it in an email. You will need this to login to Youtube XBMC plugin.
**From here, you have to add a password to your new page-associated version of your channel. I did the following:
8) Go to Google+ (plus.google.com)
9) In the dashboard (hover over Home), select "Pages" and choose "Manage this Page" for the page that you associated with your YT account.
10) Choose "Settings" in the bar at the top of the webpage
11) Scroll down and in the "Third Party Tools" category, click "Set up a password"
12) Create a password
13) Finally, use your <page-name><unique#>@pages.plusgoogle.com and newly created password as your login credentials in the YouTube XBMC plugin (replacing "<page-name><unique#>" with your unique login)

I hope this helps those who have yet to find a solution.

On step 4 "disconnect your channel from your Google+ account" I can't see any disconnect button.

All I got is :

Password
Account information
Delete channel
Youtube 4.4.6 for XBMC not working, I tried with three intel machines, with windows and linux. I just wish they would provide the previous versions to install. Some older versions were working like a charm, now it's broken. They keep pumping updates but as far as I can see all they do is inject more bugs into an app that was just working.

And no, it's not just a google plus page issue, on windows I can connect to my account but I cannot play any video, on linux I just can't connect even with a brand new account that is not linked in any way to another main account.
Interestingly, its now working in the latest nightly on Android.

The same may apply to other platforms....
(2013-11-14, 07:30)Kr0nZ Wrote: [ -> ]If anyone is still having problems getting this addon to work with g+, you just need to update your username.
When you moved to a g+ account, google changed the username you need.

I made this infograph on how to find it, its just listed on your google account settings page

http://i.imgur.com/vVRFyCg.png
Image

you might also need to delete the settings.xml file in ".xbmc/userdata/addon_data/plugin.video.youtube",
which I needed to do because the cookie info is saved here so it wont log you in with the new email untill it expires

Anyone coming to this thread looking for a solution to login issues should definitely try kr0nZ' solution. Worked perfectly for me, and now I don't need to keep fighting google's desire to join my youtube and google+ account. Thanks so much for the advice Kr0nz.
Unfortunately I don't see anything like that in my Google+ settings. No matter what I do (connect or disconnect youtube and google+) I can't get the plugin to work (2xOpenelec, 1x Windows)
(2013-12-01, 09:16)kiboy6 Wrote: [ -> ]
(2013-11-14, 07:30)Kr0nZ Wrote: [ -> ]If anyone is still having problems getting this addon to work with g+, you just need to update your username.
When you moved to a g+ account, google changed the username you need.

I made this infograph on how to find it, its just listed on your google account settings page

http://i.imgur.com/vVRFyCg.png
Image

you might also need to delete the settings.xml file in ".xbmc/userdata/addon_data/plugin.video.youtube",
which I needed to do because the cookie info is saved here so it wont log you in with the new email untill it expires

Anyone coming to this thread looking for a solution to login issues should definitely try kr0nZ' solution. Worked perfectly for me, and now I don't need to keep fighting google's desire to join my youtube and google+ account. Thanks so much for the advice Kr0nz.

What platform did it work for you ?
I have a google apps account and I solved my problems. Kr0nZ solution didn't work because things must be different for apps accounts (The "third-party tools" section isn't there).

Background:
I have a google apps account and had an old youtube username linked to it. I've been using this username for years, even in xbmc. It stopped working after the google+ comments update. The subscriptions/history/watchlater always returned zero results.

Solution:
I evidently have two youtube accounts now. One that was my old username and another that was my apps email address. It seems I have to use the apps email account now. You can switch between the accounts in the top right, next to the settings link is the "switch account" link. Most of my subscriptions imported from my other account, but it didn't get all of them for some reason.

This is also why it was returning zero results in the subscriptions/history/watchlater. It was pulling from this second account I didn't know I had. It doesn't import from the other account until you use it from the youtube website for the first time.