Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
You know, instead of loging in at all, wouldn't it be better if this addon could pull as this pulls http://daviddeutsch.github.io/yt-sanegrid/ no login needed at all.
So, if I just wanted to save the occasional YouTube video to my hard drive, would something like this be more bother than it is worth? It sounds like some of these bugs are driving people crazy.

I'm on the slowest DSL option. I'd like to be able to download and save files from YouTube that I know I will be wanting to play again. I was trying to get Java installed in Chrome, but I was told by "nickr" that I should use this instead.

Is this what I want?
If you want to login and access your subs etc, then stay away, jp2code. It is broken.
hi guys I have latest release of gotham xmbc.. installed youtube from addons and could not login to my account as I was getting "remote connection failed" all the time.
I found in this tread that there is a new release which is fixing it but I still have issues to login to youtube.

Normal clips are working via "explore youtube" but not my subscription list.

What I'm doing wrong ?
(2014-04-21, 01:25)macmus Wrote: [ -> ]hi guys I have latest release of gotham xmbc.. installed youtube from addons and could not login to my account as I was getting "remote connection failed" all the time.
I found in this tread that there is a new release which is fixing it but I still have issues to login to youtube.

Normal clips are working via "explore youtube" but not my subscription list.

What I'm doing wrong ?

Well, lets see if we can get things working for ya.

What device are you running XBMC on?

You say you first installed from the repository, then tried a posted fix addon. It's possible XBMC isn't overwriting the original addon package, so you'll need to delete that package.

If you're running this on a linux based system, it's possible your curl is outdated causing issues. Check this post for more information --> LINK.

If you're running Windows, try this.

  1. Download the addon packaged listed in this post --> LINK
  2. Since you stated you have the YouTube plugin installed, lets delete the plugin package file to enusre the revised plugin installs properly. That file can be found by entering the following into Windows Start Menu search box: %appdata%\XBMC\addons\packages Once the packages folder is opened, delete any instance of the file named: plugin.video.youtube
  3. Next, open the addons folder by entering %appdata%\XBMC\addons\ Look for a folder named: plugin.video.youtube. If that folder exists, then delete the folder.
  4. Next, open the addon_data folder by entering %appdata%\XBMC\userdata\addon_data Look for a folder named: plugin.video.youtube. If that folder exists, then delete the folder.
  5. Last, install the plugin manually by starting XBMC, then go to Settings>Addons>Install from zip

After install, enter your YouTube username and password to see if it works.
@sogopot: Will they not let you update Post 1 in this thread? I say this because you just told a guy to install your plug-in by referencing Post 4063.

For people who have been following this since day 1, that's fine.

For newbies like me, we are looking for HenrikDK to update his first post where it states the latest stable version is 3.1.0.
(2014-04-19, 17:06)Death-Axe Wrote: [ -> ]You know, instead of loging in at all, wouldn't it be better if this addon could pull as this pulls http://daviddeutsch.github.io/yt-sanegrid/ no login needed at all.

I'v had success using the no username/password fork which has PR pending on github, login, subs, and search all work. I can't vouch for security but it uses OAUTH from Google. It doesn't have the vevo fix and it has a different name and version number so any apps you use which call the plugin won't work remote apps etc. Use at own risk etc.
(2014-04-21, 06:13)sogopot Wrote: [ -> ]Well, lets see if we can get things working for ya.

What device are you running XBMC on?

You say you first installed from the repository, then tried a posted fix addon. It's possible XBMC isn't overwriting the original addon package, so you'll need to delete that package.

If you're running this on a linux based system, it's possible your curl is outdated causing issues. Check this post for more information --> LINK.

If you're running Windows, try this.

  1. Download the addon packaged listed in this post --> LINK
  2. Since you stated you have the YouTube plugin installed, lets delete the plugin package file to enusre the revised plugin installs properly. That file can be found by entering the following into Windows Start Menu search box: %appdata%\XBMC\addons\packages Once the packages folder is opened, delete any instance of the file named: plugin.video.youtube
  3. Next, open the addons folder by entering %appdata%\XBMC\addons\ Look for a folder named: plugin.video.youtube. If that folder exists, then delete the folder.
  4. Next, open the addon_data folder by entering %appdata%\XBMC\userdata\addon_data Look for a folder named: plugin.video.youtube. If that folder exists, then delete the folder.
  5. Last, install the plugin manually by starting XBMC, then go to Settings>Addons>Install from zip

After install, enter your YouTube username and password to see if it works.

Hi I've done everything I was supposed to (windows 7), but my error is still the same for more than a year now:

Code:
19:24:40 T:4908  NOTICE: Loading cookies from :'C:\\Users\\xxx\\AppData\\Roaming\\XBMC\\userdata\\addon_data\\plugin.video.youtube\\yt-cookiejar.txt'
19:24:40 T:4908  NOTICE: YouTube-4.4.6
19:24:40 T:4908  NOTICE: CommonFunctions-2.5.1
19:25:32 T:4908   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.UnicodeEncodeError'>
                                            Error Contents: 'ascii' codec can't encode character u'\u0159' in position 1: ordinal not in range(128)
                                            Traceback (most recent call last):
                                              File "C:\Users\xxx\AppData\Roaming\XBMC\addons\plugin.video.youtube\default.py", line 111, in <module>
                                                login.login()
                                              File "C:\Users\xxx\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeLogin.py", line 75, in login
                                                result, status = self.authorize()
                                              File "C:\Users\xxx\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeLogin.py", line 85, in authorize
                                                (result, status) = self._httpLogin({"new": "true"})
                                              File "C:\Users\xxx\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeLogin.py", line 183, in _httpLogin
                                                ret = self.core._fetchPage(fetch_options)
                                              File "C:\Users\xxx\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeCore.py", line 400, in _fetchPage
                                                request = urllib2.Request(link, urllib.urlencode(get("url_data")))
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\urllib.py", line 1326, in urlencode
                                                v = quote_plus(str(v))
                                            UnicodeEncodeError: 'ascii' codec can't encode character u'\u0159' in position 1: ordinal not in range(128)
                                            -->End of Python script error report<--
19:25:32 T:6904   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.youtube/
19:25:32 T:6904   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/) failed
This add-on is a must have Wink
Would there be any particular reason why I'm now getting the "Login Failed - false" error?

I've used the plugin with no problems for a long time now, but just started getting that error last night.
(2014-04-23, 15:17)anarckie Wrote: [ -> ]Would there be any particular reason why I'm now getting the "Login Failed - false" error?

I've used the plugin with no problems for a long time now, but just started getting that error last night.
same here, tried different solutions from google code but still didn't manage to solve it
(2014-04-23, 15:17)anarckie Wrote: [ -> ]Would there be any particular reason why I'm now getting the "Login Failed - false" error?

I've used the plugin with no problems for a long time now, but just started getting that error last night.

(2014-04-23, 17:49)Alonzzo2 Wrote: [ -> ]
(2014-04-23, 15:17)anarckie Wrote: [ -> ]Would there be any particular reason why I'm now getting the "Login Failed - false" error?

I've used the plugin with no problems for a long time now, but just started getting that error last night.
same here, tried different solutions from google code but still didn't manage to solve it

Did you enable Google's 2-Step verification? If so, that's why you can't login. You'll have to turn 2step off if you want to use this addon. Even if you didn't turn on 2-step verification, the logon issues has cropped up for most using this addon.

Read this post linked here --> LINK. I posted a revised addon that has many fixes integrated that were posted by many different members to get the addon working again, however it does not resolve 2-step authorization issues, so you'll need 2-step turned off to continue using the addon. Read the troubleshooting section if the addon doesn't work after you manually install it.

There is a way to get 2-step working with the addon, though you'll need to do some editing of the code. See this post for more information LINK.
Now that YouTube Live works, is there any way to adjust the quality? The Young Turks live stream is 1080p and it buffers like crazy on some Internets I use.

I would like to drop it to 720p, 480p, etc when using slower Internet so it doesn't buffer like crazy.
curl: (35) error:14077410:SSL routines:SSL23_GET_SERVER_HELLOConfusedslv3 alert handshake failure

I can't play any youtube videos.

With the latest releases of Curl, argument "--ciphers ALL" is needed to allow SSL3.

http://curl.haxx.se/mail/tracker-2014-02/0006.html
To be honest.. I'm tired of the YouTube app for XBMC.
I have to say that I also have problems with my YT account in terms of I don't know "how" correctly to login with this app.
Since Google+ forced everyone to link your YT, things work a bit differently.

Actually I use an Andoid app called "Yatse" for sending/queing YT Links to XBMC. Works perfectly with frodo (only).