Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2014-06-26, 14:33)ch33p Wrote: [ -> ]
(2014-06-26, 10:31)Olepir Wrote: [ -> ]almost all major labels music video not working (vevo and others)
Can you access them in your browser (if not welcome to Germany Sleepy)

yes, and everything work fine till couple of days ago
Why is this problem ALWAYS recurring?

Is it impossible to have some kind of agreement with youtube & xbmc to talk together and make sure the users don't have these anoying problems?

I love that there is wise coders that make it work in their spare time <3

But sometimes I think they do it on purpose just to piss the users of and keep us busy busy busy? ..oO( Let's close that option just for "fun" )

I hope for a long working solution soon Smile

You all have a great day

- Aikon
(2014-06-26, 17:57)Aikon Wrote: [ -> ]Why is this problem ALWAYS recurring?

Is it impossible to have some kind of agreement with youtube & xbmc to talk together and make sure the users don't have these anoying problems?

I love that there is wise coders that make it work in their spare time <3

But sometimes I think they do it on purpose just to piss the users of and keep us busy busy busy? ..oO( Let's close that option just for "fun" )

I hope for a long working solution soon Smile

You all have a great day

- Aikon
You are an offensive git.
I have the same problem as posted several times on last pages: nearly no music video is working Sad
All other related open source projects I'm using (youtube-dl, savefrom) have already fixed the probem.
The code for youtube-dl is available online - so it would be great if the dev could look at it...

edit: looks like this addon is not really maintained anymore. could maybe someone else fix it?
Thanks for that link - by looking through the recent commits I was able to see what the change was. It's actually quite minor. Here's the instructions on how to fix it (I'm on Linux, so adjust accordingly).

Open up ~/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py in your favourite editor, then -

line 447, change to:
match = re.search("signature=([$a-zA-Z]+)\([^)]\)", playerData)

line 455, add:
_mainFunName =mainFunName.replace('$','_S_')

line 464, change to:
fullAlgoCode += '\n\treturn %s(param)' % _mainFunName

(note, 464 is the new line line number after adding line 455)

save and quit, then delete ~/.xbmc/addons/plugin.video.youtube/YouTubePlayer.pyo to make sure your changes are picked up.

Hope my explanation is clear enough.
Thanks, although a diff would be clearer i think.

Does the new line replace 455 so that old 455 becomes 456?
Yeah, sorry, forgot to take a copy of my .py file before I edited. If there's a handy link to the current .py I'll try and produce a diff Tongue

455 is an insertion, so yeah, the old 455 becomes 456 (and 463 becomes 464, which is then changed as above).

I've literally just finished tinkering, (and then had to register to post), so apologies for the improtu explanation, but I figured people would want to know ASAP...

I've also realised I may be running with an edited .py - so those line numbers might not be accurate :/

I've uploaded my file here: http://casual-tempest.net/files/YouTubePlayer.py
Obviously standard disclaimers apply to downloading stuff off the internet, but that may simplify things for people.
(2014-06-27, 02:07)cruise Wrote: [ -> ]Thanks for that link - by looking through the recent commits I was able to see what the change was. It's actually quite minor. Here's the instructions on how to fix it (I'm on Linux, so adjust accordingly).

Open up ~/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py in your favourite editor, then -

line 447, change to:
match = re.search("signature=([$a-zA-Z]+)\([^)]\)", playerData)

line 455, add:
_mainFunName =mainFunName.replace('$','_S_')

line 464, change to:
fullAlgoCode += '\n\treturn %s(param)' % _mainFunName

(note, 464 is the new line line number after adding line 455)

save and quit, then delete ~/.xbmc/addons/plugin.video.youtube/YouTubePlayer.pyo to make sure your changes are picked up.

Hope my explanation is clear enough.
Thanks so much. That was quick Smile
I'll try to edit the file. Could maybe someone also add a fixed version to the repo? Or could only the dev do that?
On my pc I know how to edit the file - but not on my appletv...
(2014-06-27, 02:16)cruise Wrote: [ -> ]Yeah, sorry, forgot to take a copy of my .py file before I edited. If there's a handy link to the current .py I'll try and produce a diff Tongue

455 is an insertion, so yeah, the old 455 becomes 456 (and 463 becomes 464, which is then changed as above).

I've literally just finished tinkering, (and then had to register to post), so apologies for the improtu explanation, but I figured people would want to know ASAP...

I've also realised I may be running with an edited .py - so those line numbers might not be accurate :/

I've uploaded my file here: http://casual-tempest.net/files/YouTubePlayer.py
Obviously standard disclaimers apply to downloading stuff off the internet, but that may simplify things for people.

thank you! everything is ok now!
Cruise .. Your the man <3 ;-)
After a clean install of Raspbmc latest Gotham Build, the login wasn't working with Youtube Addon. (2-Step-Verification is disabled)
What helped was the manual oauth login via Browser and the manual configuration of the settings.xml file by hand. The instructions how this was done, see the video link below …

https://www.youtube.com/watch?v=CVR1m6viAHE (Instructions by Video - not by me)

It is important that your User credentials from youtube are not set in the settings.xml. If so, delete the value entry after id="user_password" and id="username". Otherwise you can login but won't be able to play a video file.

Hope this helps someone with the same problems …
Thanks for the fix
Cheers
youtuber#

what kind of atv you have?
Hello com someone please explain how i can use this fix for a newbie like me. I´m on a Mac mini and really want to use youtube with the vevo videos. Is it something that i can download and install or what?
Best regards