Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2014-07-26, 17:53)coachwhip Wrote: [ -> ]Is there any chance someone could make a zip file.

Or alternatively, tell me exactly how to ssh in from an android tablet.

I've tried to ssh but it just doesn't seem to want to accept the password of openelec. Ssh is turned on in openelec, if I disable the ssh password in openelec then the ssh client on tablet goes into a loop mode.
Still can't believe there is no terminal or half decent file manager in xmbc as an addon. Would make life so much easier.

I've kept this git up to date with patches, you can load the .zip from there.
https://github.com/learningit/plugin.video.youtube
Thank you, that's extremely helpful.
(2014-07-26, 17:53)coachwhip Wrote: [ -> ]Is there any chance someone could make a zip file.

Or alternatively, tell me exactly how to ssh in from an android tablet.

I've tried to ssh but it just doesn't seem to want to accept the password of openelec. Ssh is turned on in openelec, if I disable the ssh password in openelec then the ssh client on tablet goes into a loop mode.
Still can't believe there is no terminal or half decent file manager in xmbc as an addon. Would make life so much easier.

Connectbot works for me. User root, password openelec.
(2014-07-25, 20:15)robertt Wrote: [ -> ]Thanks cruise, vevo videos work again.

Yes, it's working for me again too, vevos work again. Is this going to be merged with the youtube plugin as well?
yesterday i watch a livestream (tomorrowland) in youtube, i send to xmbc through chrome plugin (Play-to-Xbmc), and work in 1920x1080. Why livestream play in 1080 and normal videos not?
(2014-07-26, 22:02)nickr Wrote: [ -> ]
(2014-07-26, 17:53)coachwhip Wrote: [ -> ]Is there any chance someone could make a zip file.

Or alternatively, tell me exactly how to ssh in from an android tablet.

I've tried to ssh but it just doesn't seem to want to accept the password of openelec. Ssh is turned on in openelec, if I disable the ssh password in openelec then the ssh client on tablet goes into a loop mode.
Still can't believe there is no terminal or half decent file manager in xmbc as an addon. Would make life so much easier.

Connectbot works for me. User root, password openelec.

Doesn't work for me, I'm assuming that the address I type in at start of connectbot is... [email protected] IP address
That seems to find the pi, but it will not accept password. Obviously I could be doing some wrong and omitting something obvious to people used to the cli. As I've never used ssh before.
Still would be much better if I could use the cli from the pi itself.

As an aside, thanks to cruise and learningit, The updated zip works fine, easier as I can download and put onto shares network drive.
no its [email protected]_ip_address

openelec runs as root.
Official 4.4.10 pushed, with login and VEVO playback fixes.

YouTube/Google are really being weird with their video formats right now(and with live playback always), so certain resolutions may not work, and certain live streams may not work. Not really something that is fixable(resolution should be fixable when XBMC gets DASH support)
(2014-07-27, 14:47)TobiasTheCommie Wrote: [ -> ]Official 4.4.10 pushed, with login and VEVO playback fixes.

YouTube/Google are really being weird with their video formats right now(and with live playback always), so certain resolutions may not work, and certain live streams may not work. Not really something that is fixable(resolution should be fixable when XBMC gets DASH support)

Thanks for the update all working as you describe.
Hi @TheCollective/TobiasTheCommie/HenrikDK/cruise,
thanks a lot for your work on the addon Smile Some of my addons are using it for playback...

Would be awesome if you can get the signature playback issue working permanently somehow. If not, there would also be an alternative: ruuk has ported youtube-dl to a xbmc module. youtube-dl is always up-to-date and currently supports 270 sites/services. It then can be easily used to resolve youtube urls (and a lot more). I'll also use it for my addons. If it's done this way, the youtube addon itself does not need to get changed anymore (for playback issues), instead only script.module.youtube.dl needs to get updated (which hopefully can be done automatically).
Thanks to ruuk and the youtube-dl devs for this Smile
(2014-07-27, 10:51)nickr Wrote: [ -> ]no its [email protected]_ip_address

openelec runs as root.

Thanks finally works.
4.4.10 failing to play vevo vidoes as well as my uploads. Anyone else confirm?
4.4.10 still working on vevo videos.
I'm still having issues playing trailers using this updated addon.
Can you provide specific links so I can test?