Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So the solution is to move on now? Only showing the device support video now.
Thanks Dioxaz this worked for me to get YouTube back after this new api change.
(2015-05-06, 16:01)Dioxaz Wrote: [ -> ]The path for xbmc.python in Linux is /usr/share/kodi/addons/ (or /usr/share/xbmc/addons/ I presume, if still using Frodo or older)
You must be sudo first (if under Ubuntu) to be able to write in that directory.

Reminder for Windows users: xbmc.python is located at C:\Program Files\XBMC\addons

But if you're under Linux, I suggest updating to Kodi (Helix at least, using the ppa:team-xbmc/ppa PPA, see here for details) unless you really can't do otherwise.

I'm putting a link to an extracted xbmc.python folder from a Helix install here.

Update, 2015-05-08: As some of you may have noticed, applications using gdata calls only return the device support video by now. This means that both Youtube Channels and our Youtube 4.4.10 can now be considered as obsolete. In Youtube 4.4.10, only "My history" and "My favorites" still show the streams (because it's stored by the add-on I presume, not on the Youtube account). So, migration to bromix's Youtube is the only solution.

Original (outdated) paragraph:
Edit: I think I'm understanding why both Youtube 4.4.10 and Youtube Channels are still working. Both add-ons make their calls by using URLs such as this one: https://gdata.youtube.com/feeds/api/videos?q=[search_keyword]
And when calling them directly, using a browser, they still return a valid XML result page. It's only towards the end of May, according to this page, that these 2 add-ons will actually stop working definitely I guess, if I'm not mistaken.

Dear Dioxaz,

Could you please revert with another link to download xbmc.python.zip, because i have some difficulties to use the link http://dioxaz.free.fr/download/xbmc_kodi...python.zip.

Thanks
Can someone revert with another link to download xbmc.python?

Your help is highly appreciated.
Try this: http://www.4shared.com/zip/DrZbt9ubce/xbmcpython.html

I also updated my previous post.
(2015-05-12, 19:06)Dioxaz Wrote: [ -> ]Try this: http://www.4shared.com/zip/DrZbt9ubce/xbmcpython.html

I also updated my previous post.

Thanks a lot Dioxaz

Just a question, is it possible to download videos with this version?
Not with bromix's addon, if that's what you are asking.
Hi
Ive got Bromix version to work, all except the search function which gives a script error, I put the python folder in place before I added the add-on, can anyone else still search with Bromix or is it something "broken" with the new Youtube API permanently?

Thanks !
It's not the search function itself but the embedded keyboard pop-up window that fails and triggers the error. bromix changed the keyboard input method since version 5.1.2 to a new XBMC Python API function (or something similar) that is unsupported by Frodo.

In order to make the search function work again, you have to:
  • go to the following path: ~/.xbmc/addons/plugin.video.youtube/resources/lib/kodion/impl/xbmc/
    (or C:\Users\xxx\AppData\Roaming\XBMC\addons\plugin.video.youtube\resources\lib\kodion\impl\xbmc\ or C:\Documents and settings\xxx\Application Data\XBMC\addons\plugin.video.youtube\resources\lib\kodion\impl\xbmc\ depending on your OS)
  • replace the xbmc_context_ui.py file by one coming from an older version (5.1.1 for example)

To make things easier, I'm putting a modified version of Youtube 5.1.3 with the old keyboard input method:
http://dioxaz.free.fr/download/xbmc_kodi...-frodo.zip (alternate link)
(2015-05-21, 09:28)Dioxaz Wrote: [ -> ]It's not the search function itself but the embedded keyboard pop-up window that fails and triggers the error. bromix changed the keyboard input method since version 5.1.2 to a new XBMC Python API function (or something similar) that is unsupported by Frodo.

In order to make the search function work again, you have to:
  • go to the following path: ~/.xbmc/addons/plugin.video.youtube/resources/lib/kodion/impl/xbmc/
    (or C:\Users\xxx\AppData\Roaming\XBMC\addons\plugin.video.youtube\resources\lib\kodion\impl\xbmc\ or C:\Documents and settings\xxx\Application Data\XBMC\addons\plugin.video.youtube\resources\lib\kodion\impl\xbmc\ depending on your OS)
  • replace the xbmc_context_ui.py file by one coming from an older version (5.1.1 for example)

To make things easier, I'm putting a modified version of Youtube 5.1.3 with the old keyboard input method:
http://dioxaz.free.fr/download/xbmc_kodi...-frodo.zip (alternate link)

Alright alright Smile I try to support both versions in the next update...thought at some point some or most moved one to at least Gotham Confused
I'm running xbmc Gotham and my Youtube Plugin recently stopped giving results for search, my watch later, etc

Does this mean I have to update to Kodi?
No.
(2015-06-29, 21:57)nickr Wrote: [ -> ]No.

Then how do I fix it?
Try reading back a page or two, this post 1966450 (post)
(2015-06-29, 22:21)nickr Wrote: [ -> ]Try reading back a page or two, this post 1966450 (post)

You mean this?

Update, 2015-05-08: As some of you may have noticed, applications using gdata calls only return the device support video by now. This means that both Youtube Channels and our Youtube 4.4.10 can now be considered as obsolete. In Youtube 4.4.10, only "My history" and "My favorites" still show the streams (because it's stored by the add-on I presume, not on the Youtube account). So, migration to bromix's Youtube is the only solution.

If so, what exactly does "migration to bromix's youtube is the only solution" mean?