Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Is there any way to view ALL my subscription videos and not just the "new ones" in a single list?
me too, Uncaught error on both dharma and eden.
HenrikDK Wrote:While TheUni is correct about the version 9 rtmp handshake this only applies to a small subset of video content.

It seems that the youtube decided to change encoding on their html and that is currently messing with our url extraction code. I've had a fix in our trunk since last night (caught this error while watching up on some lets plays). I wanted to see if this was a temporary problem with youtubes servers but it seems that its a permanent change so I'll push a bugfixing update out later today.

Thanks dude, top quality as usual.

Does make me wonder though, if they do it for people using external devices to view vids on the site.

I know a few folk that have a WD tv live... I bet those will be affected also. And being a large corp, they will be waiting a hell of a long time for a new firmware update.
HenrikDK Wrote:I'll push a bugfixing update out later today.

Cheers on that, thx in advance Cool
HenrikDK Wrote:... but it seems that its a permanent change so I'll push a bugfixing update out later today.

That sounds really good! Thanks in advance Henrik Big Grin
Death-Axe Wrote:Thanks dude, top quality as usual.

Does make me wonder though, if they do it for people using external devices to view vids on the site.

I know a few folk that have a WD tv live... I bet those will be affected also. And being a large corp, they will be waiting a hell of a long time for a new firmware update.

I doubt that everyone is experiencing this problem, as it's mostly caused by xbmc's version of python being terrible at handling unicode content and character encoding in genneral (god im looking forward to a python upgrade if / when it comes in eden).
HenrikDK Wrote:(god im looking forward to a python upgrade if / when it comes in eden).

This is soooo close we can taste it. Not much longer Smile

TheUni
Vrok Wrote:Is there any way to view ALL my subscription videos and not just the "new ones" in a single list?

This isn't supported by the api, and seems like a strange request to me Huh
New version should be in the repo now:

Version 2.0.3
- Fixed Context menus were "suddenly" missing on a lot of folder items (probably since pre v.2)
- Fixed "New Subscriptions Videos" feed would show up on every subscriptions page this has been corrected
- Fixed YouTube changed character encoding of their webpage which messed up playback in the plugin.
- Added Portuguese (Brazil) translation courtesy of fschnack

Sadly I've discovered that there's still an outstanding issue since "disco search" was also broken by YouTube recent changes. I have a fix for this in svn but I'm debating whether to do another quick release (putting extra load on xbmc's servers), holding off until the next beta, or just save it and see if other issues will crop up that would justify another bugfixing release.
Working for me now! Thanks for the incredibly fast update!
All the videos I tried to watch yesterday loaded without issue, about 20 or so of them.

Thanks for the super quick fix Henrik!!!
Hi when trying to access 4oD Shows I can browse no porblems but when trying to play a video nothing happens untill about the forth video tried it gives a message of playback failed. Is this the handshake 9 change being talked about, what the RTMP guys are looking at? Normal youtube content works fine.

Great Addon by the way use it most days Thank you

The Youtube Addon v2.03 was installed from the XBMC.org addon repository.
Im using XBMC Live on Asrock ion 330. Log in is no problem.
Ive checked the videos on Youtube itself and they play fine.:o




http://pastebin.com/cgELk9gg
Long time lurker, first time poster. Just wondering why the Addon repo still only shows 1.8.1 as the latest version ?
hams1000 Wrote:Long time lurker, first time poster. Just wondering why the Addon repo still only shows 1.8.1 as the latest version ?

Your XBMC version is out of date perhaps? I've just pushed 2.0.3 two days ago, or are you using the plugin for the xbox version?, as that's not maintained by us.
HenrikDK Wrote:Your XBMC version is out of date perhaps? I've just pushed 2.0.3 two days ago, or are you using the plugin for the xbox version?, as that's not maintained by us.

I have the same version issue. what repo should i have? i am running xbmc4xbox ver 3 rev30827