Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
It appears that the scraper needs to be updated for the YouTube TV shows...
Code:
17:10:49 T:140578700937120 M:2738839552   DEBUG: ------ Window Init (DialogBusy.xml) ------
17:10:49 T:140578700937120 M:2738839552   DEBUG: Alloc resources: 0.01ms (0.00 ms skin load)
17:10:49 T:140578144732928 M:2738712576  NOTICE: fetching url http://www.youtube.com/shows/animation-cartoons?p=1&hl=en
17:10:49 T:140578144732928 M:2738712576  NOTICE: YouTube-2.0.3 scrapeShowsGrid
17:10:50 T:140578144732928 M:2737442816    INFO: -->Python script returned the following error<--
17:10:50 T:140578144732928 M:2737442816   ERROR: Error Type: exceptions.IndexError
17:10:50 T:140578144732928 M:2737442816   ERROR: Error Contents: list index out of range
17:10:50 T:140578144732928 M:2737442816   ERROR: Traceback (most recent call last):
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/default.py", line 53, in ?
                                                navigator.listMenu(params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 115, in listMenu
                                                self.scrape(params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 382, in scrape
                                                ( results, status ) = scraper.scrape(params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeScraperCore.py", line 747, in scrape
                                                return self.scrapePageinator(params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeScraperCore.py", line 519, in scrapePageinator
                                                (result, status) = self.scrapeShowsGrid(html, params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeScraperCore.py", line 433, in scrapeShowsGrid
                                                title = show.div.h3.contents[0]
                                            IndexError: list index out of range
17:10:50 T:140578144732928 M:2737442816    INFO: -->End of Python script error report<--
17:10:50 T:140578144732928 M:2737442816    INFO: Python script stopped

Also, i found that not all videos will play... a few examples are these two:
Mobile Suite Gundam 00:
http://www.youtube.com/show/mobilesuitgundam00

Jackie Chan Adventures:
http://www.youtube.com/show?p=AbxogaeOUEs
guys,

When logging in how can i play all the clips within any of my lists (pre-configured in the youtube site) i was trying to do CTRL+A or other in order to pick multipale clips but w/o success.

Thanks in advance for you help.
talbo Wrote:guys,

When logging in how can i play all the clips within any of my lists (pre-configured in the youtube site) i was trying to do CTRL+A or other in order to pick multipale clips but w/o success.

Thanks in advance for you help.

This isn't easily possible right now, a play all function will be included in the next beta though, but no word on when that might be..
dandel Wrote:It appears that the scraper needs to be updated for the YouTube TV shows...
Code:
17:10:49 T:140578700937120 M:2738839552   DEBUG: ------ Window Init (DialogBusy.xml) ------
17:10:49 T:140578700937120 M:2738839552   DEBUG: Alloc resources: 0.01ms (0.00 ms skin load)
17:10:49 T:140578144732928 M:2738712576  NOTICE: fetching url http://www.youtube.com/shows/animation-cartoons?p=1&hl=en
17:10:49 T:140578144732928 M:2738712576  NOTICE: YouTube-2.0.3 scrapeShowsGrid
17:10:50 T:140578144732928 M:2737442816    INFO: -->Python script returned the following error<--
17:10:50 T:140578144732928 M:2737442816   ERROR: Error Type: exceptions.IndexError
17:10:50 T:140578144732928 M:2737442816   ERROR: Error Contents: list index out of range
17:10:50 T:140578144732928 M:2737442816   ERROR: Traceback (most recent call last):
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/default.py", line 53, in ?
                                                navigator.listMenu(params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 115, in listMenu
                                                self.scrape(params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 382, in scrape
                                                ( results, status ) = scraper.scrape(params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeScraperCore.py", line 747, in scrape
                                                return self.scrapePageinator(params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeScraperCore.py", line 519, in scrapePageinator
                                                (result, status) = self.scrapeShowsGrid(html, params)
                                              File "/home/dandel/.xbmc/addons/plugin.video.youtube/YouTubeScraperCore.py", line 433, in scrapeShowsGrid
                                                title = show.div.h3.contents[0]
                                            IndexError: list index out of range
17:10:50 T:140578144732928 M:2737442816    INFO: -->End of Python script error report<--
17:10:50 T:140578144732928 M:2737442816    INFO: Python script stopped

Also, i found that not all videos will play... a few examples are these two:
Mobile Suite Gundam 00:
http://www.youtube.com/show/mobilesuitgundam00

Jackie Chan Adventures:
http://www.youtube.com/show?p=AbxogaeOUEs

The broken show scraper is a know issue, I have a fix for it in SVN and will probably issue a testing release for those impatient, but it might be a while before this hits the repo.

Regarding your playback problems, since those shows are unavailable in my country, I'm afraid i can't really say what's wrong without a log with the plugins debug mode enabled (though i'd venture a guess that it's related to the currenty broken rtmpe support).
I am on version 2.0.3 and I have recently run into an issue where I cannot access any content via my account. Whenever I try to access my contacts, playlists, subscriptions etc the load fails and the message is "Playback failed, try logging in". I have loaded my username into the add-on settings and this was working prior to the issue arising and I didn't touch any of the settings. Any ideas? Hopefully a simple fix.

tia...
vijayk416 Wrote:I am on version 2.0.3 and I have recently run into an issue where I cannot access any content via my account. Whenever I try to access my contacts, playlists, subscriptions etc the load fails and the message is "Playback failed, try logging in". I have loaded my username into the add-on settings and this was working prior to the issue arising and I didn't touch any of the settings. Any ideas? Hopefully a simple fix.

tia...

Have you tried going to settings and logging in again like the plugin told you?

Sometimes the authentication token just runs out and for some reason i can
t remember right now we couldn't do an automagic re-login.
Is there a way to set this up to be able to see annotations in the YouTube videos?

Thanks!
pbusardo Wrote:Is there a way to set this up to be able to see annotations in the YouTube videos?

Thanks!

Xbmc doesn't really expose any api for doing overlays so this isn't currently possible
If they're text you could do it via subtitles. I suspect they're not text though.
jmarshall Wrote:If they're text you could do it via subtitles. I suspect they're not text though.

Actually they're simple xml files with box coordinates and text messages (ie timestamp, X coordinate, Y coordinate, message, box color etc). What complicates matters is that any given second (or frame) can contain multiple annotation boxes, with different position which pretty much rules out using the subtitle functionality (plus we're already using this for youtube subtitles in the next beta). The problem with showing this in xbmc is how to handle the interaction part, I can't really see my way out of that.. (is it even possible for a plugin to change default button behavior during playback?). In any case the problems posed by this seems far too many and to complicated for what i'd at best describe as an "edge case".
HenrikDK Wrote:This isn't supported by the api, and seems like a strange request to me Huh
It would be convenientNod
Tent Wrote:It would be convenientNod

It might just be me seeing as I currently have 20+ subscriptions where each has in the multiple 100's of videos (some of them in the multiple 1000's), but this seems very much an edge case to me and not really something I want to spend time on. Plus there's the whole problem of how to sort a "subscriptions" videos (by user, date, by user and date or by playlist?) and which videos do you select (do you use the users favorites, uploads or playlists?). Potentially users could encounter situations where xbmc would be locked up for half an hour just by selecting the wrong button..
I'm trying to launch straight into the Search window of this plugin (very nice btw! ).

I can launch it via the ExecBuiltin functions:

ActivateWindow(10025,plugin://plugin.video.youtube/,return)

Which opens up to the default directory:

Image

Then, when I click on Search, this shows up in the debug log:

[plugin://plugin.video.youtube/?path=/root/search/new&action=search&]

Any suggestions on how I can launch to the Search screen via the executive built-in commands? Or HTTP API command? The only thing out of bounds is the JSON API as the program as I'm going through doesn't utilize it:

Image

Thank you either way!
steppedup Wrote:I'm trying to launch straight into the Search window of this plugin (very nice btw! ).

I can launch it via the ExecBuiltin functions:

ActivateWindow(10025,plugin://plugin.video.youtube/,return)

Which opens up to the default directory:

Image

Then, when I click on Search, this shows up in the debug log:

[plugin://plugin.video.youtube/?path=/root/search/new&action=search&]

Any suggestions on how I can launch to the Search screen via the executive built-in commands? Or HTTP API command? The only thing out of bounds is the JSON API as the program as I'm going through doesn't utilize it:

Image

Thank you either way!

Are you trying to list the users previous searches?

In that case this:
Code:
ActivateWindow(10025,plugin://plugin.video.youtube/?path=/root/search&login=false&store=searches&,return)
would probably be the correct url (though I didn't test it).

In any case try looking at xbmc's log with the debug mode enabled and watch out for the line with:
Code:
18:25:22 T:2960105472 M:2176610304  NOTICE: YouTube-2.0.3 ARGV:

as that line contains the url path the plugin is executing.
Hey does anyone know of how to access a youtube channel. For example, http://www.youtube.com/user/example

Is it only possible through a browser ?