Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
activate Wrote:Hey does anyone know of how to access a youtube channel. For example, http://www.youtube.com/user/example

Is it only possible through a browser ?

If you subscribe to the channel you can access it through the plugins subscriptions list.

Alternatively you can add the user as a contact (the user doesn't have to accept) and you will be able to see them in the contacts list.
Thanks mate. Somewhat better. See the way the have set up their channel is on the opening page, the video actually has links beneath it a bit like a dvd menu. Those links seem to be leading to videos that are not held under the same username. And in these cases there are multiple username links.

Adding a contact was certainly better than the subscription. Similarly on the http://www.youtube/user/indiatimes the mainstream which is a live channel when a game is on is not picked up by any search on youtube even through a conventional browser on a computer or lowtide. It only appears on that address, hence the question.
activate Wrote:See the way the have set up their channel is on the opening page, the video actually has links beneath it a bit like a dvd menu. Those links seem to be leading to videos that are not held under the same username. And in these cases there are multiple username links.
Are you talking about links in "annotations"? cause thats already been discussed and as far as i can tell theres no way to bring this into xbmc..

activate Wrote:Adding a contact was certainly better than the subscription. Similarly on the http://www.youtube/user/indiatimes the mainstream which is a live channel when a game is on is not picked up by any search on youtube even through a conventional browser on a computer or lowtide. It only appears on that address, hence the question.
This seems to be part of youtubes new live streaming feature that was just debuted last week. I haven't looked into whether or not it's even possible to access that content from xbmc yet, and theres certainly no api access yet so this is gonna take a while to get into the plugin.
Ah i see, yes they have annotations. Okidoki.

I also didn't realise that live streaming was a new feature on youtube. Saw yesterday that a whole website covers these. http://www.youtube.com/live

Its tricky as a user because, it doesn't come up on any search app ie atv2, iphones, ipads etc. Also couch surfer wont play because its not html video. Mucked around with useragent on atv2 as well as the other ios devices without success.

Oh well atleast we know what we were talking about. Thanks Henrik!
acaranta Wrote:Stop searching .... This morning ... no 501 error ... it works perfectly ... login successfull ...

I think that the problem was on youtube side ... no other explanation possible ...

OK it might be something else it appears to be a proxy problem.
I discovered that re-enabling my local proxy at home for XBMC got me the "501 not implementend" error.

Disabling it, however got the Youtube plugin working correctly.
I use a Squid proxy and it usually works fine with Youtube.

Hope that helps...
I saw the sticky on logon problems. When I acces the plugin and click MY FAVORITES I always get an error that I'm not logged on. However if I open settings, then go back and retry it works.

Is full reinstallation as detailed in OP the way to solve this and should I post a log or is this known?
kees667 Wrote:I saw the sticky on logon problems. When I acces the plugin and click MY FAVORITES I always get an error that I'm not logged on. However if I open settings, then go back and retry it works.

Is full reinstallation as detailed in OP the way to solve this and should I post a log or is this known?

Hi, this is a known issue and a re install wont do anything, basically when ever you login youtube gives us a token, but these tokens run out after a while (usually a couple of days). Currently the plugin can't handle automatic re-login but we're working on a refactor of the code to support this in the future.
Hello,

I cant get the script to work.

I installed it thru the repo and placed my login correctly, next to that no changes in the settings.

Then when i try to run the script is says received 0 items and then it shows the settings.

I deleted the folders i had to delete and i reinstalled and still the same.

http://pastebin.ca/2047227

Here is the log.

I run Windows 7 64bit
XBMC 10.1

Hope to get help soon.
Rionsic Wrote:Hello,

I cant get the script to work.

I installed it thru the repo and placed my login correctly, next to that no changes in the settings.

Then when i try to run the script is says received 0 items and then it shows the settings.

I deleted the folders i had to delete and i reinstalled and still the same.

http://pastebin.ca/2047227

Here is the log.

I run Windows 7 64bit
XBMC 10.1

Hope to get help soon.

Hi, could I get you to enable xbmc's own debug too and upload a new log?
HenrikDK Wrote:Hi, could I get you to enable xbmc's own debug too and upload a new log?

Here we go: http://pastebin.ca/2047404
sregg Wrote:Hi everyone,

First of all, thank you for this great addon.

Now the question : would it be possible to have the "watch later" feed?

Thanks.

I'd love to get ahold of the "watch later" feed as well.
Thanks. is there an easier/faster way of logging in except for opening settings and leaving settings?

HenrikDK Wrote:Hi, this is a known issue and a re install wont do anything, basically when ever you login youtube gives us a token, but these tokens run out after a while (usually a couple of days). Currently the plugin can't handle automatic re-login but we're working on a refactor of the code to support this in the future.
kees667 Wrote:Thanks. is there an easier/faster way of logging in except for opening settings and leaving settings?

Nope sorry :/
Hey, any luck finding out whats wrong with my PC so that the addond doesnt work?
Here the log again: http://pastebin.ca/2047404
Rionsic Wrote:Hey, any luck finding out whats wrong with my PC so that the addond doesnt work?
Here the log again: http://pastebin.ca/2047404

Hi Rionsic,

No that log doesn't give us a whole lot of information to work with, it seems that the plugin is trying to login to youtube but the process get's cancelled by xbmc:

Code:
WaitOnScriptResult- cancelling plugin YouTube
If the youtube plugin had failed it would've said:
Code:
INFO: -->Python script returned the following error<--
or
WaitOnScriptResult - plugin exited prematurely - terminating

I don't know if it's you cancelling the plugin due to impatience (login can be a very long process due to 30 second timeouts and the plugin trying multiple times) or if xbmc's doing it for some reason.