Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I am trying to get this installed on the team-xbmc now as my Download icon wasn't highlighted on the unstable release; does the Youtube 2.5.0 work on it?
Which svn should I use?
TobiasTheCommie Wrote:When i hit that video it tells me it is a rental that isn't available in my country.

I would very much like a full debug log of your problem.

Even though it says 2.0.5 you have version 2.1.0, A slight mistake in our rush to fix the plugin this morning.

ETA: Since this is a rental you most likely need an updated rtmp library (version 2.4)

If you are running mac or windows, installing the latest nightly of eden should give you that.

TobiasTheCommie, your right, ScoobyDoo is a pay movie. I didn't know that selecting movies now include that option. But I did a past-bin anyway. I also get an error trying the Free Movies selection and I included that also. Also included my version of rtmpdump. I'm just now getting back on it, had to go do some work today or I would have posted sooner.

ScoobyDoo paste-bin: http://pastebin.com/42Q59wSY


Free_Movies paste-bin: http://pastebin.com/t8m6DPPc


RTMPDump v2.4
© 2010 Andrej Stepanchuk, Howard Chu, The Flvstreamer Team; license: GPL
when use youtube add on cannot play stream with
error
"stream type unsupported"

how to resolve it?
speed32219 Wrote:TobiasTheCommie, your right, ScoobyDoo is a pay movie. I didn't know that selecting movies now include that option. But I did a past-bin anyway. I also get an error trying the Free Movies selection and I included that also. Also included my version of rtmpdump. I'm just now getting back on it, had to go do some work today or I would have posted sooner.

ScoobyDoo paste-bin: http://pastebin.com/42Q59wSY


Free_Movies paste-bin: http://pastebin.com/t8m6DPPc


RTMPDump v2.4
© 2010 Andrej Stepanchuk, Howard Chu, The Flvstreamer Team; license: GPL

I couldn't find any debug information in the free_movies log.
mbah.pande Wrote:when use youtube add on cannot play stream with
error
"stream type unsupported"

how to resolve it?

I suspect you need to update your librtmp package, but without a debug log there is no way to be certain that is the problem.

Is it all videos, or just some, that fail?
Hi Tobias,
I think it is a problem from Youtube updating their API yesterday. I installed XBMC yesterday and had a problem straight away.

I am trying to download the latest from unstable but it is not reflecting today's update yet.

xbmc (11.0~git20110803.e536552-0ubuntu1~ppa1~natty)
wasabi Wrote:Hi Tobias,
I think it is a problem from Youtube updating their API yesterday. I installed XBMC yesterday and had a problem straight away.

I am trying to download the latest from unstable but it is not reflecting today's update yet.

xbmc (11.0~git20110803.e536552-0ubuntu1~ppa1~natty)

I'm not sure what your problem is, you are being rather vague.

I suggest you use Dharma and just use the normal version of the plugin that you can download through XBMC directly. No svn for xbmc or plugin.
Sorry, I assume that this is the same error everyone started mentioning on the 4th August.

18:51:26 T:3079313264 M:2830446592 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/?

While in YT, I got an error on-screen, "Stream not supported".

And my problem is I use Linux so there is no nightlies for me. I think there was a fix done yesterday so when I noticed the unstable PPA had been updated on 20110805, I thought it would include the fix.
Now waiting for sudo apt-get update to actually download the correct version.


I wish I had Windows!
wasabi I think you are confusing yourself, the addon system in xbmc has nothing to do with svn or apt, stick with the stable version of xbmc (unless you need the nightly build) go to system/settings and find the addon menu, there you should find available updates (I think) find the updated YouTube plugin in the Video Add-ons.
What gott_sei_dank said.

In any case, if you want us to be able to do anything, at all, we need the entire log. Not just a part of it.

Use pastebin.com or something similar and paste the link here.
TobiasTheCommie Wrote:I couldn't find any debug information in the free_movies log.

Line 808-857. Looks to be a 404 file not found error.

http://pastebin.com/t8m6DPPc
speed32219 Wrote:Line 808-857. Looks to be a 404 file not found error.

http://pastebin.com/t8m6DPPc

Yes, there is an httperror, but not any debug. I need the debug information to figure out why there was an httperror.

There probably was an error in your version that means you would have to restart the plugin for the debug setting to have been toggled.

If you could try again i believe the debug information should come this time.
Debug still doesn't appear to be turned on in the plugin.

Please go to "change plugin setting". Enable debug. press ok.

If debug is already enable, disable it, and press ok. open settings again, and enable it once more, and click ok.

Restart xbmc.

Try again.
TobiasTheCommie Wrote:Debug still doesn't appear to be turned on in the plugin.

Please go to "change plugin setting". Enable debug. press ok.

If debug is already enable, disable it, and press ok. open settings again, and enable it once more, and click ok.

Restart xbmc.

Try again.

Here ya go!

Line 820: http://www.youtube.com/movies/movies?fl=f&pt=fm?p=1&hl=en
does not work

Changed to: http://www.youtube.com//movies?fl=f&pt=fm?p=1&hl=en
works - removed the highlighted movies above in the url

http://pastebin.com/3G2NHU5T

Also ran into another error, API error when I select some videos under family genre, dang it. Some of the older videos play (Lassie) and many don't (Oliver!), get the API error.

Code:
00:49:27 T:2826959728 M:1292206080  NOTICE: -->Python Interpreter Initialized<--
00:49:27 T:2826959728 M:1292206080  NOTICE: YouTube-2.0.5
00:49:29 T:2826959728 M:1292460032  NOTICE: YouTube-2.0.5 getVideoUrlMap Searching for fmt_url_map 2: [u'']
00:49:29 T:2826959728 M:1292460032   ERROR: Error Type: exceptions.AttributeError
00:49:29 T:2826959728 M:1292460032   ERROR: Error Contents: YouTubePlayer instance has no attribute 'showMessage'
00:49:29 T:2826959728 M:1292460032   ERROR: Traceback (most recent call last):
                                              File "/home/XBMC/.xbmc/addons/plugin.video.youtube/default.py", line 48, in ?
                                                navigator.executeAction(params)
                                              File "/home/XBMC/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 203, in executeAction
                                                player.playVideo(params)
                                              File "/home/XBMC/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py", line 57, in playVideo
                                                self.showErrorMessage(self.__language__(30603), video["apierror"], status)
                                              File "/home/XBMC/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py", line 365, in showErrorMessage
                                                self.showMessage(title, result)
                                            AttributeError: YouTubePlayer instance has no attribute 'showMessage'
00:49:29 T:3055814528 M:1292460032   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/?path=/root/explore/movies&action=play_video&videoid=_dHFoGqfYXM]