Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm probably an idiot for this, but I couldn't get it to install. I downloaded the zip, expanded the folder, copied it to: c:Users\UserName\AppData\Roaming\XBMC\plugins\Video\plugin.video.youtube.beta

I am running Camelot. I got an error when I tried to browse to it...

I've never installed a plugin before, so that could be my issue. I thought it was like a skin, just browse to the path...
Quote:I am running Camelot.

You need Dharma.
Yup..I'm an idiot. Thanks
TobiasTheCommie Wrote:Could you enable xbmc debug for the log? Just in case there is something weird happening in XBMC and not in our plugin.

Oh, and of course do it with the new 0.9.7 Wink

Latest update:
Just tested again with XBMC r33122, and latest plugin download (0.9.7) which was downloaded from mediafire. Debug log was enabled in XBMC settings and in the plugin settings.
This time I went into the plugin and checked the plugin settings before attempting to play the video. On exiting the settings it took a while for it to log in. When completed it said "[1]Logged in".
Then I checked the videos. The ones I checked are the ones I mentioned in my first post - that is one with rtmpe and age restriction, one with rtmpe, and a regular unprotected YouTube video. I also tried to watch the rtmpe video that you have been using for testing. I did not get any of the rtmpe videos to play at all - I think the error that was given on screen in all cases was "uncaught error". Also, the regular video was *much* slower to start playing than with previous versions of the plugin - about 30 second wait (in previous plugins playback of that video was instant).

Here is the debug from the session described above:
http://pastebin.com/yXmgAp3p

For comparison here is one from a session with ver 0.9.6 of the plugin. The session was more-or-less the same as the one above except that settings were not checked before trying to play the videos, and the regular YouTube video played instantly:
http://pastebin.com/60aKGpDV


I'm sorry to be bringing bad news again (though it looks like the login situation might have improved!). I hope this isn't something that's particular to me Huh. Are there any others who have been trying to play rtmpe videos?? Have any other British users been able to watch more than the first 2 mins of any full episode from the 4oD YouTube channel??
@procrastinator:

Ok, actually getting somewhere, slowly, now with the rtmp thing. I can see that youtube doesn't give you a swfConfig, which we need to playback the video.

I've made some updates and here is revision 96.

http://rapidshare.com/files/415463144/pl...ta-r96.zip
Note: This version is just for procrastinator, download 0.9.7 instead of this unless you have rtmpe problems.

I hardened our swfConfig scraper. In did some other minor stuff.

I honestly don't know if anyone else have used rtmp at all. So this issue might be just you, or it may be a general one.

But it works for both me and HenrikDK.

Still, this needs to be fixed, even if it is is just you, someone else will encounter the same problem later.

The 30 second delay is weird. It is a login function(a different one) waiting for youtube.com to respond.

I have updated the function a bit, and hopefully it won't trigger now.

But the normal login, you got a [1] which meant it had to retry once before it logged in. So, backup loop kicked in. Which is good. That it was needed was bad.

I really think this login issue is not plugin specific. It seems more and more like it is a connection problem unrelated to our plugin(and most likely unrelated to xbmc as well).
sufreak Wrote:Yup..I'm an idiot. Thanks

I wasn't gonna say anything. Big Grin
Big Grin Good News! Big Grin

Just had another go with the updated plugin (revision 96) and it worked!!

I had two sessions which produced slightly different results. In the first session everything seemed to work fine, however in the second session there was a slight problem. The two sessions are explained below

Session 1:
Before checking any of the videos I first checked the plugin settings. On exiting I had to wait a little while and then got the "[1] Logged in" message. I then went to check the videos - these are the same ones I've mentioned in my last post. All videos worked, and played well beyond a couple of minutes into video.

http://pastebin.com/gXazyE64

Session 2:
This time I went straight to the videos in the plugin without checking the settings first. On this attempt the age restricted rtmpe video failed to play and came up with the error message "couldn't extract video url". I tried again and the video failed again with the same message. I then tried playing the non-age restricted rtmpe stream; on the first attempt this did not play, but I'm not sure that this is the plugin's fault, I think that might've just been a blip in XBMC! When I tried playing it again it worked fine. Your test rtmpe video also played fine, as did the regular YouTube video. Here's the debug from that one:

http://pastebin.com/Mb5AAMC0

I also repeated the two sessions above and produced the same results.


Excellent work! I don't know about you guys but I'm gonna go and crack open a beer!
That sounds good. Smile

Session 2 error is the same login problem as we have seen before, patching that login as well.

This MUST be network related. It crashes when it opens the connection to the server.
Release version 0.9.8

Version 0.9.8
- fix login message "bad username and password"
- Always print reply from youtube on uncaught exceptions
- Added steps to httpLogin to aid with debugging
- Harden swfConfig
- Only httpLogin when required
- Minor fixes
- Fix, download didn't work with & in the title
- Loop httpLogin up to 10 times on connection failure.
- Debug is no longer forced on.
- Remove counter on login message

http://code.google.com/p/youtubexbmc/downloads/list
Unless there are any major issues left we are going to issue a Release Candidate soon.

Once we release -rc1 we won't accept any more feature requests before we release our final 1.0, so if you have any requests, now is the time to voice it.

Of course we still want all errors and mistakes reported.

If you find something wrong with our plugin i'll give you a cookie!
Thanks for the great Plugin guys, it rocks Smile
So far haven't had any problems with it.

I was wondering if it was possible to choose what parts of Youtube to show on the main screen.
For example, i don't need the "Youtube Feeds/Youtube Suggest/My Contacts" shown, I never use them.
grote002 Wrote:Thanks for the great Plugin guys, it rocks Smile
So far haven't had any problems with it.

I was wondering if it was possible to choose what parts of Youtube to show on the main screen.
For example, i don't need the "Youtube Feeds/Youtube Suggest/My Contacts" shown, I never use them.

If we can get more pages in the settings window this would be doable.

ETA: Nuka1195 provided us with what we needed, we can implement this.
Show Hide folders is implemented in SVN and will be in the -rc1 release.
I installed the 0.9.8 it's been working great. Nod
On one of my subscriptions BBCFood I get a 'forbidden 403'. This plays fine in a browser.
http://pastebin.com/UGFukwku
Edit: I just looked at that log it says 0.9.6