Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
christian.prins Wrote:Regarding the firewall issue.

Code:
urlopen error (10061, 'Connection refused')

Does any of you know which port should be opened, or do I have to add XBMC as a program to my firewall.

Please enable debuging in the plugin and in XBMC. Restart XBMC, try again, and upload the entire log to a pastebin.
NathanK Wrote:Is the age restriction question prior to viewing, a bug, or a setting update that will be made.

Discussion here:
http://forum.xbmc.org/showpost.php?p=868...count=1249

I seem to be able to view all 4oD and DemandFive TV apart from age related stuff. However for the age related content, through a browser I can view by either clicking the OK to watch button, or logging in and then no need to click OK.
With or without login credentials through the plugin it fails.

Here's a snippet of the log around the age verification.
I don't understand why it doesn't work for you.

According to the link you provided it should work if you are logged in in the plugin, and you verify your age on the same account on the browser.

Sadly we have no (easy) access to 4oD from Denmark. And actually hitting the age verification automatically in the plugin hasn't really worked consistently or in a stable way ever.

Try giving me a full log. (Be sure to screen it for password, if you login)
The YouTube plugin (2.6.2) worked fine for me 10 minutes ago - I've just tried to go back into it and it said Login Error - I've just re-entered my login credentials and its now working again.

One thing I have found with this plugin, is that the ATV 2 struggles to play 720p quality - I have to drop it down to SD quality, and once Its finished playing a video, it goes back to the current menu view but doesn't allow me to go up or down to select a new video - the only button on the ATV 2 remote that works, is the menu button and you have to keep pressing this to get out of the plugin and then you can go back into it again and it all works until you play another video and the same thing happens

However, If I play using YouTube on the FrontRow (ATV 2) it quite happily plays 720p streams & allows me to choose other videos
TobiasTheCommie Wrote:I don't understand why it doesn't work for you.

According to the link you provided it should work if you are logged in in the plugin, and you verify your age on the same account on the browser.

Do I need to log in from the same machine. My XBMC is a basic Linux install with no desktop/browser. So I'm logging in from a different machine on my network.
ady199 Wrote:The YouTube plugin (2.6.2) worked fine for me 10 minutes ago - I've just tried to go back into it and it said Login Error - I've just re-entered my login credentials and its now working again.

One thing I have found with this plugin, is that the ATV 2 struggles to play 720p quality - I have to drop it down to SD quality, and once Its finished playing a video, it goes back to the current menu view but doesn't allow me to go up or down to select a new video - the only button on the ATV 2 remote that works, is the menu button and you have to keep pressing this to get out of the plugin and then you can go back into it again and it all works until you play another video and the same thing happens

However, If I play using YouTube on the FrontRow (ATV 2) it quite happily plays 720p streams & allows me to choose other videos

Hi, theres a bug in the current version that makes the plugin use VP8 streams as the default 720p playback, since apple tv relies on hardware support this causes problems for you. We're looking into pushing a bugfixing release as soon as possible.
I have a few problems in a skin regarding Youtube plugin sets content to movies. One of them, maybe most obvious one, is that youtube videos are mainly 16:9 or like while Movie posters are 2:3

May I ask what are the reasons for setting content to movies?
pecinko Wrote:I have a few problems in a skin regarding Youtube plugin sets content to movies. One of them, maybe most obvious one, is that youtube videos are mainly 16:9 or like while Movie posters are 2:3

May I ask what are the reasons for setting content to movies?

From the home page:
http://code.google.com/p/youtubexbmc/

Quote:Known problems

One of the main features of the plugin is that it defaults to thumbnails view for video items. This only works when using the default "Confluence" skin as the plugin is dependent on the Id defined for confluences thumbnails view.

In short, we dont, we just use the id defined for confluences thumbnails view (id 500) which happens to conflict with a lot of other skins since xbmc doesn't implement any proper way to control this.

What you can do is go into plugin settings -> advanced -> view mode in confluence and set it to "xbmc default" this will change it so that the plugin no longer changes the default view mode for videos, note that for any folder you already viewed you have to change the view back to normal listing since xbmc remembers this stuff.

Alternativly you could ask the creator of you skin to change the id of the skins thumbnails view to correspond with confluence
HenrikDK Wrote:In short, we dont, we just use the id defined for confluences thumbnails view (id 500) which happens to conflict with a lot of other skins since xbmc doesn't implement any proper way to control this.

What you can do is go into plugin settings -> advanced -> view mode in confluence and set it to "xbmc default" this will change it so that the plugin no longer changes the default view mode for videos, note that for any folder you already viewed you have to change the view back to normal listing since xbmc remembers this stuff.

Alternativly you could ask the creator of you skin to change the id of the skins thumbnails view to correspond with confluence

I'm the skin author.

Thanks for the info. However, something is clearly setting the content to movies as I have view layout based on content type and Youtube is using movies layout in both thumbs and lists view. This results in poor thumbs.

I do not think that setting a view type should be done by addon but rather by user. If you force thumbnail view, you will loose all additional info you provide like comments or view counts.

So, I should rather ask in skin dev forum about Youtube being recognized as Movie content as it is NOT done by addon itself?
pecinko Wrote:I'm the skin author.

Thanks for the info. However, something is clearly setting the content to movies as I have view layout based on content type and Youtube is using movies layout in both thumbs and lists view. This results in poor thumbs.

Just double checked my code and you are right, and on line 398 we do set content to movie Blush. I think we we're trying to get rid of the view hardcoding but never got it working right (ie. we couldn't get xbmc to change it's view to thumbnails when viewing videos). We'll remove it in the next release since it doesnt seem to do anything for confluence and I'm not aware of any category for webvideos, that will affect the way xbmc handles the content.
Code:
xbmcplugin.setContent( handle=int( sys.argv[ 1 ] ), content="movies" )

pecinko Wrote:I do not think that setting a view type should be done by addon but rather by user. If you force thumbnail view, you will loose all additional info you provide like comments or view counts.

I disagree, XBMC currently can't remember view settings for dynamically generated folder paths such as those provided by addons, the result is that most plugins default to boring file listings, or the user has to spend time setting the view for each new folder level. We created a trac ticket about this problem along time ago but i dont know if theres been any movement on that issue.

Considering that most youtube uploaders spend a good deal of time customizing the thumbnails for their videos it seems to me to be a very poor idea to disregard that. Also since humans seem to be very much visual "creatures", i think most will find the thumbnail to be preferable to a long listing of video statistics. And in confluence we still provide that additional info through the info view for each video, but it requires the user to ask for it.
@HenrikDK

Thanks. Can't wait for the next release :-)

As for the views, I have made combined thumbs/info so it will hopefully bring best of the both worlds. Just need it to to NOT be reported as movies so I get right thumbs :-)

Cheers, P.
Anyone able to shed some light on an issue im experiencing.
when i run the script i get a 'script failed' error

the debug log shows the following, ive seen a few other people post issues with the exact same errors but i havent seen any solutions. any ideas how to fix this?

23:55:19 T:2895952752 M:2951340032 NOTICE: -->Python Interpreter Initialized<--
23:55:21 T:2895952752 M:2950189056 ERROR: Error Type: exceptions.ImportError
23:55:21 T:2895952752 M:2950189056 ERROR: Error Contents: No module named json
23:55:21 T:2895952752 M:2950189056 ERROR: Traceback (most recent call last):
File "/home/xbmc/.xbmc/addons/plugin.video.youtube/default.py", line 45, in ?
import YouTubeLogin as login
File "/home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubeLogin.py", line 25, in ?
import YouTubeCore
File "/home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubeCore.py", line 19, in ?
import sys, urllib, urllib2, re, time, socket, cookielib, json
ImportError: No module named json
23:55:21 T:3079034752 M:2950189056 ERROR: GetDirectory - Error getting plugin://plugin.video.youtube/
23:55:21 T:3079034752 M:2950189056 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/) failed
haywire Wrote:Anyone able to shed some light on an issue im experiencing.
when i run the script i get a 'script failed' error

the debug log shows the following, ive seen a few other people post issues with the exact same errors but i havent seen any solutions. any ideas how to fix this?

23:55:19 T:2895952752 M:2951340032 NOTICE: -->Python Interpreter Initialized<--
23:55:21 T:2895952752 M:2950189056 ERROR: Error Type: exceptions.ImportError
23:55:21 T:2895952752 M:2950189056 ERROR: Error Contents: No module named json
23:55:21 T:2895952752 M:2950189056 ERROR: Traceback (most recent call last):
File "/home/xbmc/.xbmc/addons/plugin.video.youtube/default.py", line 45, in ?
import YouTubeLogin as login
File "/home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubeLogin.py", line 25, in ?
import YouTubeCore
File "/home/xbmc/.xbmc/addons/plugin.video.youtube/YouTubeCore.py", line 19, in ?
import sys, urllib, urllib2, re, time, socket, cookielib, json
ImportError: No module named json
23:55:21 T:3079034752 M:2950189056 ERROR: GetDirectory - Error getting plugin://plugin.video.youtube/
23:55:21 T:3079034752 M:2950189056 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/) failed

Hi haywire, it's a missing dependency in our addon.xml file, it should only happen if you're running nightlies. In that case you can download the latest version 2.6.3 from our website or if you're more patient you can wait until the pull request we've submitted goes through.
New version up on website:
http://code.google.com/p/youtubexbmc/

Changelog:
Version 2.6.3 (Beta)
- Fixed plugin to prefer h264 for 720p again as this was causing problems for apple tv2 users
- Fixed added dependency on simplejson since we're using that now and alot of nightly users we're having problems with the plugin.

Version 2.6.2 (Beta)
- Added missing settings strings
- Changed login code so it no longer prints username and password to log file when plugins debug mode is enabled (broken since 2.6)
I tried it a few hours ago, still choppy 720p for me, reverted back to 2.1.1

http://pastebin.com/3KcZ4Bex

Edit: 1080P is OK
http://pastebin.com/7HnTinXk
macf1an Wrote:I tried it a few hours ago, still choppy 720p for me, reverted back to 2.1.1

http://pastebin.com/3KcZ4Bex

Edit: 1080P is OK
http://pastebin.com/7HnTinXk

Hmm, seems youtube has also begun serving up stereo 3d versions of certain videos and it's messing with the url extractor causing it to fall back to vp8. I'll look into it.