Kodi Community Forum

Full Version: Dharma Beta2 - are these bugs or expected?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've installed Dharma B2 on a Shuttle XS35GT (plus latest NVidia drivers) and I'm having some issues.

Just trying to work out if they're general issues or individual to my own. For reference, I have a sort of mid Camelot SVN running very smoothly on an ASRock ION330 to compare.

1. SMB Hanging Bug

This long thread, and this bug in trac are about this problem. It hasn't had any traction or attention from devs, never even been assigned to anyone but it's a pretty common (and serious) bug based on the sheer number of people commenting on and reading that thread. It occurs in Dharma B2 as well. There is a workaround via mounting the shares outside of XBMC (autofs) and this works completely, but it really shouldn't be necessary and is a lot harder for the average user to set up.

2. UI Slowness in Dharma B2

I can't be 100% sure this isn't individual to my own hardware, but there have been some recent reports from others. The Dharma UI (stock Confluence skin) is noticeably less smooth than Camelot when running in the same way - 1920 by 1080 @ 60. It's like it's running more like 20fps even though System Info reports 60.

3. Wierd Pause When Browsing Long Lists

Possibly related to #2 above, I get a wierd pause for about 1/2 a second when broswing long lists as the selected item moves, every 10 elements or so. I have tried two separate remotes and receivers to try and eliminate the remote and the same remotes/receivers do not exhibit the behaviour in Camelot.

4. No sound on iPhone 4 .mov files and ?mono files

Not much more to say on this one but any file with mono sound seems to play without sound, as do .mov files off an iPhone4 - this could definitely be my hardware as audio has been quite fiddly with the Shuttle so far.

5. Trailers appearing in the movie library

My movie library is generally stored like this:
Avatar.mkv
Avatar-trailer.flv
...or similar - always <moviename>-trailer (named this way via Ember MM).

Is this no longer the way to do it? Each movie is appearing twice in the library, and one leads to the movie, the other the trailer.

6. Bluray playlists no longer work

In Camelot (well, my 3 months after Camelot SVN) - I was able to click on a bluray playlist file (.mpls IIRC) in the file library and it would play the bluray. This doesn't seem to work anymore. I think blurays now get added to the library though I haven't tried this actually?

7. Not a problem - just some praise

Ok, after all that moaning, some praise - video playback in general is vastly improved over Camelot. Without any tweaking and with no xorg.xonf changing, my TV switched 24/50/60 accurately and plays much much[b] smoothly than Camelot - almost all the slight timing errors (jitter type things) have disappeared, the resume of pause and startup is much smoother, and somehow the brightness/levels seem much better as well although this might be something to do with my receiver as well - but Confluence is certainly much brighter. Overall, although it's hard to put a finger on exactly why, video playback just seems much more natural and accurate - obviously a lot of behind the scenes work has gone on into this and it's a real credit to the devs.

The Add Ons system also seems very simple and efficient. I think a few of the video add ons could do with a little UI finesse in use, but overall the whole system is excellent and easy to use.


[b]My goal with this is to find out whether these are bugs in general that others are running into, or if they're issues at my end.


XBMC is my favourite piece of software ever, on any platform. It's a remarkable effort and I love that it is OS, free, and clearly made by people with love for the job.

Thankyou to the devs for all your efforts. If you're ever in Melbourne, I'd love to buy you a beer.
I'll jump on 5.

Please tell us what your file/folder structure looks like and attach a complete debug log for that scan/scrape session. Maybe you should open separate threads for requested infos about your issues?
I will - once I am sure they're not just issues at my end.

Sounds like #5 isn't, so I will post the required info in a few hours once I am back with the system.
I have to mention that #5 doesn't happen to me with the same naming convention (...and files also created by EMM).
Number 5 happens to me aswell.

Interesting. I thought it was something else, but now I see it's the ones with the trailers in them

EDIT: Also created with EMM.
Ok full debug log. (2mb - pastebin always kills my browser when I cut and paste big things to it so I have stuck it in a dropbox).

This is what was done during this session:

First thing is as soon as I turned on debugging I noticed the UI was at 50fps (I have definitely set it to 60 previously). So I changed it 60, and notice the onscreen reported fps is now 30. Browse around a bit and it stays at 30, so I set it back to 50 - it also is reporting it's running in some ridiculous resolution lik 288 * 420 or something at this point, so I set it to 1920 by 1080 @ 50.

Now the UI seems perhaps more nice and smooth, more like Camelot - so I am thinking something is going wrong with the UI setting of 60hz for some reason.

Next, I browse up and down a long list of movies (abotu 400 entries) - weird pauses are still there.

I then run a clean library, followed by an update library.

Directory Structure @ Pastebin

Shows one of the two big movie directories I have - structure for the other one is the same. Note this is taken from my Windows machine, the actual mount is done via autofs to a local mount point of /smb/homeserver/Movie Library 02/ . Also there's a couple of full bluray rips in there as I am testing the new bluray in library support.

I kill this scan eventually as it appears to be in an infinite loop and adds about 20 copies of Letters to Juliet to the library. This is 20 more than I want, and 19 more than my wife wants Laugh

If killing it was a mistake I can re-run one from start to finish but it's quite late over here and work starts early in the morning.....I will have to do it tomorrow night if so.
#5.

Having same problem.

Used to work fine on Camelot.

What I usually store:
MovieName.mkv
MovieName-trailer.mov
MovieName.tbn
6. .mpls files work fine aslong as your build has libbluray (but better yet just play index.bdmv)


1. unlikly to get fixed until samba.org releases some new smb lib. the one we use is single threaded and as such an extreme bottleneck.
For #4, try setting your XBMC speaker config to 2.0. I had the same problem when it was set to 5.0...
Beta 3 update (vanilla beta 3 install on shuttle xs-35 with network driver added and updated lirc to deal with a newer receiver).

1. Haven't tested as autofs works so well

2. Is gone - although when the UI is set to 60hz my TV reports 1080i input - meaning 30hz is actually send, I think this is where the UI slowness comes from. Setting the UI to 50hz makes it nice and smooth. Probably an xorg.conf would solve this one I guess?

3. Gone

4. (edit) Gone!

5. Gone

6. *.bdmv don't play - does Live actually have lib bluray??
Same for me, #5 is fixed for me but now I have no audio!

Heh, always somethin'.
elupus Wrote:6. .mpls files work fine aslong as your build has libbluray (but better yet just play index.bdmv)


1. unlikly to get fixed until samba.org releases some new smb lib. the one we use is single threaded and as such an extreme bottleneck.

Elupus, you say "just play index.bdmv". Is that from the physical blu-ray disk? Or from a copy of that on the hard disk? I tried to play disks, but it does not work. In Windows, you must first anydvd it. Is there something similar with XBMC Live and how to do it? (still running beta 2). Thanks.
XBMC won't have any decryption stuff - they'll need to be decrypted rips. But even those don't seem to play with live B3 and I kinda thought they would?
Quote:1. Haven't tested as autofs works so well

Any chance you could clarify this.

I'm on D-B2 - haven't upgraded to B3 yet (in the works), but I've suddenly started getting a disconnect on the network (most noticeable when resuming from S3). This never used to happen, so not sure what started it, as I never touched anything. Weird!