Kodi Community Forum

Full Version: Unable to locate package xbmc when install in ubuntu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Ok, update - to get it to work I had to compile from source to get it working. The SVN PPA is broken...

Very basic notes here. I will be updating this as I play with it more over the next few days.

Certainly seems a better way than XBMCLive/Freak so far as all the hardware pretty much works out the box. Networking (wired and wireless, sound, remote, suspend/resume etc). (this is with my Shuttle XS35)
I'm getting the same errors that others are in this thread.

I've tried installing as per the directions provided on the XBMC wiki page:

sudo add-apt-repositor ppa:team-xbmc
sudo apt-get update
sudo apt-get install xbmc
sudo apt-get update

Yet I get the same error as the first poster. So I tried to change the distribution to Lucid (as suggested) then tried to do an update once more. That went through fine.

then I tried to install xbmc and I get the following:

Reading package lists... Done
Building dependency tree
Reading state information...Done
E: Unable to locate package xbmc

So, apparently I'm doing something wrong here.

I should note that this is a completely fresh install of 10.10. This is the first package I've tried to install even. I literally just built the box this afternoon and installed Ubuntu about an hour ago. I applied updates then tried to install XBMC. So far, that's as far as I've gotten on this...

Any help would be appreciated.

PS: I've tied to access the link above for the walk through (http://xbmcstuff.bossanova808.net/?p=80) but it's throwing the following error: Error establishing a database connection.

EDIT: naturally, shortly after trying to get this to work for the past hour and a half...I find a solution: http://wiki.xbmc.org/index.php?title=HOW...Step_Guide

udo apt-get install python-software-properties pkg-config

I did this, changed the distribution to Lucid on both and lo and behold, it worked...naturally.
I've also problems with installing xbmc.

I'm using this guide: http://wiki.xbmc.org/index.php?title=XBMCbuntu

I using Ubuntu 10.4 server and when I typed this:
sudo apt-get install python-software-properties pkg-config
I've got the following:
[sudo] password for dave:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package python-software-properties
E: Unable to locate package pkg-config

Can anybody help me?
Have you tried using the Synaptic package manager to Install XBMC or even the newer Ubuntu Software Center program.
I can't using synaptic because i'm using no GUI like gnome, kde etc.

Or am I wrong?
Maybe you should install a gui or use xbmc live?

(it is not important at this stage but the guide tells you to use karmic mini...and you start by using Lucid Server)

If you dont want to switch to xbmcLive or using a gui.....have you done?:
sudo apt-get update

im trying for over 2 days to install XBMC Sad

please help.

cant find the packages
sudo apt-get update doesn't work either.

Now, I'm trying to install ubuntu 9.10. Maybe it will work with this version.
working on all release except 10.10
users without a GUI can type aptitude on terminal, it loads a text version of aptitude which you can easily use to search packages, install, remove, upgrade/downgrade and anything else.

easy to use provided you can read and use a keyboard.
just add the SVN repo to your maverick installations


the stable ppa only has the srsly outdated 9.11 build and no maverick packages

After a hard reset of the router, everythings works fine.
Hannes The Hun Wrote:just add the SVN repo to your maverick installations...
Thanks Hannes, this worked!
sudo add-apt-repository ppa:team-xbmc-svn/ppa
sudo apt-get update
sudo apt-get install xbmc
Just a note that this adds unsupported/experimental nightly builds to your machine.
Only do this if you enjoy living on the edge. Cool
Pages: 1 2