Kodi Community Forum

Full Version: Can't remove stuff from db
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

strange behavior at Dharma Beta 2:

I wanted to change from using the mapped network drive letter at tv-show source to smb://....
So i removed the source where i set X:\myshows. But i didn't chose 'Yes' at the question, if i want to delete it from the db. (i though: why delete all infos, when i will readd it).
The i added the save samba network share as source (smb:\\server\share\myshows) and he fetched all the infos.
Now i have all episodes twice (at x:\myshows\... and smb:\\server\share\myshows).
I tried to use clean db at video-setting,
i tried to delete the tv show from the db with 'remove from database' and let rescrape it.
But i still have all episodes twice.
My fault or a bug?
That's strange. Hasn't been my experience with Dharma 2.

You said you went from a mapped drive to using smb://, is the mapped drive still accessible when you are doing the clean database?

Maybe you can remove all sources and then confirm that even though the sources are removed that the files cannot still be accessed at those paths and then try cleaning again. Strange.

I'm still a noob with the product, but just thinking out loud.
I will try so disconnect the mapped network drive and clean database again.

----------------
Edit:
i could fix it this way.