Kodi Community Forum

Full Version: Screen image screwed up after using HDMI-Passthrough Onkyo TX-SR508
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello all,

I've installed my new AV-Reciever (Onkyo TX-SR508) which has HDMI Passthrough.

Everything went fine but when i connect my HTPC running Ubuntu Lucid 10.04 with an Geforce G210 graphicscard with HDMI-Passthrough through the Onkyo my image on the television is kinda screwed up. It's still watchable but it looks like the whole image is interlaced of some sort... or an refreshrate error. It has horizontal lines/artifacted with some flickering and non-smooth movements.

This only occurs when running Ubuntu with the Nvidia drivers, (i've tried 185, 195 and 260). When running the vesa drivers from Ubuntu the image is perfectly clear, also in Windows 7 i dont suffer this problem. Connecting the HTPC directly to my TV solves the problem when using nvidia drivers under ubuntu.. it seems like something interfers but since it's only happening when running the nvidia drivers under ubuntu i guess it's a software/setting problem.

Here are soms pictures of what i mean: (the problems are the horizontal lines/artifacts, in the pictures they seem less then they actually are.)

Screwed with horizontal artifacts
https://sites.google.com/site/timberghma...loos-1.jpg

Screwed with horizontal artifacts
https://sites.google.com/site/timberghma...G_7105.jpg

Compare 1
Screwed with horizontal artifacts
https://sites.google.com/site/timberghma...G_7107.jpg

Perfectly
https://sites.google.com/site/timberghma...G_7108.jpg

Compare 2
Screwed with horizontal artifacts
https://sites.google.com/site/timberghma...G_7112.jpg

Perfectly
https://sites.google.com/site/timberghma...G_7109.jpg

Screwed with horizontal artifacts
https://sites.google.com/site/timberghma...G_7116.jpg


Anybody has some clue's for me where to look or what to change? Maybe some xorg.conf settings since i've no clue what to change!
does the 508 have upscaling ? I cant remember, but if you've got that turned on for the xbmc input, that might be causing it to screw up
also try turning off the 508's on screen display.
smithr99 Wrote:does the 508 have upscaling ? I cant remember, but if you've got that turned on for the xbmc input, that might be causing it to screw up

The 508 doesn't have an Upscaling function, so that can't be the problem..

drewy Wrote:also try turning off the 508's on screen display.

Hmm.. good call.. but i've no clue how to turn it off? Can not find this in the setup or anything! You have a clue?

First of al thanks both for responding! I find it strange it _only_ occurs under Ubuntu with the Nvidia drivers enabled.. any thoughts on this?
I have not seen this issue with my setup. Running nvidia 260.19.06 drivers.

Here is my xorg.conf, if it helps...

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  ([email protected])  Tue Oct 20 21:00:15 PDT 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "ONK"
    ModelName "ONK TX-SR508"
    HorizSync       15 - 81
    VertRefresh     23 - 76
    # 1920x1080p @ 50Hz (EIA/CEA-861B)
    ModeLine "[email protected]" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    # 1920x1080p @ 59.94Hz (EIA/CEA-861B)
    ModeLine "[email protected]" 148.350 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    # 1920x1080p @ 23.976Hz (EIA/CEA-861B)
    ModeLine "[email protected]" 74.230 1920 2560 2604 2752 1080 1084 1089 1125 +hsync +vsync
EndSection

Section "Extensions"
    Option "Composite" "false"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "HWCursor" "false"
    Option "NoFlip" "false"
    Option "ModeValidation" "NoEdidModes, NoXServerModes, NoVesaModes, NoPredefinedModes"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "true"  
    Option "DynamicTwinView" "false"
    Option "ExactModeTimingsDVI" "True"
    Option "FlatPanelProperties" "Scaling = Native"

SubSection     "Display"
        Depth       24
        Modes      "[email protected]"
    EndSubSection
EndSection
scaling is set to native, the supported modes seem to have been perfectly communicated from your panel through the onkyo... I have no clue what's happening there.

ahve you already tried to switch resolutions/refresh rates in XBMC to see if the problem still exists?
(2010-10-14, 10:26)Hannes The Hun Wrote: [ -> ]scaling is set to native, the supported modes seem to have been perfectly communicated from your panel through the onkyo... I have no clue what's happening there.

ahve you already tried to switch resolutions/refresh rates in XBMC to see if the problem still exists?
ok,  this is really old but i it the same issue yesterday - how did you fix it?