Kodi Community Forum

Full Version: How to enable VDPAU Scaling in XBMC?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Guys,

I have a feature set C GPU and I know I need to set this feature through advancedsettings.xml in the userdata folder, I just wanted to check with you guys as to whether the text below is what I need or do I need something else in there too?

Code:
<advancedsettings>
  <video>
    <vdpauscaling>true</vdpauscaling>
  </video>
</advancedsettings>

Thanks in advance for your help.
That's all you need.
Great stuff!

Thanks very much.
@bobo1on1

Sorry to trouble you again but I applied the advancedsettings.xml but it did not enable vdpau scaling. SD xvid Playback was visibly not improved and there was no mention of it being enabled on playback in the log (no references to pixmap etc).

I'm guessing I need a later version of XBMC as I am currently running 9.11 Camelot?

Is vdpau scaling only enabled in SVN releases of XBMC or do I need to wait for the Dharma stable release for vdpau scaling support?

Thanks again for your help.
9.11 always used vdpau scaling.
@spiff

I have included an excerpt from the xbmc.log below when playing back an SD xvid. Does this look ok? How can I tell if vdpau scaling is functioning?

Thanks very much for your help.

Code:
06:28:53 T:140228623812672 M:1891532800  NOTICE: DVDPlayer: Opening: /home/lee/v
ideos/TV/Dexter/dexter.s02e12.avi
06:28:53 T:140228623812672 M:1891532800 WARNING: CDVDMessageQueue(player)::Put M
SGQ_NOT_INITIALIZED
06:28:53 T:140228219459344 M:1891532800  NOTICE: Creating InputStream
06:28:53 T:140228219459344 M:1891278848  NOTICE: Creating Demuxer
06:28:53 T:140228219459344 M:1891561472  NOTICE: Opening video stream: 0 source:
256
06:28:53 T:140228219459344 M:1891561472  NOTICE: Creating video codec with codec
id: 13
06:28:53 T:140228219459344 M:1891561472  NOTICE: CDVDVideoCodecFFmpeg::Open() Us
ing codec: MPEG-4 part 2
06:28:53 T:140228219459344 M:1891561472  NOTICE: Creating video thread
06:28:53 T:140228219459344 M:1891561472  NOTICE: Opening audio stream: 1 source:
256
06:28:53 T:140228182107920 M:1891561472  NOTICE: running thread: video_thread
06:28:53 T:140228219459344 M:1891561472  NOTICE: Finding audio codec for: 86017
06:28:53 T:140228219459344 M:1891561472  NOTICE: Creating audio thread
06:28:53 T:140228173715216 M:1891409920  NOTICE: running thread: CDVDPlayerAudio
::Process()
06:28:53 T:140228182107920 M:1887965184  NOTICE:  fps: 23.976000, pwidth: 640, p
height: 352, dwidth: 640, dheight: 352
06:28:53 T:140228182107920 M:1887965184  NOTICE: Display resolution DESKTOP : 12
80x720 @ 60.00 - Full Screen (12)
06:28:53 T:140228623812672 M:1886441472  NOTICE: Using GL_TEXTURE_2D
06:28:53 T:140228623812672 M:1886314496  NOTICE: GL: Selecting Single Pass YUV 2
RGB shader
06:28:53 T:140228623812672 M:1885831168  NOTICE: GL: NPOT texture support detect
ed
06:28:54 T:140228173715216 M:1884815360  NOTICE: Creating audio device with code
c id: 86017, channels: 2, sample rate: 48000, no pass-through
if you get really subpar picture compared to the lanczos3 scaler in dharma, you know it's being used. the vdpau scaler really isn't all that fancy. anyways, as i said, 9.11 always turned on vdpau upscaling. so you using 9.11+vdpau is enough info - you're using it. oh, and enabling debug logging is always a good idea.
Ok great, thanks very much for the tips spiff.
adr3nal1n Wrote:@bobo1on1

Sorry to trouble you again but I applied the advancedsettings.xml but it did not enable vdpau scaling. SD xvid Playback was visibly not improved and there was no mention of it being enabled on playback in the log (no references to pixmap etc).

That's because we disabled xvid support for vdpau because it doesn't work, you can still enabled it using advancedsettings.xml and get weird blocky video Smile
Ah, that explains it then!

Thanks guys.