Kodi Community Forum

Full Version: [LINUX] HOW-TO create a XBMC server for diskless PXE network booting clients
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
you made a typo. it's lars-opdenkamp, not lars-odenkamp
Confused failed copy/paste
tnx Smile
dushmaniac Wrote:create a directory /var/lib/tftpboot/pxelinux.cfg and create a file "default" in that dir.

put this in the file:
DEFAULT vmlinuz ro initrd=initrd.img nbdroot=x.x.x.x nbdport=2000 xbmcdir=nfs=x.x.x.x:/var/lib/xbmc-diskless/overlay xbmc=autostart quiet splash
replace x.x.x.x by your server's ip

At the moment I have installed xbmc-diskless-server package and configured Ubuntu's dhcp server as described in this thread. After copying the files (pxelinux.0, initrd.img and vmlinuz), I tried to boot my asrock 330 from LAN. At the start up sequence it tries to load several files, including pxelinux.cfg/default, but gives the following error message:

Quote: Unable to locate configuration file

Having read some of the posts, I checked whether /var/lib/tftpboot/pxelinux.cfg/default had been created properly, which is the case.

What can I do to fix this? Huh
Thanks for putting time in getting this done.

I'm having some problems running this script, (/bin/grep: /var/lib/xbmc-diskless/target/etc/apt/sources.list.d/*: No such file or directory) I'll look at the code later, just some suggestions for now:

1. you should allow users to point to a pre-downloaded iso
2. should provide paths of where stuff is being placed
I haven't spent time on this lately (pvr development is taking most of my time).

sounds like pxelinux.0 is loaded but it can't find it's config files. the pxelinux.cfg directory has to be in the same directory as pxelinux.0 if you're using the suggested configuration.

the script isn't checking for return codes properly at some places. something probably went wrong when the ppa entries were added to sources.list
1) what do you mean by pre-downloaded image? a prebuilt squashfs image? in that case you shouldn't be using the first three options ("create", "pack" or "upgrade").
2) you can change the paths in the config files. not sure if I documented that, but there's a default config in /etc/default/xbmc-diskless.conf that will be overridden by /etc/xbmc-diskless.conf if it's present. you can configure all paths there.
How well is this type of setup performing for everybody using it?

This type of setup seems very similar to having your main hard drive on a SAN/NAS (using iSCSI, etc).

I would think it would be kinda laggy when retrieving lots of thumbnails, etc.
you get most of the data over nbd, with performance comparable to iscsi. the nfs part is the slowest and it is minimised to /home/xbmc and /etc. "slowest" doesn't mean it's slow at all, but it's slower than nbd. everything else is persisted in your ram only.

so the performance is pretty good. never benchmarked or measured anything, but my boxes show the main xbmc window in about 10 seconds, which is fast enough for me. never experienced any lag at all.
I'm using it on a 100M network with an atom d525 frontend and once booted, it's fast and perfectly useable.

Just boot time is more than 10s in my case (about 30-40s, but my image is with 550M nearly double in size as the original) and the only problem is, that I didn't get suspend to ram working.

Don't know if this may work in diskless setups anyway.
the image size doesn't matter for nbd. the connection speed and programs that you're starting on boot do make a difference.

suspend to ram doesn't work because the root device is gone when your box wakes up.
what's the best way to update my image with latest xbmc pvr package? or do i need to create a new image?
it's explained in the OP.
and because of a problem with the old package, you probably have to execute the "fix commands" that are posted there too.

I'm doing a fresh install on an ubuntu 10.04.2 LTS
Linux rphnsvr 2.6.32-24-server #39-Ubuntu SMP Wed Jul 28 06:21:40 UTC 2010 x86_64 GNU/Linux

When I choose create image from the main menu I get a message saying cant find package xbmc-live

Also when I do an apt install for xbmc-live it says the package is mentioned by other packages but cannot be found.... I did this step sudo apt-add-repository ppa:lars-opdenkamp/xbmc-diskless and apt looks ok, its had the apt-get update run etc.... any ideas? is there an issue with the repository at this time?
you probably didn't select any PPA in the wizard.
select the teamxbmc ppa or my pvr ppa (opdenkamp) and it'll find the package. I did a clean install yesterday evening using the pvr ppa and it works fine.

the other ppa's listed there might be a bit outdated. haven't checked those for months
dushmaniac Wrote:it's explained in the OP.
and because of a problem with the old package, you probably have to execute the "fix commands" that are posted there too.

sorry, i didn't realized it :/
It workes like a charm now. Thanks for the new package Big Grin
I've got xbmc-diskless up and running (using opdenkamp ppa), tftp etc. is fine, but XBMC won't start up on my client. It tells me:

"XBMC needs hardware accelerated OpenGL rendering. Install an appropriate graphics driver."

The client has Intel GMA950 graphics (which I think are OK according to the XBMC hardware list) and I thought the problem was that a Nvidia version of glx was being loaded so I swapped that out for the X.org version but it still doesn't work.

My /var/log/Xorg.0.log is here:


If anyone could take a look and let me know if they see my problem I would really appreciate it. Alternatively if there's somewhere else I should be looking to diagnose the issue then a pointer would be welcome.

Thanks for any help you can give.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17