Kodi Community Forum

Full Version: [LINUX] HOW-TO create a XBMC server for diskless PXE network booting clients
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
hi all,
i'm very enthousiastic about this!

i installed the script on myserver, got xbmc booting over the network.
however, provisioning does not work. i created a test file in:
/var/lib/xbmc-diskless/provision/default/.xbmc/userdata/RssFeeds.xml

did a
sudo chown -R 1000:1000 * in /var/lib/xbmc-diskless/provision/default/

then
sudo xbmc-diskless.sh

and selected 'provision'

then rebooted my xbmc client.
but the rss feed did not change.

any ideas?
the provisioning only triggers for new installations. once a machine has been booted, it leaves a file in it's filesystem indicating that it's been provisioned. you wouldn't want to overwrite all your configuration files on each boot.

if you want to reprovision an installation, you have a couple of options:
- remove the client's overlay from /var/lib/xbmc-diskless/overlay OR
- remove the file .provisioned from the client's overlay OR
- remove the file ~/.provisioned from your client

reboot the client and the new config will be written.
sadly, all 3 options did not work...

- remove the client's overlay from /var/lib/xbmc-diskless/overlay OR
i removed this on my server, rebooted client, nothing changed
- remove the file .provisioned from the client's overlay OR
did this on the client, then rebooted the client, did not change to new rss feed
- remove the file ~/.provisioned from your client
same as above....

i'm overlooking somthing here... but what?
i would likt to setup one xbmc client, then copy config info to server and then merge it with the image. i think that's what provisioning is for?
i installed rc2 live updated to this pvr version. set db to 13. but still no pvr addons with rc2. anyone?
I think the pvr addons are in addons/installed addons/pvr or something like it. You wont find them when you go to "get addons".

cheers
@basco
the provisioning process does the following things on the client:
- if a file /home/xbmc/.provisioned exists, bail out
- look for a file named default.tar.bz2 on the nfs share (on your server, it'll be /var/lib/xbmc-diskless/overlay/provision/default.tar.bz2). if it exists, extract it's contents in /home/xbmc
- look for a file named XX.tar.bz2 (where XX is the nic's mac address without colons) and extract it
- create the file /home/xbmc/.provisioned

little example:
I want to distribute some advancedsettings.xml to each client. On my server, I created a dir /var/lib/xbmc-diskless/provision/default/.xbmc/userdata and I put the advancedsettings.xml in there.

On one client, I got an old irman infrared receiver, which needs a specific lirc config.
The lirc config is placed in /var/lib/xbmc-diskless/provision/[mac of client]/config/lirc/hardware.conf. The xbmc config for the receiver went to /var/lib/xbmc-diskless/provision/[mac of client]/.xbmc/userdata/Lircmap.xml.

Now I run xbmc-diskless.sh and choose "provision" which creates the archives. The files will then be distributed to each new client. The "default" file is distributed to all clients and in the next step the client specific ones are copied. The latter can overwrite the first.

It's a bit complicated at the moment, but I got some plans for it for the next version that will make it easier.

About the pvr addons: please provide a full debug log via pastebin.
does diskless server also include tvheadend? or am i able to include this?
it's not included by default, but you can just "sudo apt-get install hts-tvheadend" to install it on your server.
hi,

today i tried to setip diskless xbmc.
i used the dchpproxy method to boot xbmc via lan.

but now i have the problem, that xbmc just loads and loads and loads on the booting screen.
which logs should i check to see what's wrong?

other question: is it normal, that the xbmc logo on booting screen is in black&white?

hope you understand my problem ;D

regards
with sudo xbmc-diskless.sh check i get the following output:

Loading the default configuration
Checking your configuration:
image present: yes
inetd running: yes
tftpd running: yes
tftpd (69) listening: yes
nfsd running: NO - clients will not be able to persist data
mountd running: NO - clients will not be able to persist data
statd running: yes
portmap running: yes
/etc/exports has overlay: yes
portmap (111) listening: yes
nfs (2049) listening: NO - clients will not be able to persist data

Sad
the boot logo should be black&white indeed.

clearly nfs is not running for some reason.
try this:
Code:
sudo apt-get install nfs-kernel-server
sudo dpkg-reconfigure nfs-kernel-server
sudo /etc/init.d/nfs-kernel-server restart
sudo xbmc-diskless.sh check

if it still doesn't work, do you see any error in /var/log/daemon.log?
i figured it out.

problem was in /etc/exports.

it was like:

/var/lib/xbmc-diskless/overlay/ /(rw,no_root_squash,async,no_subtree_check)

and i changed it now to:

/var/lib/xbmc-diskless/overlay/ 255.255.255.000/24(rw,no_root_squash,async,no_subtree_check)

now erverything is on yes in the check.

but my client still hangs on xbmc booting screen Sad
try and remove the quiet and splash command from the following line in var/lib/tftpboot/pxelinux.0

Quote:DEFAULT vmlinuz ro initrd=initrd.img nbdroot=192.168.64.1 nbdport=2000 xbmcdir=nfs=192.168.64.1:/var/lib/xbmc-diskless/overlay xbmc=autostart probe_mask=4 vga=0x361 quiet splash

then you should see whats going on!
in this file are only cryptical characters :/
ok i found the line.
correct file was

/var/lib/tftpboot/pxelinux.cfg/default


my clients hangs on:
mounting the NBD root...
Connection: connection timed out

few lines above my client seems to lease ip 192.168.1.31 without errors. but the ip is already used by a other client. i think that's the problem :/
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17