Kodi Community Forum

Full Version: Choppy playback ION Ubuntu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm having some issues with choppy playback on my ION system. When i look at any 720p content, may it be HDTV or Bluray I get some occasional choppy playback.

Every now and then it stutters, and sometimes the picture freezes and then returns in superspeed to catch up with the audio.

$ for i in 24 60; do xrandr -r $i; nvidia-settings -q RefreshRate | grep -o "[0-9][0-9].*Hz"; done

Section "Device"
        Identifier "nvidia"
        Driver  "nvidia"
        Option  "NoLogo"              "true"
        Option  "DynamicTwinView"     "false"
        Option  "FlatPanelProperties" "Scaling = Native"
        Option  "ModeValidation"      "NoVesaModes, NoXServerModes, NoVertRefreshCheck, NoHorizSyncCheck"
        Option  "UseDisplayDevice"    "DFP-1"
        Option  "ModeDebug"           "true"
        Option  "HWCursor"            "false"

Section "Screen"
        Identifier      "screen"
        Device          "nvidia"
        SubSection      "Display"
                Modes "1920x1080_60_0" "1920x1080_24"

Section "Extensions"
        Option  "Composite"           "false"

Reading speed from media drive:
$ sudo hdparm -t /dev/sdb

Timing buffered disk reads:   78 MB in  3.03 seconds =  25.71 MB/sec

Settings in XBMC (Dharma 3)
Render Method: Auto Detect
Allow hardware acceleration (VDPAU) YES
Adjust display refresh rate to match video YES
Sync playback to display YES
A/V sync method Audio Clock
Allowed error in aspect ratio to minimize black bars NONE
VDPAU Studio level color conversion NO
Video Post-procession Disabled

I've tried alot. Always have the same freaking lag. What should I try?
Start with posting a debug log Smile
interesting, while playback the HttpApi goes complete bonkers

are you controlling XBMC via web remote? could you try to disable it in settings?
I second the choppy playback.

Using XBMC svn 35017 on a Shuttle XS35 ION2, Ubuntu Maverick kernel 2.6.35-22.

Playing 720 or 1080p suddenly seems to miss some frames once in a while. Looking in the log I can see some messages concerning discontinuity, it seems bad.

What I did when making this log file:

- Started XBMC, it stalled at a black screen, had to click using my mouse before it continued starting up(!)
- Browsed the settings for a few seconds, changed nothing
- Played The A-Team 720p which ran perfectly on Dharma Beta 2.
Did not seek forward or backwards, just played/resumed it immediately 10 minutes in the movie.

Every few seconds it stutters a bit. The same goes for Avatar 1080p.

Where does this discontinuity all of the sudden come from?

Yes, I am controlling xbmc via a web remote. I don't have any lirc yet.
peterbo Wrote:Where does this discontinuity all of the sudden come from?


Known issue with DTS, it's already fixed.
The following thread fixed it for me

bobo1on1: I just compiled last night from latest svn, should that not reflect a fix on my installation then?

Sorry if I am asking a noob question.
Don't think you have latest SVN. Your change (SVN:34955M).

That puts you to a change from Oct 22nd (depending where you live).

Sync up again.
i also have occasional stuttering while HD playback.
i dont control xbmc via web interface, but with lirc + X10 remote.

@johnwilliams: Did the links solve the problem for you?