Kodi Community Forum

Full Version: [LIVE] dharma beta 4 crashing when trying to play a video! Help!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Ok i just installed the lates beta 4 on my zotac ionitx-a-u, I also updated the nvidia drivers. Everytime i want to play any type of video i get a black screen with a little "X" in the middle and it resets. not sure why everthing was working for me with the beta2......anyone have the same problem? anyone know how to fix it??
Umm, log? Hard to help you if we cannot tell what's failing.
I second and have a log on Acer Revo.

http://pastebin.com/dd5EucsT

MB
shit I just upgraded to beta 4 as well here is my crash log, anytime audio is trying to be played it crashes.

going into TV shows and TvTunes starts to play my theme.mp3 I got a crash. going into movies and trying to play any movie I get a crash

http://flomaster.pastebin.com/GVRVg5kg

I have it narrowed down to be audio related at the moment I can't watch or listen to anything


-=Jason=-

EDIT: I disabled TvTunes and went into tv shows and it did not crash until I actually tried to play a show.

fuck this sucks big time. hopefully when I get off work there will be a fix
Happening in dharma 3 also. Nvidia driver version 260.19.12 may be the culprit here.

http://www.nvnews.net/vbulletin/showthread.php?t=156665
I down graded to Nvidia 260.19.04 still getting crashes.

I did the following to upgrade

sudo apt-get update
sudo apt-get upgrade xbmc

I didn't upgrade a kernel or anything just a few lib packages and xbmc.

FML looks like I'll be installing xbncFreak beta3 from scratch again.

the old saying "if it aint broke, don't fix it" comes to mind here

seems like the log says its unable to open "audio mixer" thats the new xbmc audio engine in the works. perhaps thats the cause

going to addons > Audio Mixer = this screen for me
Image
-=Jason=-
I dont think its the driver, since I didnt experience this at all, I recon its your kernel or OS...

karmic xbmcbuntu style and whatever I throw at it no crashes, though it did crash once on beta3 a quick xbmc re-install fixed it.
Same problem here.After update to Beta4 no MP3 and no Videos are starting.It ends in reboot XBMC.
My System is AsRock ION 330 with Ubuntu 9.10 and NVIDA 2.56.52 Drivers.
The only thing that works is looking Pictures.
which build number is beta4? just trying to reproduce this on my lucid64 XBMCbuntu box... the svn35068 from 10/28 is working fine here
I had exactly the same problem as ferrari2992.

Also when starting alsamixer from the console I get this

Code:
ALSA lib conf.c:3441:(snd_config_hook_load) /home/xbmc/.asoundrc may be old or corrupted: consider to remove or fix it

So, I removed my .asoundrc with

Code:
mv /home/xbmc/.asoundrc /home/xbmc/.asoundrc.old

after a reboot video and audio playing correctly.

Hope this helps others
Haven't had this issue, but I do remove xorg.conf and .asoundrc when upgrading, as the scripts in /etc/xbmc/live.d/ should recreate these.

You can do this manually as well, but it should also recreate them on a reboot if they don't exist.

This should not be required though if you have a working alsa and X11.

P.S. I run Dharma B4 on Karmic on an ASRock ION 330HT with nvidia-glx-260 (260.19.12) and alsa-base 1.0.22.1
Turn off lcd/vfd support.
im running SVN#
Code:
[email protected]:~$ apt-cache policy xbmc
xbmc:
  Installed: 2:10.00~svn35068-lucid1
  Candidate: 2:10.00~svn35068-lucid1
  Version table:
*** 2:10.00~svn35068-lucid1 0
        500 http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     1:9.11-lucid3 0
        500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/ lucid/main Packages
[email protected]:~$

my Nvida Drivers are now 260.19.12

Alsa versin is v1.0.22

I now have access to Audio Mixer Smile

I deleted my old .asoundrc file a new different one has been created. my videos now play Smile with out crashing But I have no sound. Thris brings me back to this thread where I have been asking what F*ing settings I need to use with this new 04 Nvidia script.
http://forum.xbmc.org/showthread.php?tid=83175

the script has created a new .asoundrc file apon reboot that is fine and dandy, but I need to know what audio settings I should have for passthrough and how to get analog audio working as well.

-=jason=-
I think to get audio from both analog and hdmi you have to set it up like this.

output : hdmi
Speaker config : 2.0
disable dolby and dts
audio output device set to custom "plug:both" without the quotes
passthrough doesn't matter with this config(I think). but set it to "plug:both" to be safe. This is untested btw Smile Hope it helps

cheers
Pages: 1 2