Kodi Community Forum

Full Version: SVN 35547: Weather says "No internet connection", slow lookups on network - ipv6?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Running Ubuntu 10.10 on a Lenovo V200, nic is wireless Intel AGN4965.

Just installed the svn 35547 and whenever I try to load the weather, it says "Internet connection required". The weather service is definitely up as I accessed the url through a browser perfectly.

I think it might have to do with the ipv6 settings that have been fiddled with lately. Anyway, Ubuntu has always been setup to boot with the flag ipv6.disable=1 in the grub config file.

Do I have to disable ipv6 within XBMC also? If so, I cannot seem to find the setting.

When using the internet for anything else, it takes several seconds for it to respond.

Debug log, if helpful:
http://pastebin.com/uNJ2Uafz
I don't think it is the weather failing but the check to google.com is failing. That is how the internet connection is tested:

19:51:14 T:3079300976 M:1538732032 INFO: easy_aquire - Created session to http://www.google.com
19:51:15 T:3040045936 M:1538936832 WARNING: FillBuffer: curl failed with code 28
19:51:15 T:3040045936 M:1538936832 ERROR: CFileCurl::CReadState::Open, didn't get any data from stream.

In your case, it seems to have issues getting to google.com.

The other sites in your log (rss, weather) seem to be okay.
Thanks for the reply.

I still have the problem, add-ons, weather, skins - nothing can be downloaded. It hangs for a couple of seconds when trying and then stops or gives me the "no internet" message.

http://www.google.com is easily accessible in chrome and firefox. I really don't get it, I have checked my /etc/hosts file which seems fine and I have absolutely no blocking enabled for any ip/network address in my router.

I tried deleting my user dir (.xbmc), same thing.

Any clues for what I could try to do? Have already downloaded the latest svn (35572), no change.

The computer is using a wireless network.
Did you try to disable ipv6 via the advancedsettings.xml file?

disableipv6 set to true.

Something like:

<advancedsettings>
<network>
<disableipv6>true</disableipv6>
</network>
</advancedsettings>
Thanks a lot, that did the trick!
stupid question though... have you figured out what is wrong in your IPv6 setup? Disabling IPv6 is only a stopgap measure, it'll have to be enabled sometime soon again anyway...

MD
most likely a buggy nic and/or router.
apperantly it happens with some non ipv6 routers probably in combination with certain NICs.

I have a dlink DIR-655 and on the new ion 330ht I get this but problem while older ion330 seem to be ok. Although I havent tested much on the older one.

I understand some people are concerned about disabling ipv6... I am no expert on this but...If your router, like mine, does not support ipv6 at all... stop working on fixing Ubuntu/xbmc disable it or get a new router.

BTW, why do you need ipv6 today? If you disable it what exacly do you miss. My internet seem to work pretty good on ipv4.
I'm having the same problem. I'm running Kubuntu Lucid and Dharma and have had connection issues while indexing, and absolutely no luck with skins and add-ons. Where is the advancedsettings.xml file from tslayer's post?
dgrayfromdc Wrote:I'm having the same problem. I'm running Kubuntu Lucid and Dharma and have had connection issues while indexing, and absolutely no luck with skins and add-ons. Where is the advancedsettings.xml file from tslayer's post?

From the Wiki -The "advancedsettings.xml" file, which does not exist by default, may be created by a user in their "\UserData\" folder.
Please consult your plaform specific FAQ for the appropriate location.
NOTE! This file will not exist unless created by the end-user, meaning YOU!
The XBMC software will never write to this file, so any settings you define will not be overwritten by any XBMC GUI settings.
So you can only edit this file manually on your computer, via a text-editor (like Notepad in Windows or a XML-editor).
All the settings available outside of the GUI are documented on this page.
Aenima99x Wrote:From the Wiki -The "advancedsettings.xml" file, which does not exist by default, may be created by a user in their "\UserData\" folder.
Please consult your plaform specific FAQ for the appropriate location.
NOTE! This file will not exist unless created by the end-user, meaning YOU!
The XBMC software will never write to this file, so any settings you define will not be overwritten by any XBMC GUI settings.
So you can only edit this file manually on your computer, via a text-editor (like Notepad in Windows or a XML-editor).
All the settings available outside of the GUI are documented on this page.

Thanks!! I just came back over to post that I had found it on the wiki page. For my setup (linux) it resides at:

Code:
$HOME/.xbmc/userdata

Thanks for the tip about the file being user created! I probably would have stumbled a bit before figuring that out.
Just wanted to follow-up, worked like a charm!! Thanks!!! Big Grin Nod
After a full day of exploring add-ons and weather updates, the same issue has returned.

Here is a post of my advancedsettings.xml file:
Code:
<advancedsettings>

  <network>
    <disableipv6>true</disableipv6>
  </network>

  <moviestacking>
    <!-- movienamea-xvid.avi, movienameb-xvid.avi -->
    <regexp>(.*?)([ ._-]*[a-d])(.*?)(\.[^.]+)$</regexp>
  </moviestacking>

  <videolibrary>
    <!-- default set to false to prevent xbmc from removing items from the database while updating -->
    <cleanonupdate>true</cleanonupdate>
    <!-- hide empty series in the video library -->
    <hideemptyseries>true</hideemptyseries>
    <!-- separator used for multiple artists/genres in tags. Note, this is *space* *slash* *space* -->
    <itemseparator> / </itemseparator>
  </videolibrary>
  
  <videoscanner>
    <!-- Set to true to silently ignore errors while scanning videos -->
    <ignoreerrors>true</ignoreerrors>
  </videoscanner>

</advancedsettings>

As I posted before, the solution worked. Then without provocation, or further tweaks, it started all over again. Symptoms are "Internet Connection Required" error when trying to look at weather and repeated database connection errors when my video library is being scanned. (Thus the <ignoreerrors> setting)

My newly added add-ons function, although sometimes it takes a few tries for the content to play. I can still add more add-ons as well. But the weather service has gone out again and the library updates are buggy. Any other thoughts? :confused2:
I also keep getting the "Internet connection required" message when checking the weather. Interestingly the current weather icon is shown at the top of the screen next to the date/time. All other network functions (add-ons, scrapers, shares) appear to work as well.

I run the git builds and this has been happening for at least 2 months maybe more. I didn't raise the issue earlier since I thought it was the usual breakage that occurs when running git builds.

Disabling ipv6 as suggested didn't help.

Update: For some reason it takes at least 50 seconds for XBMC to report a "Connected" state in System info after starting. Only then can I access the weather add-on.
amak79 Wrote:I also keep getting the "Internet connection required" message when checking the weather. Interestingly the current weather icon is shown at the top of the screen next to the date/time. All other network functions (add-ons, scrapers, shares) appear to work as well.

I run the git builds and this has been happening for at least 2 months maybe more. I didn't raise the issue earlier since I thought it was the usual breakage that occurs when running git builds.

Disabling ipv6 as suggested didn't help.

Update: For some reason it takes at least 50 seconds for XBMC to report a "Connected" state in System info after starting. Only then can I access the weather add-on.
I have the samen problem with 10.0, then disappeared in 10.1 and now its back in the latest SVN builds.
Pages: 1 2