Kodi Community Forum

Full Version: Shutdown/Suspend issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
First I'd like to point out that no, it's not the usual suspend doesn't work issue... I have done some searching. Smile

Having never used linux before, the last 48 hours have been a nightmare of troubleshooting, largely with wireless related issues. Now almost everything is working.

The last problem was that suspend wasn't waking from USB. I solved that from reading other threads. Then suspend was auto-restarting. I also solved that from the help on this board and the wiki.

The problem now is that I have "shutdown" set to suspend, but while the "suspend" option works perfectly well, suspending and waking via usb, if I go to "shutdown" the computer blinks a _ against a black screen for a while, then just reboots back into XBMC.

Is there anything I need to change in order to get shutdown suspending properly? I assumed once I got suspend to work the shutdown that is set to suspend would work as well, but that doesn't seem to be the case.

Just to add some detail I should have initially added, this is on Dharma RC2. Unfortunately not knowing much of linux, I'm not sure what version of ubuntu it is, but if it helps it's the one that comes with the current xbmc live camelot download. The computer is a Revo 3610.

Thank you for your help.

do some searches on the "upower" package. If you install and configure that properly it should fix the problem
blm14 Wrote:do some searches on the "upower" package. If you install and configure that properly it should fix the problem

Thanks for the help.

I apologize if this is a dumb question (again, linux newbie) but when I run the "sudo apt-get install upower" command, I get a "Couldn't find package upower" response.

At first, I noticed my wifi wasn't working (potentially another issue I'm going to have to work on... getting it to resume after suspend), but after rebooting I now have a connection again but I continue to receive that message.

Edit: Furthermore, I appear to be running Ubuntu 9.10, which may be part of the upower issue, as the wiki says that's needed for 10.4 (and the first package update I found on the UbuntuUpdates website is for 10.04)