Kodi Community Forum

Full Version: Jitter/stutters on fast forward / rewind
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

I have a shuttle xs35gt and I have tried xbmc live (xbmc-Dharma_rc2) and openelec and I have the same issues with both where when ever I forward or rewing I get stutters (framerate drops massively for a few seconds) and then returns to normal.

I have a debug log here:


The forwarding starts from line 426 and play is line 436.

Is there any reasons this is happening? It happens with vdpau on or off and it is a little frustrating.

I have 2gb ram and I thought the processor would be sufficent. Any thoughts?

I think it might be because of the

CDVDPlayerAudio:: Discontinuity

on line 439.

Could this be right and what could be causing this?

This is probably fixed in r35340.

Thanks for the reply but I have tried it again using an update -

This uses SVN:35615 and I still have the same issue.

This shouldn't be a hardware limitation right? The memory and CPU usage do not really spike at all and the audio is perfect.

I went through a bit of pain and installed windows 7 (from a 2gb USB) and the forward/rewind issue does not happen there.

I would really prefer to go back to Linux/Live though. Has anyone else got the problem, or is it something easy to fix?

Bump - I tried with Dharma final also and still same issue.

Does anyone have any ideas? Or, is there any more information I can provide?

Bump sorry.

I still have this issue with live/openelec versions. It doesn't happen as much on rewind as it does on fast forward and never with skips?

Is this a systematic issue or just something with the shuttle xs35gt or just my build?

Can anyone help?
I have the same issue.
Using an i3 540,2 gig ram,ati 5450 (mainly using ati because intels 24p bug).

And have tried both 10,0 and 10,1 xbmc live.

in windows it is fine and reach at most 10% cpu usage (avi files and ff,rew)
If i use ff 2x i can ff for 4-5 sec and hit play and it works but anything over 2x immediately leads to stutter after pressing play for up to 10 sec.
Ex if i do ff 4 for 1 sec and press play it takes longer to get it to play normally then it would have take to play the same part without ff.

First i thought it was because i used a ati board and had vdapu on but.
I have tried all possible combinations with vdapu,screen sync,etc but see NO change at all between the settings.

And jumps work fine.
Bump still same problem on 10.1 also.

Any ideas?
Anyone have any ideas? It doesn't happen in the windows build.

I have tried turning on/off most settings but to no effect.
Bump for a bit of help!
I had the same problem on Ubuntu 10.10, and now 11.04 and my machine is quite beefy for an HTPC.

Phenom II X4 @ 3.4Ghz, 8GB DDR3, nVidia GT240. Using VDPAU, though I have not tested to see if that has anything to do with it.

It seems to be worse the longer your seek, and the higher the bitrate of the file (SD content stutters for minimal, if any, amount of time - high bitrate HD content can stutter for a few seconds (video stuttering, with audio fine) before it gets its footing again.

All of my content is remote on a plug computer on the LAN via gigabit ethernet and being accessed via SMB shares... I have not had the time to switch things over to NFS but I doubt it would make a difference. Also jump works fine for me as well.

It's pretty annoying considering the muscle available.
Bump again

Thanks for posting binaryjay. From asking around it does seem to be affecting other users also. Maybe all on Linux?

This seems like a pretty bad issue in terms of functionality?

I know the developers are very busy but does anyone know the cause of this. Or, is there more information we can provide to help sort it out?

It doesn't happen on Windows either.
Plea for help now!?

If anyone else has the issue please shout. Is there anything I can do to help get to the bottom of this?
I am just trying to figure out if this problem is systematic with Linux, or just on my system.

If it is systematic then how can it be fixed?
Pages: 1 2