Kodi Community Forum

Full Version: Shutdown and Hibernate doesn't work, can't change system setting
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

i got a problem with Dharma 10.0 installed with ubuntu 9.10. I can't shutdown or hibernate my system via xbmc. So i read the forum and found the setting: setting --> system --> powersaving --> shutdown function
But: I can't change she setting there. It only shows "hibernate"

What can i do to activate the shutdown funktion? In 9.11 the shutdown works fine.
still got the problem
I am not sure if it is supposed to be handled in 10.0 or not but a lot have changed since ubuntu 9.10. If not handled someone needs to write an upgrade kit... Turn on the debug logg and see if you have permission problems and or missing services. Look for freedesktop. Without a documented migration path you may be better of installing live 10 from scratch.
I too have this problem and it's really frustrating.

I just upgrade both of my XBMC clients to 10.0. One of the clients (a custom build PC) works fine, the other (an Acer Revo) does not have the option to shutdown, only "Suspend" and "Hibernate".

I've done everything on this page: http://wiki.xbmc.org/index.php?title=Ubu...end_/_Wake . Including editing "custom-actions.pkla" and using hal. Nothing seems to work. The frustrating part about it is I have another machine whose configurations are near identical and it's working fine. Any advice would be really appericated.


After future research I noticed that client that was working correctly had the process "/usr/bin/dbus-launch --exit-with-session sh /home/xbmc/.xsession" running, while the broken client did not. Tried to manually launch it and immedately noticed that dbus-launch disappeared from the broken client. Reinstalled dbus and boom, problem solved.

sudo aptitude reinstall dbus
# Now Reboot
Same problem here. After installing XBMC 10.0 (I'm running Live installed to the HDD) I've lost the ability to shutdown & suspend from within XBMC.

Everything worked perfectly for months & months prior to 10.0; seems the update broke this for me. (I've done no other changes.)

I'm fairly certain it's not the USB autowake bug (because I don't get an immediate re-wake, the XBMC GUI simply flickers but really does nothing - I know this because the scrape continues instead of restarting).

I've tried everything else from the wake/resume wiki page & was hoping the dbus reinstall mentioned here might be my fix, but alas - no dice.

Anyone have other thoughts?
I have the same issue to with the Shutdown function not working - http://forum.xbmc.org/showthread.php?tid=88821