Kodi Community Forum

Full Version: Laggy or Jumpy Playback
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey there. I am a total noob, please bear with me.

My playback gets laggy especially with high def or larger files.
I am running XBMC live Darma 10.0 r35648 on a computer with
Intel DH57DD motherboard
Intel i3 540 processor
4GB ram
1.5TB caviar green

here is my log file
http://pastebin.com/DnmN3XvB

Thanks a bunch
Two problems here, the dts audio stream has messed up timestamps, our a/v sync algorithm can't handle that, and you're playing h264 1080p without hardware acceleration, but it seems your cpu can handle that.
How would I go about fixing the audio. and with regard to the video. My cpu doesn't appear to be stressed by the load? any suggestions?
You can try encoding the audio to ac3, but I'm not sure if it's possible to fix the timestamps after they have been messed up.
Oh I understand. It is the movie that is messed up not so much my player. Thank you very much.
well...

Keriderf Wrote:My playback gets laggy especially with high def or larger files.

but you provided only a debug log with playback of your Salt rip. so either this happens with a lot of movies, or only on some occasions such as this file. that's some information you have to provide to us. output of mediainfo might also be helpful for affected files.
You might have a lot of movies with dts audio Smile
Quote:You can try encoding the audio to ac3, but I'm not sure if it's possible to fix the timestamps after they have been messed up.

http://forum.xbmc.org/showthread.php?tid=89517

pretty hackish, but it seems to have worked...
I have noticed it before in other movies. even a couple standard def movies but not as frequent. I thought maybe it was a dropped frame or something. But then I do have other H.264 movies that play without a hitch so i thought i would go back and see if i could find spots where movies are always laggy