Kodi Community Forum

Full Version: [live-usb] help with hdmi audio
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Ok, so im a total linux noob, but ive managed to get pretty far by reading these forums. BUT I DON'T KNOW HOW TO GET HDMI AUDIO WORKING

So far, i've installed xbmc 9.11 on a usb, took out the nomount in right files to get to the hard drives, made a permanent storage with toporesize, got wireless working with wicd curses, and updated the nvidia driver and now can get hdmi out working on my tv.

the nvidia driver gave me a bit of trouble. I downloaded the latest driver tried the sh ./*.run, ran the install, but could not find a way to quit X.

then i did an apt-get upgrade command, the system told me something about openg GL not supported and ibelieve this quit the X and hence was able to run the nvidia *.run file and install it.

oh, and i had to add Option “ConnectedMonitor” “DFP-1″ to xorg.conf. before i did that the x server would not show up on my tv, but if i switched to command line, it would show up on my tv. however, after adding the option above, the x server only shows up if the tv is connected. if i want to work on xbmc on just the laptop (tv not connected) ihave to nano into the xorg.conf and take out the option line i added (anyone know a workaround to this?)

OK so NOW i have a permanant storage file, access to my external HDD, wireless working, and video out to the tv working.

HOWEVER I CANNOT get audio through the hdmi to the tv to work. Ive enabled digital out in the system menu. when trying to play a movie, i get some kind of message about audio not working
I don 't know the first thing about ALSA, but i tried apt-get install ALSA and it told me that the latest version was already installed.

Can anyone help me outHuh some of the stuff ive looked up on alsa is way beyond me and don't really know where to start.

I am running off of a usb. My laptop is an ASUS k50id, has a gt320M graphics card, a NVIDIA MCP79D chipset, 64 bit os, and Built-in Intel® High Definition audio compliant audio chip
I ran aplay -l and i don't get a digital device, maybe this is the problem?


card0: NvVidia [HDA NVidia], device 0: ALC269 Analog [ALC269 Analog]
Subdevices: 0/1
Subdevice #0: Subdevice #0


there should be one that says digital, no?