Kodi Community Forum

Full Version: No audio for some videos
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all. I know that this is a somewhat common issue, and I have searched out the subject on the forums and google, and haven't been able to resolve it yet.

Anyways, I'm running a Zotac Mag HD ND01 Ion box with a copy of XBMCFreak installed. On this box I use both XBMC and Boxee. As it stands right now, everything works fine with all mkv videos, but, for some videos with lower quality audio, I don't get any audio at all.

My box is connected directly to my Samsung tv using HDMI.

The settings in my XBMC are this:

Audio output: HDMI
Speaker Config: 2.0
Boost volume level on downmix: yes
Dolby Digital AC3 capabale: no
DTS capable: no
Audio output device: custom: plug:hdmi
Passthrough output device: hdmi

My ~/.asoundrc

Quote:pcm.dmixer {
type dmix
ipc_key 1024
ipc_key_add_uid false
ipc_perm 0660
slave {
pcm "hw:0,3"
rate 48000
channels 2
period_time 0
period_size 1024
buffer_time 0
buffer_size 4096
}
}
pcm.!default {
type plug
slave.pcm "dmixer"
}

The info on an example video in question:

Quote:D(Audio: mp3, 22050 Hz, 2 channels, s16, 80 kb/s P(aq:99%, kB/s:7781)
D(Video: vp6f,yuv420p, 320x240, 265 kb/s P(vq:99%, dc:ff-vp6f, Mb/s:0.29, drop:1,pc:1)

C( ad: 0.000, a/v: 0.044, edl:-, dcpu: 9% acpu: 3% vcpu: 4%)
W( fps:20.00 CPU0: 3.5% CPU1:0.5% CPU2: 4.0% CPU3:2.0%)

`speaker-test -c1 -r22050` works fine in terminal
`speaker-test -c1 -r44100` works fine in terminal

Any suggestions on what else to try?
Will be watching this post as I am having problems getting stereo sound out my spif also Sad
I had the same issue, it has something to do with my JVC TV verses my Panasonic, the Panasonic will play everything, but if I move the HTPC to the JVC I get the same issues you describe. It has to be the 48k signal going out the HDMI is just not quite right for the JVC because the Panasonic works fine.
It looks like you have the same .asoundrc as I do, mine was created by the info at http://wiki.xbmc.org/index.php?title=HOW...controller. Have you tried the HTPC on a different HDMI TV?
MacGyver Wrote:I had the same issue, it has something to do with my JVC TV verses my Panasonic, the Panasonic will play everything, but if I move the HTPC to the JVC I get the same issues you describe. It has to be the 48k signal going out the HDMI is just not quite right for the JVC because the Panasonic works fine.
It looks like you have the same .asoundrc as I do, mine was created by the info at http://wiki.xbmc.org/index.php?title=HOW...controller. Have you tried the HTPC on a different HDMI TV?

Interesting. The thought never even crossed my mind that it could just be my TV. Unfortunately, I don't have access to any other HDMI tv's to test it.

Also, I wanted to add. The videos that I have been playing are from a Video plugin that appears to scrape a website that has the videos in a JW player flash player. When I go to the site manually in Chrome on the HTPC and play the video, the audio works fine. I don't know what the script does to the video from the website to XBMC that kills the audio for me.
Solved a similar problem. Given that I am a total xbmc and ALSA newb, I hope this may help someone.

In my case it turned out that the problem was that my Sony Bravia KDL-32S5100 TV would respond with silence when 22050 Hz file was played. I established this by trial and elimination, eventually isolating it to being unable to play 22050 Hz wav audio file.

My asound.conf/.asoundrc is much simpler, since there is no motivation to mess with dmixer on a dedicated HTPC box. The config is along the lines of post #2 at this thread. The key to getting the sound up-converted to 48 KHz is the "rate 48000" line and making sure your 'Output Device' is set to 'Custom' and custom name is 'hdmi_complete' in the Audio settings.

HTH!
I have similar problem, and I confirm that it was a issue with my Sony Bravia KDL-46EX500 which respond with silence when 22050 Hz file is played.

I applied SirG tip, and it works :-) However, it also resample 44100Hz to 48000Hz, which is not good : high cpu usage, lower sound quality.

I read the Alsa documentation but wasn't able to make it convert ONLY 22050Hz audio. Does someone know how to do that ?