Kodi Community Forum

Full Version: mapping keys for vrc-1100 remote
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
hi. while most of the keys seem to be correctly mapped by default for this remote, i'm struggling with one or two. in particular the power button doesn't seem to default to :
<power>XBMC.ShutDown()</power>
and appears to do nothing. does anyone else have the keys for this remote all mapped correctly and willing to share their config ? thanks.
resolved. for the benefit of others :

turned on debugging which showed the following for the power button :
DEBUG: OnKey: 61599 pressed, action is

i then made the mistake of thinking i needed to use remote.xml to map this key, but it turned out to be keyboard.xml, so i created ~/.xbmc/userdata/keymaps/keyboard.xml containing the following :

<keymap>
<global>
<keyboard>
<key id="61599">XBMC.ActivateWindow(ShutdownMenu)</key>
</keyboard>
</global>
</keymap>

so the power button now takes me to the shutdown menu.
Well, I've got a question.
I have the same remote but there is one important button that's not working for me
and that's the button to show the context menu.

So my question is: how do you get the context menu with this remote ?

I tried some things in keyboard.xml and remote.xml but with no luck.
which button are you trying to use to show the context menu ?
I tried all of them but I thought that I have red on the net that the guide button can be used to show the context menu.
i'm not quite sure which guide button you are referring to but i've extracted all the default codes for the buttons on my vrc-1100 and they are as follows :

button onkey code button code string key action
internet OnKey: 61612 0xF0AC browser_home XBMC.ActivateWindow(Home)
power OnKey: 61599 0xF008 backspace {null}
yellow OnKey: 127136 + OnKey: 258132 0x3F054 {null} Notification(MCEKeypress, My TV, 3)
blue OnKey: 127053 0x1F04D {null} ActivateWindow(music)
green OnKey: 127049 0x1F049 {null} ActivateWindow(pictures)
red OnKey: 127045 0x1F045 {null} ActivateWindow(video)
under yellow OnKey: 127055 0x1F04F {null} Notification(MCEKeypress, Recorded TV, 3)
under blue OnKey: 127047 0x1F047 {null} OSD
under green OnKey: 127060 0x1F054 {null} Notification(MCEKeypress, Live TV, 3)
under red OnKey: 258125 0x3F04D {null} Notification(MCEKeypress, DVD menu, 3)
rew OnKey: 127136 + OnKey: 258114 0x3F042 {null} Rewind
fwd OnKey: 127136 + OnKey: 258118 0x3F046 {null} FastForward
skip back OnKey: 61617 0xF061 numpadone SkipPrevious
skip fwd OnKey: 61616 0xF060 numpadzero SkipNext
play OnKey: 61619 0xF0B3 play_pause Pause
stop OnKey: 61618 0xF0B2 stop Stop
pause OnKey: 61619 0xF0B3 play_pause Pause
record OnKey: 127058 0x1F052 {null} {null}
back OnKey: 61448 0xF008 backspace ParentDir
info {null} {null} {null} {null}
up OnKey: 61478 0xF026 up Up
left OnKey: 61477 0xF025 left Left
right OnKey: 61479 0xF027 right Right
down OnKey: 61480 0xF028 down Down
ok OnKey: 61453 0xF00D return Select
left mouse {null} {null} {null} {null}
right mouse {null} {null} {null} {null}
mouse {null} {null} {null} {null}
volume up OnKey: 61615 0xF0AF volume_up VolumeUp
volume down OnKey: 61614 0xF0AE volume_down VolumeDown
channel up OnKey: 61473 0xF021 pageup PageUp
channel down OnKey: 61474 0xF022 pagedown PageDown
mute OnKey: 61613 0xF0AD volume_mute Mute
start OnKey: 847885 0xCF00D {null} {null}
1 OnKey: 61537 0xF061 numpadone Number1
2 OnKey: 61538 0xF062 numpadtwo Number2
3 OnKey: 61539 0xF063 numpadthree Number3
4 OnKey: 61540 0xF064 numpadfour Number4
5 OnKey: 61541 0xF065 numpadfive Number5
6 OnKey: 61542 0xF066 numpadsix Number6
7 OnKey: 61543 0xF067 numpadseven Number7
8 OnKey: 61544 0xF068 numpadeight Number8
9 OnKey: 61545 0xF069 numpadnine Number9
* OnKey: 61544 0xF068 numpadeight Number8
0 OnKey: 61536 0xF060 numpadzero Number0
# OnKey: 323683 + OnKey: 323685 0x4F065 {null} {null}
close OnKey: 323699 0x4F073 {null} {null}
clear OnKey: 61467 0xF01B escape PreviousMenu
enter OnKey: 61453 0xF00D return Select

so i believe you can't map the mouse buttons or the info button and by default the record, start, hash, and close buttons aren't mapped and can therefore be mapped using the process i've previously described. some of the other buttons are mapped to actions that don't apply in xbmc, so again they can be remapped.

hope that helps.
guys, have you tried the hama_mce remote event client ? its a gift fallen from heaven

http://trac.xbmc.org/ticket/8827
try it, you wont regret it
That guide button is the one under the blue key, but normally you can map the context menu to any key you want.

But I'm gonna try that event client that Juanjo mentioned.
Could anybody please explain what i need to do to get the event client working? Im a bit lost.
guerilla Wrote:Could anybody please explain what i need to do to get the event client working? Im a bit lost.


Code:
$ cd /usr/local/src
$ sudo wget http://trac.xbmc.org/attachment/ticket/8827/hama_mce-1.5.tar.gz
$ sudo tar xpvf hama_mce-1.5.tar.gz
$ sudo cd hama_mce-1.5
$ sudo apt-get install build-essential
$ sudo make
$ sudo make install
$ sudo reboot
Thanks for the reply but i get this error when trying

Code:
[email protected]:/usr/local/src# sudo tar xpvf hama_mce-1.5.tar.gz

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Exiting with failure status due to previous errors

any suggestions?
EDIT:
I think I found the solution, if you download it with wget then it will be an html file
If you do
Code:
file hama_mce-1.5.tar.gz
Then the output will tell you that it is an html file.
Try to download it with a browser...

http://trac.xbmc.org/raw-attachment/tick...1.5.tar.gz

and copy it then to your xbmc htpc and do the commands that are standing above.
____________________________________________________________________________________________________________

Another person with that problem. Sad
I had that problem too and nobody could answer me how to fix it.
Normally you have to install the build-essential package if you never compiled something on your box.
Code:
$ sudo apt-get install build-essential
I googled for that problem but couldn't untar it/find a solution...

So I downloaded that hama_mce-1.5.tar.gz file to my windows computer, untarred it with 7zip and copied that with and ftp client to my xbmc box in the home directory.

From there I installed it:

Code:
$ sudo cd hama_mce-1.5
$ sudo make
$ sudo make install
$ sudo reboot
Thanks for that it seems to of worked. Can I ask a pretty dumb question. what does this let me do?
You can find your answer here Wink

http://trac.xbmc.org/ticket/8827
Does this remote use an RC6 infrared receiver?
Pages: 1 2