Kodi Community Forum

Full Version: [linux] No audio for standard def
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I get audio from 720p and 1080p content fine via coax spdif but music and standard def audio doesnt come through. I have XBMC running on ubuntu 10.10. I also do not get any sound out of the OS. Any suggestions on where to look first, I am new to linux.

Thanks,

David
Please post a debug log (don't forget to turn on debug logging).
bobo1on1 Wrote:Please post a debug log (don't forget to turn on debug logging).

I dont have a debug log yet but I have narrowed it down to MP3 audio from music or video. I also do not hear any menu sounds. DTS, AC3, AAC, Dolby D and others all work fine.
here are the contents of the log. It was too big to paste here so I put it at tinypaste.com

http://tinypaste.com/08ed6
Code:
Initialize - using alsa device plug: dmixer
You seem to be using the wrong alsa device.
bobo1on1 Wrote:
Code:
Initialize - using alsa device plug: dmixer
You seem to be using the wrong alsa device.

I wasnt sure what to do so I tried this...

Quote:Audio issues
S/PDIF out for both analog and digital audio
You might find yourself able to get one of both working, but switching from one to the other might not work. Ubuntu and other distributions use PulseAudio to manage ALSA devices and unfortunately it doesn't provide management for passthrough digital audio. The following solution bypasses PulseAudio and forces XBMC to directly use ALSA. There is no need to uninstall or tweak PulseAudio on Ubuntu in any way.
Open ~/.asoundrc in a text editor (create the file if it doesn't exist) and add the following:
note: make sure to use the correct card/device id and replace 'pcm "hw:0,1"' with it. You can find the id's by typing 'aplay -l' in a terminal.
pcm.dmixer {
type dmix
ipc_key 1024
slave {
pcm "hw:0,1"
period_time 0
period_size 1024
buffer_size 8192
#periods 128
#rate 44100
rate 48000
}
bindings {
0 0
1 1
}
}
Launch xbmc and go to "system->settings->system->audio hardware" and change the following:
AUDIO OUTPUT DEVICE: custom
CUSTOM AUDIO DEVICE: plug:dmixer (note: this is case sensitive, even though xbmc shows only capitals!)
PASSTHROUGH AUDIO DEVICE: iec958
Now all audio output (besides menu sounds) should work including crossfading and switching digital/analog audio sources.

That log was generated after I followed those instructions
Here's what I had to do
Quote:sudo alsamixer

arrow over to SPDIF (two or three options)

'm' to unmute (all)
rockinthesix Wrote:Here's what I had to do


arrow over to SPDIF (two or three options)

'm' to unmute (all)

what does that do? is that so that the OS isn t trying to control sound?
Also, something that I noticed is that I also do not get any sound out of the other apps in the OS. if I go to hulu or pandora, no audio is sent out of SPDIF. Speaker tests in the sound preferences dont work either.
I was never able to figure this out completely. I have XBMC working fine but no system sounds. I re-enabled the onboard sound card and set the system to use that. Then in XBMC setup I told it to use the PCI card. Now in XBMC all audio formats play perfectly. But my other audio that would be coming from things like youtube or any thing else I play from anything other than XBMC will go though the on board sound card which is not hooked up.

So the issue is that when the OS boots up it takes control of whatever sound card you tell it to in the sound preferences. XBMC needs to switch between passthrough and other formats, but it cant do the switch because the OS has it in use.

Any ideas on how to get this to work? I hate to ask for it but, my Linux skills are next to none so step by step instructions are what I really need.

Ubuntu 10.10
XBMC 10.0
Diamond Xtreme Sound 7.1 /24bit sound card

Thanks,

David
So you're using coax SPDIF out?
What is the output of:
aplay -l
aplay -L

SPDIF should be listed as 'iec958' - Make sure this is unmuted in alsamixer

What do you have set in your audio section?

Try setting the speaker output config to: 2.0
Audio Device: Defaults
Passthrough: iec958

Then, try the following:
sudo nano /etc/asound.conf

Add in the following:
pcm.!default {

type plug
slave {
pcm "iec958"
}

}

I've used this many times to get the MP3 (and system sounds) working, using SPDIF

(Maybe also just do this whilst the onboard audio is disabled, so as to not confuse the issue)