Kodi Community Forum

Full Version: I/O exception, illegal character.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Since I didn't get an answer in the other thread I'll try again with a new one.

I keep getting this error msg when i'm connected to my XBMC instance.

The remote works but i can't view my shows or movies and the message keeps popping up.

"I/O Exception (java.io.IOException)

Illegal character in authority at index 22:"

It just came out of nowhere.

What could be wrong? Stare
Probably you have entered a newline character in the ip field in the host settings
gfoldv Wrote:Probably you have entered a newline character in the ip field in the host settings

I don't follow, the "host or ip address" field on the remote?

The only thing that's in there is and that's it.

The remote works fine with another xbmc setup, so it's gotta be something with the installation, perhaps a plugin or a script?
I'm getting crazy here, do I really have to uninstall, and reinstall XBMC to solve this? Any dev that might shed some light? As i said the remote works but i get the illegal characther message ALL THE TIME, and when someone calls playback isn't paused. And i can't view my shows or my movies.

I tried installing a new instance of XBMC in another location, but it looked exactly the same, i guess all settings is saves in my profile.

I really don't want to uninstall XBMC and loose all my settings.

having the same issue - ill post back here with a solution if its found.
You entered an illegal character in the ip or host field. Most likely you pressed enter in the host field. Reenter all connection settings and make sure you don't hit the enter button.
Ok, so i deleted my entire installation! And now i get

I/O Exception (java.io.FileNotFoundException) (120)

What the hell is up, will this never function properly?
Did you also check there is no space after your IP?

I was using port 8080 and appearently something else on my system was using that port as well and the remote got fucked up. Angry

So for those of you that have this issue, try changing port, to something like 25675 or similiar.

This whole situation with these errors is a bit odd. I was getting the I/O Error as well. So I changed my port. When that made no difference I did a Port Forward in my router for that port on the IP that XBMC is running on. Made no difference. I checked settings and found a trailing space after the IP. Subsequent to deleting the trailing space I got a new result: 'HTTP 410 Unauthorized'. Go back and add the trailing space I get the I/O error again. Go back and try yet another port, and get the HTTP error again, but the remote still seems to work anyway. Go back and add the trailing space, and get the I/O error again, but the remote still seems to work anyway.

You'd think that after dozens of users in the Market reviews (which the Dev's apparently only read at random for the purpose of 'amusement' (their words on the Market, not mine)) note they have the same problem, and more than a year down the road, they'd have it figured out (along with the tiny unreadable fonts) by now?
Changing the port to something other than 8080 worked for me. Something else on the Ubuntu install was using 8080