Kodi Community Forum

Full Version: [ATV1] - AC3 problems
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all

First of all, i've been using XBMC on linux with CrystalHD from a while and all was working fine, read a lot this forum, and i think i not alone with this case Wink

I have now, for some personal reason, migrate to an ATV 1rst gen and try to use XBMC on ATV (without Linux. With Linux on ATV, all work fine too).

Info :

ATV Boot ROM Version: ATV11.00DA.B04
ATV System Version: Apple TV OS 10.4.7 (8N6014)
ATV Kernel Version: Darwin 8.8.2
XBMC version : Git:844c6c7
Launcher : 3.2.5
ATV : 3.0.2

So, i have a big problem with AC3.
AC3 -> No sound on my receiver thought SPDIF (All of my movies works fine on XBMC Linux (PC and ATV)), noise on TV with HDMI (normal because Tv don't decode AC3/DTS ). In this configuration, DTS work fine on my receiver.

Here is the debug Log : http://pastebin.com/qDnDN4GS
Here is an extract of mediaInfo for the sample :

Code:
*** MediaInfo Mac // Plain text file report
2011-03-04 12:29:50 +0100
Information for File: sample.mkv

General / Container Stream # 1
    Total Video Streams for this File -> 1
    Total Audio Streams for this File -> 1
    Video Codecs Used -> AVC
    Audio Codecs Used -> AC3
    File Format -> Matroska
    Play Time -> 2h 1mn
    Total File Size -> 4.37 GiB
    Total Stream BitRate -> 5 138 Kbps
    Encoded with -> mkvmerge v2.9.8 ('C'est le bon') built on Aug 13 2009 12:49:06
    Encoding Library -> libebml v0.7.7 + libmatroska v0.8.1
Video Stream # 1
(...)
Audio Stream # 1
    Codec -> AC-3
    Codec (FourCC) -> A_AC3
    Audio Stream Length -> 2h 1mn 45s 536ms
    Audio Stream BitRate -> 640 Kbps
    Audio Stream BitRate Mode -> CBR
    Number of Audio Channels -> 6
    Audio Channel's Positions -> Front: L C R, Surround: L R, LFE
    Sampling Rate -> 48.0 KHz
    Audio Stream Size -> 557 MiB (12%)
    Audio Stream Title -> Ac3 640 Kbps
    Audio Stream Language -> English

It seem that CoreAudio don't read Audio info correctly :

Code:
Using digital output
AC3 pass through is enabled
DTS pass through is enabled
(...)
Stream #0.1(eng): Audio: ac3, 48000 Hz, 5.1, s16, 640 kb/s
(...)
Creating audio device with codec id: 86019, channels: 2, sample rate: 48000, pass-through
(...)
CoreAudioRenderer::Initialize: No suitable AC3 output format found. Attempting DD-Wav.
(...)
CCoreAudioRenderer::Initialize - Channels: 2 - SampleRate: 48000 - SampleBit: 16 - Resample false - IsMusic false - IsPassthrough true - audioDevice: Built-in Line Output

Davilla ? Any idea ? Do i miss something ?
Try with xbmc audio player (paplayer / dvdplayer ?) ... no more luck, no sound

Also, try to play audio file (AC3), sample here : http://dl.free.fr/ejW5Jh9Ul
No sound on my receiver. xbmc.log here : http://pastebin.com/NcyuREf7

Edit : question ?
Is there a way to activate only SPDIF and d├ęsactivante HDMI audio and Analogic Audio ?

Davilla, in an other post you say :

Quote:passthrough is always 2 channels, it's a hack to SPDIF which is two channels.

"Error: Requested setting (audiooutput.passthroughdevice) was not found. It must be case-sensitive", I've seen that before. It's harmless.

"CoreAudioRenderer::InitializeEncoded: Unable to identify suitable output format." InitializeEncoded was passed an output format that did not match anything. This has been changed from an error to a debug logging as it's not an error per say.

And you can not reproduce that problem, so no fix possible... i understand that. But i have this problem, easily reproduce it. I can made change on code, compile, try and try, and try again Wink

That i can say, is on XBMC when i play with sound when i play movie, it say passthrough enable. Great, but no sound Wink HDMI had noise... bad. Related to my DTS problem (that don't close audio channel properly), It appear this problem is on old A/V.

So what can i do to help ?

Please, give me advice where you check codec or "case sensitive" in CoreAudio. Perhaps you have a Code documentation ?

Edit 2 : Just see that when i boot my ATV, (AC3 enable on ATV parameters Audio-Video), and when the beautiful Apple movie show up, i see on my receiver : 48Khz 3/2, with of course, my ATV plugin onto my receiver with SPDIF. So AC3 passthrough seem to work... but not on XBMC.

i Also try to make some sample (AC3 - 48Khz, AC3 - 44Khz, AC3 - passthrough) with Handbrake ... no more luck. just no sound.

Edit 3 : Ok, let's play.

A sample with video (nervermind), and 3 audio :
- AAC(CoreAudio) 6-channel discrete 48k 640kbps
- AC3(Passthru) 48k 640kbps
- AC3 6-channel discrete 48k 640kbps

Here is : http://dl.free.fr/eg8Xjm1Xd

All work weel on ATV (ATV player after syncronisation with itunes). Receiver say 48k, 3/2 for the two AC2 channels, and 48k PCM dor AAC (normal)
All channels don't work on XBMC for ATV on my receiver.

Testing with Ubuntu+xbmc on ATV : all play 48K - 3/2, (weird, but ok, it work)

Please, if someone had the same problem, feel free to write some exemple here and help dev to find a way Wink
I don't have a digital audio receiver so there's no way I can reproduce passthough issues at the current time.
Sad sniff, thanks a lot davilla for answer Wink

Any XBMC OSX Dev Team ?
A answer found on bugtrack of a52codec (4Years Old)

http://trac.cod3r.com/a52codec/ticket/44

Quote:The passthrough (in this mode) does not work with all receivers. It is not fully following the spec because there is no choice. The brief "pop" is a result of AC3 audio being sent over PCM format, and other receivers can detect this, and appropriately decode. This cannot be corrected until Apple fixes rdar 5435791. So, go to bugreporter.apple.com and demand they resolve it.


My Receiver is a little Old (Yamaha DSP-A1) and don't understand AC3 over PCM ... Damned.
Same issue on this thread. No apparent solution at this time.
I have this same issue. Are their any updates to this problem?
Not actually, Apple problem, not XBMC if i understand right. But Some guys are on the forum are working on EngineAudio, perhaps it will help.
I had similar problem. I installed XBMC (on AppleTV1 with Crystal HD), video out with component to plasma screen. Audio out with optical to the Sony STR-DB 830 amp. The boot up animation of Apple TV worked fine (I get blue led light on Dolby Digital or DTS and the amp display shows the decoding). The movies with DTS audio as well.

The only thing I couldn't get were the movies with AC3 audio. The amp was receiving as the blue led was on and the display showed "Dolby Digital". In XBMC there was a complete silence and with NitoTV I got "helicopter sound".

It turns out that it was the amplifiers fault as I connected it to a newer model Sony STR-DB1080 and all worked fine.