Kodi Community Forum

Full Version: [WINDOWS] Problem using JumpSMS
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I cannot get JumpSMS to work in windows.

I have a standard Microsoft MCE remote and the ehome usb receiver, but each time I try to use a key that is linked to JumpSMS, it just sends the number instead of letters.

I have tried almost everything, even changing NumberX everywhere in keyboard.xml and remote.xml into JumpSMSX. (both in c:\Program Files\XBMC\system\keymaps as in c:\documents and settings\...\xbmc\userdata\keymaps), but to no avail. The strange thing is, that if I run a live xbmc (linux), it works out of the box. It’s just when I install XBMC in windows, that I have this problem. I tried installing xbmc on several pc’s, with different versions of windows, but each time the same problem, only numbers are send, and no letters.

I am using dharma 10.1, but the live is also dharma 10.1 so, it’s not linked to this version. I tried with remote sends keyboard presses switched on and off, and tried it with the addon for the mce remote installed and not, but each time the same problem.

Can anyone help me ?
Check out this site http://xbmccustomregis.sourceforge.net/remote.html. It got my RC6 MCE remote working.
Put this in your keymap.xml file. It's what I had to do to get JumpSMS to work, and still allow me to type in times during a video.

Code:
<MyVideoLibrary>
        <keyboard>
            <two>JumpSMS2</two>
            <three>JumpSMS3</three>
            <four>JumpSMS4</four>
            <five>JumpSMS5</five>
            <six>JumpSMS6</six>
            <seven>JumpSMS7</seven>
            <eight>JumpSMS8</eight>
            <nine>JumpSMS9</nine>
        </keyboard>
    </MyVideoLibrary>
YodaEXE Wrote:Put this in your keymap.xml file. It's what I had to do to get JumpSMS to work, and still allow me to type in times during a video.

Code:
<MyVideoLibrary>
        <keyboard>
            <two>JumpSMS2</two>
            <three>JumpSMS3</three>
            <four>JumpSMS4</four>
            <five>JumpSMS5</five>
            <six>JumpSMS6</six>
            <seven>JumpSMS7</seven>
            <eight>JumpSMS8</eight>
            <nine>JumpSMS9</nine>
        </keyboard>
    </MyVideoLibrary>


@YodaEXE it is already in my keyboard.xml (i suppose you meant that instead of keymap.xml), but it just doesn't work.

@lewisc, tried that already (just did it again on a test pc now), and also has no effect.
If it is in the correct location (c:\Program Files\XBMC\System\Keymaps\Keyboard.xml), then it looks like a bug. However open your keyboard.xml and paste the contents to pastebin, then post the link from here to let us have a look, before we declare it a bug.

I only have the keyboard.xml amended file in my user data folder - therefore if I make changes to the core build, it retains the remote jump commands and I don't have to continually amend the keyboard.xml in Program Files location.
@ viper1705:

How did you configure your remote? Did use the MCE Remote addon or did you use my Custom Reg Config v1.24??

If you use my reg config v1.24 and keyboard.xml v1.80 then you shouldn't run in to any problems.

Keymap.xml is not used any more but XBMC can read it if it exist!

Anyways I'd recommend reinstalling XBMC so that the default XBMC keyboard.xml will be installed again. You should not edit keyboard.xml in the "Program files" system installation folder. Instead just create a new keyboard.xml in the %AppData%\XBMC\userdata\keymaps folder with your custom settings and it will override the system folder one!

See my site for more info!

Btw in keyboard.xml you need to have jumpsms in global section as follows:

Code:
<keymap>
  <global>
    <keyboard>
        <zero>Number0</zero>
        <one>Number1</one>
        <two>JumpSMS2</two>
        <three>JumpSMS3</three>
        <four>JumpSMS4</four>
        <five>JumpSMS5</five>
        <six>JumpSMS6</six>
        <seven>JumpSMS7</seven>
        <eight>JumpSMS8</eight>
        <nine>JumpSMS9</nine>
    </keyboard>
  </global>
</keymap>

Cheers,
EG.
elitegamer360 Wrote:@ viper1705:

How did you configure your remote? Did use the MCE Remote addon or did you use my Custom Reg Config v1.24??

If you use my reg config v1.24 and keyboard.xml v1.80 then you shouldn't run in to any problems.

Keymap.xml is not used any more but XBMC can read it if it exist!

Anyways I'd recommend reinstalling XBMC so that the default XBMC keyboard.xml will be installed again. You should not edit keyboard.xml in the "Program files" system installation folder. Instead just create a new keyboard.xml in the %AppData%\XBMC\userdata\keymaps folder with your custom settings and it will override the system folder one!

See my site for more info!

Btw in keyboard.xml you need to have jumpsms in global section as follows:

Code:
<keymap>
  <global>
    <keyboard>
        <zero>Number0</zero>
        <one>Number1</one>
        <two>JumpSMS2</two>
        <three>JumpSMS3</three>
        <four>JumpSMS4</four>
        <five>JumpSMS5</five>
        <six>JumpSMS6</six>
        <seven>JumpSMS7</seven>
        <eight>JumpSMS8</eight>
        <nine>JumpSMS9</nine>
    </keyboard>
  </global>
</keymap>

Cheers,
EG.

@steelman1991: Yes it is in that location, and the same is in the user data folder to make sure, but both have no effect. url to keyboard.xml is http://pastebin.com/zUmhFwXW btw on startup I can see in the log a few error messages about JumpSMS0 and 1 which is normal since they don't exist (I just replaced number with jumpsms everywhere in the xml to be sure) so the keyboard.xml is indeed used, but the jumpsms is just not working.

@elitegamer360: I tried them all, first I did nothing since the mce remote is supported without installation of any addon, I also tried with the mce remote addon, and with your reg config v1.24 and keyboard.xml v1.80 (on a different pc), also to no avail.
What do you mean with keymap.xml ? Shouldn't this be keyboard.xml, or do I need to create keymap.xml ?
If you turn on debug logging your xbmc.log will tell you what keypresses XBMC is receiving and what it's doing with them. Post the debug log on pastebin and we can have a look, but fix the errors with JumpSMS0 and 1 first as they will be complicating things.

JR
I'm unsure of the mechanics (JHRennie and EG are far more expert than me), however I don't have the jumpsms commands in anything global, only under MyVideoLibrary\Keyboard (See lines 388 through 404 on the log) and everything works perfectly.

I have posted my keyboard.xml to pastebin, copy it, rename your existing to anything other than keyboard.xml and replace with mine - see if it works - if it doesn't then revert back and start the troubleshoot process again.

As EH has stated place it in %AppData%\XBMC\userdata\keymaps folder and that way it will override the system folder.

http://pastebin.com/R17JjFCk
jhsrennie Wrote:If you turn on debug logging your xbmc.log will tell you what keypresses XBMC is receiving and what it's doing with them. Post the debug log on pastebin and we can have a look, but fix the errors with JumpSMS0 and 1 first as they will be complicating things.

JR

Ok, I did what you asked.

On a test pc with windows XP, I removed XBMC again, and reinstalled it to get a clean keyboard.xml. I copied that one into appdata and there changed Number2 - Number9 into JumpSMS2 - JumpSMS9 in the global section. I checked the virtual keyboard and there is no reference to numbers there, so it should take the global actions.
I started XBMC, enabled remote sends keyboard presses, activated debugging, and then restarted XBMC.
I then went into settings / Weather / and went to change location, it then pops up the virtual keyboard. There I pressed a few number buttons (again jumpsms didn't work). I have put the resulting log on pastebin: http://pastebin.com/dZ1jqJZf
I hope you will find out what went wrong.

thx
Are you confusing JumpSMS with SMS input into the virtual keyboard? These are two different things.

Is your problem only with the virtual keyboard? i.e. does your remote correct handle the JumpSMS actions within lists?

Cheers,
Jonathan
jmarshall Wrote:Are you confusing JumpSMS with SMS input into the virtual keyboard? These are two different things.

Is your problem only with the virtual keyboard? i.e. does your remote correct handle the JumpSMS actions within lists?

Cheers,
Jonathan

aha, is there a difference ?

No, the problem is not only in the virtual keyboard, in lists the keys have no effect. But i thought the easiest way to test it, is to call up the virtual keyboard, as this (the sms style input) worked in the live version (linux), so I could compare.
jmarshall Wrote:Are you confusing JumpSMS with SMS input into the virtual keyboard? These are two different things.

Is your problem only with the virtual keyboard? i.e. does your remote correct handle the JumpSMS actions within lists?

Cheers,
Jonathan

I finally made some progress on this problem thx to jmarshall. It seems this problem is linked to the regional settings in windows, especially the keyboard layout. I am from Belgium, which means we have a different keyboard layout then in most other countries (azerty instead of querty). This means that to get a number on the keyboard I have to press shift + number, otherwise I only get a special character. for example 2 without shift is é , 3 without shift is " , 4 is ' ...
if I go to the virtual keyboard, I can see this happening. when I push 2 on the remote it gives me é. (doesn't matter how many times I push 2, it's always é). the same happens in the list I suppose, that why it stays at the first position (not many movies start with a special character like é).
Now if i go into the regional settings, and change my keyboard to querty, the jumpsms works correctly in the lists. In the virtual keyboard it then only shows numbers (so the sms style input still doesn't work there unlike in the linux live version).
Is there anything that can be done ? because if I change my keyboard to querty, it breaks entering text and other stuff in windows ofcourse.

thx