Kodi Community Forum

Full Version: Duplicate fanart
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Has anyone else had a problem with fanart ending up in duplicates in their thumbnail cache? I just checked mine again, and once again, I've started accumulating a LOT of duplicates. I don't think it really does anything except make the slideshow screensaver even MORE susceptible to repeating the same image over and over.

Any reason why it would be happening? Best way to remedy? I didn't know if I should just delete what was cached, remove everything from my library and re-add it, or what.
Glave Wrote:Has anyone else had a problem with fanart ending up in duplicates in their thumbnail cache? I just checked mine again, and once again, I've started accumulating a LOT of duplicates. I don't think it really does anything except make the slideshow screensaver even MORE susceptible to repeating the same image over and over.

Any reason why it would be happening? Best way to remedy? I didn't know if I should just delete what was cached, remove everything from my library and re-add it, or what.

No clue, but you are WAY right about the slideshow... it looks ridiculously ghetto sometimes, fading between the same picture 4 or 5 times.
Well, this is part of the reason why. We have 1000 movies, and 79 tv shows. The odds of seeing the same poster should be pretty slim, but when you start getting duplicates of your fanart, it stacks the deck in favor of repeats very fast.
There was a fix that went into 10.1 to reduce this somewhat.

34a667eb794f9600159c5676015580c0fc8cc188

There is, however, still an issue in that browsing episodes in files mode, where you have a local fanart.jpg may cause similar behaviour. This will be taken care of when video art moves to the texture cache.

Cheers,
Jonathan
jmarshall Wrote:There was a fix that went into 10.1 to reduce this somewhat.

34a667eb794f9600159c5676015580c0fc8cc188

There is, however, still an issue in that browsing episodes in files mode, where you have a local fanart.jpg may cause similar behaviour. This will be taken care of when video art moves to the texture cache.

Cheers,
Jonathan

Good to hear! I shut down XBMC, deleted all of the cached fanart, started back up and did an update library. I went from 1700 items down to 950, lol.