Kodi Community Forum

Full Version: no hdmi audio on Zotac ION Zbox HD-ND22
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The spec on the above box are:
http://www.zotacusa.com/zotac-zbox-zboxh...ni-pc.html

I have installed both live and xbmcfreak version of Dharma 10.0 and have gone over everything I can find but cannot get any audio through the hdmi.
video is good, I have a 720p TV and that resolution avi plays smooth and sharp.

I also tried Mandriva 2010.2 and recompiled the kernel with the Nvidia ION drivers from Nvidia site so video is fine but same problem with audio.
I'm at a loss now and really really do not want to install windows.

any ideas for me?
Read the wiki:

http://wiki.xbmc.org/index.php?title=HOW...,_or_GT240

snd_hda_intel.conf in /etc/modprobe.d/ for ubuntu.

Code:
options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2
lithiumc Wrote:Read the wiki:

http://wiki.xbmc.org/index.php?title=HOW...,_or_GT240

snd_hda_intel.conf in /etc/modprobe.d/ for ubuntu.

Code:
options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

are you saying create a new file called snd_hda_intel.conf ? (didn't work if that's the case)
I had read an gone over that wiki numerous times trying every possible combination.
I have installed ubuntu desktop and still cannot get sound on this box...
Try this thread -> http://forum.xbmc.org/showthread.php?tid=95866

I had issues with the latest Ubuntu and this was helpful. Not sure how it will work with the distro your working with.
I have the same box and that works perfectly for me, I am going to ask the obvious here did you unmute all spdif channels in alsamixer.

what happens when you run

speaker-test -Dplughw:0,3

I don't use desktop, I just use live.

It took me awhile to figure things out so if you need help let me know.
I have the same Zotac box.
I almost gave up on the sound thru hdmi
There was an easy fix.. make sure you unmute everything in the audio mixer