Kodi Community Forum

Full Version: Disable spinning CD in now playing
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've been trying to find a way to either remove the spinning CD alogether (preferred) or just stop it spinning when I have the now playing screen up with music. I find it kind of distracting.

I guess its something to do with this code (around line 137) in MusicVisualization.xml in the 720p directory but for the life of me I can't work out what I should change.

Code:
<control type="image">
      <description>default cd image</description>
      <posx>35</posx>
      <posy>-4</posy>
      <width>200</width>
      <height>200</height>
      <texture diffuse="disc_mask.png">disc.png</texture>
      <aspectratio align="bottom">keep</aspectratio>
      <include>cdartspin</include>
      <visible>Skin.HasSetting(CDArt) | Skin.HasSetting(SafeMode)</visible>
</control>

Am I correct in saying that I can't just delete the disc.png as it is in the textures.xbt file?

any other way to disable the spinning?
rocketpants Wrote:I've been trying to find a way to either remove the spinning CD alogether (preferred) or just stop it spinning when I have the now playing screen up with music. I find it kind of distracting.

I guess its something to do with this code (around line 137) in MusicVisualization.xml in the 720p directory but for the life of me I can't work out what I should change.

Code:
<control type="image">
      <description>default cd image</description>
      <posx>35</posx>
      <posy>-4</posy>
      <width>200</width>
      <height>200</height>
      <texture diffuse="disc_mask.png">disc.png</texture>
      <aspectratio align="bottom">keep</aspectratio>
      <include>cdartspin</include>
      <visible>Skin.HasSetting(CDArt) | Skin.HasSetting(SafeMode)</visible>
</control>

Am I correct in saying that I can't just delete the disc.png as it is in the textures.xbt file?

any other way to disable the spinning?

You can disable the cdART image in Skin Settings.
I've tried disabling cdArt in the skin settings (enabled was the default) but it doesn't appear to stop spinning or remove the CD itself.

I'll just go check on another PC...

... OK weird. It is disabled on the other PC but not this one.

Anyway, problem solved - thanks.
I spoke too soon. The spinning CD is back again. cdArt is disabled.

The only thing I have done in the mean time is sync my userdata/thumbnails directory between the 2 PCs I am using.

Any ideas on how to disable the spinning CD or get rid of the CD all together?
I think I have solved it and/or found a bug

I have added some smart playlists to my favourites and access these from the main menu music submenu. If I start the playlist this way the playlist automatically starts playing with CD spinning and no fanart (instead of visualistion).

If I start the playlist by navigating into the music menu then to playlists and starting the playlist I am presented with a list of the songs on the playlist then I can start it. The CD does not spin and I get fanart instead of visualisation.

Sorry if this has already been discussed. I'm new to this skin.
to remove the spinning disc, delete this code in MusicVisualisation.xml

Code:
<include condition="!Skin.HasSetting(CDArt) + !Skin.HasSetting(SafeMode)">cdart-musicvisualisation</include>
<control type="image">
    <description>default cd image</description>
    <posx>35</posx>
    <posy>-4</posy>
    <width>200</width>
    <height>200</height>
    <texture diffuse="disc_mask.png">disc.png</texture>
    <aspectratio align="bottom">keep</aspectratio>
    <include>cdartspin</include>
    <visible>Skin.HasSetting(CDArt) | Skin.HasSetting(SafeMode)</visible>
</control>


i'll look into the playist issue asap and report back. :-)
Thanks Ronie,

I'll keep testing - I'm noticing funny things that are quite reproduceable so there may well be a problem at my end. If I find anything else I'll let you know.
I've tested that smart/playlist favourites thing on a couple of different machines and get the same behaviour on both - no fan art is displayed if I start the playlist from the music sub-menu as a favourite but everything works if I start it from the playlist menu item.
yup, i can confirm.

it 's a xbmc 'thing' and there's little i can do about it.