Kodi Community Forum

Full Version: Can't Access Samba
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am unable to access the contents of my Samba Share from XBMC. I can load the top folder and it displays the contents but whenever I try to load a file, it won't and whenever I try to open a folder, it asks for a login. I enter the login and it just asks for it again.

My server is Ubuntu Server with raidz.

I have a desktop running linux and a laptop running Windows 7 and they are both able to access the server.

Please help!
Look in your samba configuration file (usually is /etc/samba /smb.conf). Check the following value:

security = share

It's like I have I share my folder

path = /media /Videos
available = yes
browsable = yes
public = yes
writable = yes
Okay, I am checking but then why would my Window 7 laptop and my Ubuntu desktop be able to access it without problems?
It's rare that you only fail to xbmc. Check configuration, network, smb client adds the group you have set in smb.conf.

Sorry for my English Smile
Yeah, I added all of that mentioned above to smb.conf.

Nothing changes. I don't understand why I can access everything from my Ubuntu desktop but not from XBMC Live.
If anyone needs more info, I can give it. I finally got my server up and running but the whole reason I built a server was to use it with my xbmc box. Kind of frustrating.
I am having a similiar problem:

I just installed XBMCbuntu Frodo Final Compiled 01/28/13, I copied over a copy of mediasources.xml and sources.xml in the userdata directory. I have shares located on 2 different servers. I can access the one share but not the other. It keeps asking for login credentials on the one. I can access both shares just fine on a windows box using explorer and RASPBMC (RC3) using the same xml files.

I also tried another avenue of accessing the share by going to new source. It finds the domain and then the machine just fine lists the shares on the machine, but goes through the same process of asking for login credentials. I have tried both a dedicated account that I have for xbmc and the administrator account.