Kodi Community Forum

Full Version: Tvheadend reports no signal
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have beem using a vdr backend without problems for about a year. Recently though it seems that the tvheadend addon is under more active development.

So about a month ago i tried tvheadend. I love the web interface and it's very easy to configure with newcs. My problem is tvheadend wont find certain channels. It reports "no signal" and wont find any services. Unfortunately for me its the Sky sports and movie channels and a few others. It finds all the FTA channels ok.

I tried this on karmic, lucid, maverick server and desktop, xbmc-live, openelec, all with the same problems (except openelec must not support my tv card). I have changed all the possible settings in tvheadend without success.

So i went back to vdr and all my channels work with a good signal. I'm really not sure how to proceed now so i'm hoping someone might be able to help.

I tried tvheadend again tonight on lucid desktop, using the opdenkamp ppa with the same result.

If you need any more info let me know.

My tv card is a compro videomate s350.

in the tvheadend webui you can find a little icon in the bottom right, in the "system log" bar. click it and it'll enable debug logging. have a look at the log and see what happens.

if you can't find anything useful in the log, try asking for help in #hts on freenode.
Thanks for the reply. I just did a fresh install on ubuntu lucid desktop. I used the ppa i mentioned in the first post and now i don't get any channels in xbmcHuh . What dist are you using for your testing?

ubuntu lucid. but I don't think it has anything to do with that.

new packages have just been published on the ppa. update xbmc (to version odk20), reset the pvr database and if you still don't see any channels in xbmc, pastebin a full debug log please.

Here is a debug log of xbmc from the mentioned ppa. It doesn't show any channels.

Quote:ERROR: AddOnLog: Tvheadend HTSP Client: ReadResult - access denied
that'll be the problem.

you'll have to set a username and password in the tvheadend add-on settings. the same ones that are set up in tvheadend's webui. if you don't have any username and password set up there, add one.
Nice one, its working now. I still have to try and solve the no signal problem. Whats the best method to ask for help on #hts?

just post the question there and wait a couple of hours, or longer :-)

I changed the add-on so it'll display a message in the GUI if an access denied error is received. it'll be included in the next ppa build.
Just thought i would let you know that i now have tvheadend working perfectly. All my channels work and no sign of the low signal problem i was having. I just took more time going through the services and sorting out the channels. I also disabled idle scanning and auto detect muxes.

Thanks for all your hard work, the tvheadend add-on seems much more stable than the vdr one.

good to hear that it works now. enjoy! Smile
I had the same problem with little or no signal on my muxes and after some fiddling i found out that if I have Signal Monitoring enabled i thinks i have no signal or really bad quality, like 1-5% only. But if i disable Signal monitoring it works perfectly.