Kodi Community Forum

Full Version: [RELEASE] veetle.com
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
Here is a Dropbox link to the UNFIXED file, you dont need an account to download it. Thanks for compiling

https://www.dropbox.com/s/moyw827zuuetai...x86-osx.so
(2012-09-07, 00:08)bitbotherer Wrote: [ -> ]Not got a Linux ARM install here with me but this should be the fix for it - I used the libavformat.so.53.21.0 version for examination.

Search for:
Code:
04 30 90 E5 00 20 D3 E5 46 00 52 E3 01 00 00 0A 00 00 A0 E3 1E FF 2F E1 01 20 D3 E5 4C 00 52 E3 FA FF FF 1A 02 20 D3 E5 56 00 52 E3 F7 FF FF 1A 03 20 D3 E5 04 00 52 E3 F4 FF FF 8A 05 20 D3 E5 00 00 52 E3 0D 00 00 1A 07 10 D3 E5 06 00 D3 E5 08 20 D3 E5 01 18 A0 E1 00 34 81 E1 02 2C 83 E1 62 38 22 E0 23 34 A0 E1 FF 3C C3 E3 62 34 23 E0 08 00 53 E3 64 00 A0 83 00 00 A0 93 1E FF 2F E1 00 00 A0 E3 1E FF 2F E1

and replace with

Code:
04 30 90 E5 00 20 D3 E5 47 00 52 E3 07 00 00 0A 46 00 52 E3 19 00 00 1A 01 20 D3 E5 4C 00 52 E3 16 00 00 1A 02 20 D3 E5 56 00 52 E3 13 00 00 1A 03 20 D3 E5 04 00 52 E3 10 00 00 8A 05 20 D3 E5 00 00 52 E3 0D 00 00 1A 07 10 D3 E5 06 00 D3 E5 08 20 D3 E5 01 18 A0 E1 00 34 81 E1 02 2C 83 E1 62 38 22 E0 23 34 A0 E1 FF 3C C3 E3 62 34 23 E0 08 00 53 E3 64 00 A0 83 00 00 A0 93 1E FF 2F E1 00 00 A0 E3 1E FF 2F E1

And that 'should' change the flv check to one for FLV or Gxx.

Located about 0x30c60

I don't get it. I have tried using a number of editors - the last being ht2.0.20 windows based - still the search string does not show. The closest I found is 04 30 90 E5 00 20 D3 E5 and then everything else is wrong after that. I'm using this file libavformat.so.53 .

I admit, I have no idea what I am doing, but should the string not show up when I search? I'm trying but appear to be lost.

What editor do you use? I realize someone smarter than me will figure this out but now I really want to do this! Can you send me the file you used? Unfixed. I know, I know, pain in the ass. But us Cancers have to figure things out. It's in our nature.

Any help?

Thanks
(2012-09-07, 00:50)midiman Wrote: [ -> ]I don't get it. I have tried using a number of editors - the last being ht2.0.20 windows based - still the search string does not show. The closest I found is 04 30 90 E5 00 20 D3 E5 and then everything else is wrong after that. I'm using this file libavformat.so.53 but have no idea how to check the version.

I admit, I have no idea what I am doing, but should the string not show up when I search? I'm trying but appear to be lost.

What editor do you use?

Any help?

Thanks all

It should turn up if the versions matched - if you upload your file somewhere I'll match it for your revision.

@myteematt
Just disassembled your file and found the function (_flv_probe) BUT the layout is different to the usual check and needs a few tweaks - will do shortly (if not in bed).
Current version is this:
Code:
__text:0001FEC0 _flv_probe      proc near               ; DATA XREF: __data:0009AF0Co
__text:0001FEC0
__text:0001FEC0 arg_0           = dword ptr  4
__text:0001FEC0
__text:0001FEC0                 mov     eax, [esp+arg_0]
__text:0001FEC4                 mov     eax, [eax+4]
__text:0001FEC7                 cmp     byte ptr [eax], 46h ; 'F'
__text:0001FECA                 jz      short loc_1FEE0
__text:0001FECC
__text:0001FECC loc_1FECC:                              ; CODE XREF: _flv_probe+24j
__text:0001FECC                                         ; _flv_probe+2Aj ...
__text:0001FECC                 xor     edx, edx
__text:0001FECE                 mov     eax, edx
__text:0001FED0                 retn
__text:0001FED0 ; ---------------------------------------------------------------------------
__text:0001FED1                 align 10h
__text:0001FEE0
__text:0001FEE0 loc_1FEE0:                              ; CODE XREF: _flv_probe+Aj
__text:0001FEE0                 cmp     byte ptr [eax+1], 4Ch ; 'L'
__text:0001FEE4                 jnz     short loc_1FECC
__text:0001FEE6                 cmp     byte ptr [eax+2], 56h ; 'V'
__text:0001FEEA                 jnz     short loc_1FECC
__text:0001FEEC                 cmp     byte ptr [eax+3], 4
__text:0001FEF0                 ja      short loc_1FECC
__text:0001FEF2                 cmp     byte ptr [eax+5], 0
__text:0001FEF6                 jnz     short loc_1FECC
__text:0001FEF8                 mov     eax, [eax+5]
__text:0001FEFB                 mov     edx, 64h ; 'd'
__text:0001FF00                 bswap   eax
__text:0001FF02                 cmp     eax, 8
__text:0001FF05                 jbe     short loc_1FECC
__text:0001FF07                 mov     eax, edx
__text:0001FF09                 retn
__text:0001FF09 _flv_probe      endp
__text:0001FF09
__text:0001FF09 ; ---------------------------------------------------------------------------
__text:0001FF0A                 align 10h
(2012-09-07, 01:04)bitbotherer Wrote: [ -> ][quote='midiman' pid='1185513' dateline='1346971851']

I don't get it. I have tried using a number of editors - the last being ht2.0.20 windows based - still the search string does not show. The closest I found is 04 30 90 E5 00 20 D3 E5 and then everything else is wrong after that. I'm using this file libavformat.so.53 but have no idea how to check the version.

I admit, I have no idea what I am doing, but should the string not show up when I search? I'm trying but appear to be lost.

What editor do you use?

Any help?

Thanks all

It should turn up if the versions matched - if you upload your file somewhere I'll match it for your revision.



Thanks a lot for the offer! The file can be found here https://www.dropbox.com/sh/qyd315dagw3sr4a/ZRrJNWMoyK
myteematt - that looks like the Gen1 ATV code I already patched/posted, and the file names are identical.

midiman - is your openelec system x86 or ARM? I thought openelec was all x86, though I see there is a raspberry pi version. What bitbotherer posted was ARM patch, what I posted was x86 patch (er well, he and I were discussing ARM patch, but that doesn't count). x86 - hex (not ascii) search for '80 38 46' or '80 3A 46'
(2012-09-07, 01:47)midiman Wrote: [ -> ]Thanks a lot for the offer! The file can be found here https://www.dropbox.com/sh/qyd315dagw3sr4a/ZRrJNWMoyK

Quick fix for you Smile
Search for:
Code:
04 30 90 E5 00 20 D3 E5 46 00 52 E3 01 00 00 0A 00 00 A0 E3 1E FF 2F E1 01 20 D3 E5 4C 00 52 E3 FA FF FF 1A 02 20 D3 E5 56 00 52 E3 F7 FF FF 1A 03 20 D3 E5 04 00 52 E3 F4 FF FF 8A 05 20 D3 E5 00 00 52 E3 F1 FF FF 1A 05 00 93 E5 30 0F BF E6 08 00 50 E3 64 00 A0 83 00 00 A0 93 1E FF 2F E1

and replace with

Code:
04 30 90 E5 00 20 D3 E5 46 00 52 E3 03 00 00 0A 47 00 52 E3 05 00 00 0A 00 00 A0 E3 1E FF 2F E1 00 F0 20 E3 02 20 D3 E5 56 00 52 E3 F9 FF FF 1A 03 20 D3 E5 04 00 52 E3 F6 FF FF 8A 05 20 D3 E5 00 00 52 E3 F3 FF FF 1A 05 00 93 E5 30 0F BF E6 08 00 50 E3 64 00 A0 83 00 00 A0 93 1E FF 2F E1

That is for the specific Openelec Arm version you put up (and is found about 0x2aed8)
Huh - no wonder... midiman, you got an R-pi?? cool!
(2012-09-07, 02:14)plugh Wrote: [ -> ]Huh - no wonder... midiman, you got an R-pi?? cool!
It probably explains why we always seemed at cross purposes communicating Smile
[quote='plugh' pid='1185554' dateline='1346975639']
myteematt - that looks like the Gen1 ATV code I already patched/posted, and the file names are identical.


Unless Im missing something, the OSX patch does not work on either ATV 1st gen (mutant tiger 10.4.7, 3.0.2 OS, Eden XBMC), nor XBMC Eden running Mtn Lion. Anyone got this working. IOS works great tho !
(And some wonder why I prefer to tell people how to do their own patching...)

Nuggyblake, not sure what you are talking about. I posted the avformat file that I personally extracted from my xbmc 10.1 gen1 atv, personally patched, and personally use every day. If it 'does not work', well, one of us is in 'bizzaro world'.

What I said was that the disassembly listing posted had the same structure as the code in the aforementioned personally patched and posted image, and has the same filename. Perhaps the other file was built for a different / newer version of OSX, but the code structure and filename are still what they are. Ok?

If someone wants to see an example of a patch for that code structure, then examination of my previously patched and posted gen1 atv library might be informative.

(2012-09-07, 02:49)plugh Wrote: [ -> ](And some wonder why I prefer to tell people how to do their own patching...)

Nuggyblake, not sure what you are talking about. I posted the avformat file that I personally extracted from my xbmc 10.1 gen1 atv, personally patched, and personally use every day. If it 'does not work', well, one of us is in 'bizzaro world'.

What I said was that the disassembly listing posted had the same structure as the code in the aforementioned personally patched and posted image, and has the same filename. Perhaps the other file was built for a different / newer version of OSX, but the code structure and filename are still what they are. Ok?

If someone wants to see an example of a patch for that code structure, then examination of my previously patched and posted gen1 atv library might be informative.

Again, if you mean the dl ( avformat-52-ATV-OSX.zip) in post 243, I have had no luck with that. Path you provided does not work (atleast with my install). XBMC is not installed in root application folder (symlink to ~/frontrow/applications/xbmc.app/contents/resources/xbmc/system/players/dvdplayers/......). The path in 243 is for OSX desktop not ATV 1st gen Tiger. In Mtn Lion, it only references x86).

Doubtful that root vs frontrow location makes a difference, but there are variations.

Not trying to be difficult, just clarifying.

Has anyone else got this working on their ATV 1st gen ? Please post.

FYI - IOS ver works great.

HOLY CRAP - Okay Im using Eden, your using 10.1. I wonder if this makes a difference (will try and let you know)

Update: Yes, Dharma is different to Eden. Your fix works on Dharma (10.1) 10.8.1 OSX. Does not work with Eden. Same on ATV as you stated (Dharma works, Eden does not).

Not sure what the difference is at this point, but will start digging.
(2012-09-07, 02:14)plugh Wrote: [ -> ]Huh - no wonder... midiman, you got an R-pi?? cool!


5 of them actually! Thanks for your help as well.

(2012-09-07, 02:04)bitbotherer Wrote: [ -> ]
(2012-09-07, 01:47)midiman Wrote: [ -> ]Thanks a lot for the offer! The file can be found here https://www.dropbox.com/sh/qyd315dagw3sr4a/ZRrJNWMoyK

Quick fix for you Smile
Search for:
Code:
04 30 90 E5 00 20 D3 E5 46 00 52 E3 01 00 00 0A 00 00 A0 E3 1E FF 2F E1 01 20 D3 E5 4C 00 52 E3 FA FF FF 1A 02 20 D3 E5 56 00 52 E3 F7 FF FF 1A 03 20 D3 E5 04 00 52 E3 F4 FF FF 8A 05 20 D3 E5 00 00 52 E3 F1 FF FF 1A 05 00 93 E5 30 0F BF E6 08 00 50 E3 64 00 A0 83 00 00 A0 93 1E FF 2F E1

and replace with

Code:
04 30 90 E5 00 20 D3 E5 46 00 52 E3 03 00 00 0A 47 00 52 E3 05 00 00 0A 00 00 A0 E3 1E FF 2F E1 00 F0 20 E3 02 20 D3 E5 56 00 52 E3 F9 FF FF 1A 03 20 D3 E5 04 00 52 E3 F6 FF FF 8A 05 20 D3 E5 00 00 52 E3 F3 FF FF 1A 05 00 93 E5 30 0F BF E6 08 00 50 E3 64 00 A0 83 00 00 A0 93 1E FF 2F E1

That is for the specific Openelec Arm version you put up (and is found about 0x2aed8)

I want to have your children! Thanks I will advise how it works.
OK I dont see much love for the Raspberry Pi and Raspbmc. I grabbed and uploaded the file avformat-53-arm.so from a working RC4 install and uploaded it. If someone can point me in the right direction maybe we can come up with a working solution.

http://s000.tinyupload.com/?file_id=0056...5486493650
I hope we all know this is a temporary fix until the Veetle plugin itself is updated because I am running into problems on the Windows side of this fix. Other XBMC plugins such as 1channel, Icefilms, and Youtube have links to FLV streams that will NOT work when the file replace fix is applied. Presently this is acceptable until a plugin update, as there are alot of links to files, but this is not a permanent solution. Please keep patching and compiling, its all weve got for now :-)
(2012-09-07, 07:48)myteematt Wrote: [ -> ]I hope we all know this is a temporary fix until the Veetle plugin itself is updated because I am running into problems on the Windows side of this fix. Other XBMC plugins such as 1channel, Icefilms, and Youtube have links to FLV streams that will NOT work when the file replace fix is applied. Presently this is acceptable until a plugin update, as there are alot of links to files, but this is not a permanent solution. Please keep patching and compiling, its all weve got for now :-)
That thing would disable the normal flv streams? are you sure?
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31