Kodi Community Forum

Full Version: [RELEASE] veetle.com
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
I think the issue with continuous play or the stopping at the end of each program is a problem with veetle itself, having streamed shows on there before, it seems like it creates a new channel with the same title every time one ends, therefore it is essentially a new stream created, the veetle plugin for xbmc doesnt seem to recognize this. We combatted this by using an outside program that runs then sends it to veetle so it's always continuous, however after about 12 hours it times us out and we have to restart the stream. Hope this helps with a possible fix for xbmc.
Appreciate the info
has anyone managed to fix it?

I have 0.3.1 installed on windows 7 and it works fine with xbmc 13.2 and the same setup on android but it doesn't work. I have used the same .zip file so its definitely a working one.
Quote:I have 0.3.1 installed on windows 7 and it works fine with xbmc 13.2 and the same setup on android but it doesn't work. I have used the same .zip file so its definitely a working one.

same here.
rpi openelec not working, but
win 8 xbmc works
I get an error by Veetle. It says akamaiSecureHD.py, script failed.

Kodi 'Helix' version

Windows Vista no problem
Windows 7 problem
Windows 8 problem

What is the solution.

Regards,
Bert
hey anyone know why i`m not getting all the channels showing up? Running windows 8.1 on my laptop and its working fine... but on my media player, also running win 8.1 there are
lots of channels missing? Says i should have ALL (106) ... but only 80 show up when i open it??
Get the fightnight repo, has the updated version, still gets the same error, but ignore it, the addon works great.
There seems to be something amiss with the add-on and some android firmware releases. The error has been posted before but not a solution.

I have a Zidoo x9, which was running fine on firmware release 1.0.2.9. All if my add-ons which where depended on the Veetle add-on produced streams. However when I updated to firmware 1.0.3.3, all Veetle streams failed miserably. When started on it's own or invoked by another add-on the Veetle add-on produces this error in akamaiSecureHD.py

Code:
10:29:36 T:1824640536  NOTICE: -->Python Interpreter Initialized<--
10:29:36 T:1824640536  NOTICE: [plugins.video.veetle] VeetleProxyServer: 'Starting proxy server...'
10:29:36 T:1824640536  NOTICE: [plugins.video.veetle] VeetleProxyServer: 'Proxy server started'
10:29:36 T:1823621336  NOTICE: Thread LanguageInvoker start, auto delete: false
10:29:36 T:1822857736  NOTICE: Thread BackgroundLoader start, auto delete: false
10:29:37 T:1823621336  NOTICE: -->Python Interpreter Initialized<--
10:29:37 T:1823621336 WARNING: CPythonInvoker(15): Script invoked without an addon. Adding all addon modules installed to python path as fallback. This behaviour will be removed in future version.
10:29:39 T:1823621336   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <class 'socket.error'>
                                            Error Contents: (98, 'Address already in use')
                                            Traceback (most recent call last):
                                              File "/mnt/sdcard/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.veetle/akamaiSecureHD.py", line 271, in <module>
                                                httpd = server_class((HOST_NAME, PORT_NUMBER), MyHandler)
                                              File "/home/jenkins/workspace/Android-ARM/tools/depends/xbmc-depends/arm-linux-androideabi-android-17/lib/python2.6/SocketServer.py", line 400, in __init__
                                              File "/home/jenkins/workspace/Android-ARM/tools/depends/xbmc-depends/arm-linux-androideabi-android-17/lib/python2.6/BaseHTTPServer.py", line 108, in server_bind
                                              File "/home/jenkins/workspace/Android-ARM/tools/depends/xbmc-depends/arm-linux-androideabi-android-17/lib/python2.6/SocketServer.py", line 411, in server_bind
                                              File "<string>", line 1, in bind
                                            error: (98, 'Address already in use')
                                            -->End of Python script error report<--

Along with errors in script.common.plugin.cache:

Code:
10:29:54 T:1717131256   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.UnicodeEncodeError'>
                                            Error Contents: 'ascii' codec can't encode character u'\xed' in position 2409: ordinal not in range(128)
                                            Traceback (most recent call last):
                                              File "/mnt/sdcard/Android/data/org.xbmc.kodi/files/.kodi/addons/script.common.plugin.cache/default.py", line 40, in <module>
                                                run()
                                              File "/mnt/sdcard/Android/data/org.xbmc.kodi/files/.kodi/addons/script.common.plugin.cache/default.py", line 35, in run
                                                s.run()
                                              File "/mnt/sdcard/Android/data/org.xbmc.kodi/files/.kodi/addons/script.common.plugin.cache/lib/StorageServer.py", line 247, in run
                                                self._runCommand(data)
                                              File "/mnt/sdcard/Android/data/org.xbmc.kodi/files/.kodi/addons/script.common.plugin.cache/lib/StorageServer.py", line 173, in _runCommand
                                                res = self._sqlSet(data["table"], data["name"], data["data"])
                                              File "/mnt/sdcard/Android/data/org.xbmc.kodi/files/.kodi/addons/script.common.plugin.cache/lib/StorageServer.py", line 420, in _sqlSet
                                                self._log(u"Insert : " + data.decode('utf8', 'ignore'), 3)
                                              File "/home/jenkins/workspace/Android-ARM/tools/depends/xbmc-depends/arm-linux-androideabi-android-17/lib/python2.6/encodings/utf_8.py", line 16, in decode
                                            UnicodeEncodeError: 'ascii' codec can't encode character u'\xed' in position 2409: ordinal not in range(128)
                                            -->End of Python script error report<--

There where mentions of a language locale issue, but I can't figure out what needs to be straightened out.

So, is it a mismatch/inconsistency in the Veetle addon or is the problem in the underlying Android OS?

Edit:
Replacing the original akamaiSecureHD.py with the one from http://code.google.com/p/membrane-xbmc-r...ecureHD.py seems to overcome the akamaiSecureHD.py errors

However, the 'script.common.plugin.cache' still seems to choke on a character. This must be caused by changes in the Android firmware. It worked on a older firmware. So where in the Android settings could this be fixed?
any updates to this release? everything works fine, but when u stop the movie...it freezes and I have to reboot.
Veetle Channel Streams freeze after each ends. wait about 5-10 mins it will start audio up but picture stays frozen. Have to leave channel and reopen stream to fix. kinds annoying when it won't auto play next stream in same channel.

PLEASE HELP!!!!Huh

using latest Kodi 15.2 and Veetle addon with Fire Stick.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31