Kodi Community Forum

Full Version: [RELEASE] veetle.com
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
kobun Wrote:Did this stop working for apple tv 2? Haven't gotten to work in few months always get script error.

i don't have an atv2 but it works for me. i would imagine it's a problem your end as if it had not been working for a few months i would have had lots of reports by now Wink

post a full debug log to pastebin if you are still having problems.

t0mm0
Hi t0mm0
a couple of questions..
is there a method to refresh the available streams in Veetle?
I usually restart xbmc to get the up to date streams. Am I correct?

Is Veetle plugin update automatic?
Or do I have to download( if available) a new version manually?

keep up the good work!
Gangsta75
gangsta75 Wrote:Hi t0mm0
a couple of questions..
is there a method to refresh the available streams in Veetle?
I usually restart xbmc to get the up to date streams. Am I correct?
just coming out of the plugin and going back into it will refresh the stream list, no need to restart xbmc.

gangsta75 Wrote:Is Veetle plugin update automatic?
Or do I have to download( if available) a new version manually?
as with all xbmc addons, as long as you have its repository enabled you will get updates automatically
gangsta75 Wrote:keep up the good work!
thanks Cool

t0mm0
t0mm0 Wrote:just coming out of the plugin and going back into it will refresh the stream list, no need to restart xbmc.
t0mm0

Mmmh, it does not seem to work here;
I've tried to quit and start again the plugin but it does not load the newest streams.
gangsta75 Wrote:Mmmh, it does not seem to work here;
I've tried to quit and start again the plugin but it does not load the newest streams.

well it is working for me - i don't know how that could be cached (there is no caching code in the addon and i don't think xbmc will do any caching in this situation....). look at the log and you will see something like
Code:
14:34:21 T:2965371760  NOTICE: Total veetle.com Channels: 252
14:34:21 T:2965371760  NOTICE: Flash Enabled veetle.com Channels: 46
every time you load the plugin. this means it is grabbing the json file and parsing it for all available channels.

flash enabled channels don't change that frequently so are you sure you are not just expecting stuff to appear that isn't playable by the addon? remember it can only play the flash enabled channels.

t0mm0.
t0mm0 Wrote:flash enabled channels don't change that frequently so are you sure you are not just expecting stuff to appear that isn't playable by the addon? remember it can only play the flash enabled channels.

I'm aware that it can't currently play all of the streams but I will check the log this evening.
Do you see the "url loading" widget on every start up of your plugin?
Because in my case I see it just the first time.
Thank you very much! installed and works great! Fantastic work!
does it work on pre eden release?
because I download your add on, I m able to see the channel but when I want to see one of them nothing happen....Sad
do you have an idea?
thanks!




nevermind I download the latest nightly and everything works fine!!

thanks for this great add on!!
cheers
bakito,
I do not have an answer for you, but a suggestion for posting your log filse. Use the service at pastebin.com next time. Makes it faster and easier to see (:
I the same issue with some of the eden builds. But its working using
OpenELEC_EDEN-Generic.i386-devel-20110927231540-r8326

bakito Wrote:does it work on pre eden release?
because I download your add on, I m able to see the channel but when I want to see one of them nothing happen....Sad
do you have an idea?
thanks!




nevermind I download the latest nightly and everything works fine!!

thanks for this great add on!!
cheers
hello everyone!
I have a strange issue...I put veetle on my favorite but when I want to access it through my favorite the first time it load ,, it just crash and I have to reload it to get it work...any ideas??

http://pastebin.com/aDMtuxPq


thnaks for your great addon!
cheers!
bakito Wrote:hello everyone!
I have a strange issue...I put veetle on my favorite but when I want to access it through my favorite the first time it load ,, it just crash and I have to reload it to get it work...any ideas??

http://pastebin.com/aDMtuxPq


thnaks for your great addon!
cheers!

i can't see any errors in that log relating to the veetle addon so i am not sure what is happening....
arg!!!
maybe it's my nightly build....I tested it with to skin ( alaska and xperience more) and it's the same...
anyway thanks for your quick answer!!
cheers
here's a paste from the log file


19:50:32 M: 31944704 NOTICE: -->Python Initialized<--
19:50:35 M: 27774976 ERROR: DNS lookup for http://www.veetle.com failed: 11001
19:50:35 M: 27774976 ERROR: Error Type: urllib2.URLError
19:50:35 M: 27774976 ERROR: Error Contents: <urlopen error (4, 'getaddrinfo failed')>
19:50:35 M: 27774976 ERROR: Traceback (most recent call last):
File "Q:\plugins\video\plugin.video.veetle\default.py", line 120, in ?
response = urllib2.urlopen(CHANNEL_LISTING)
File "Q:\system\python\python24.zlib\urllib2.py", line 130, in urlopen
File "Q:\system\python\python24.zlib\urllib2.py", line 358, in open
File "Q:\system\python\python24.zlib\urllib2.py", line 376, in _open
File "Q:\system\python\python24.zlib\urllib2.py", line 337, in _call_chain
File "Q:\system\python\python24.zlib\urllib2.py", line 1021, in http_open
File "Q:\system\python\python24.zlib\urllib2.py", line 996, in do_open
URLError: <urlopen error (4, 'getaddrinfo failed')>
19:50:35 M: 34217984 ERROR: DIRECTORY::CDirectory::GetDirectory - Error getting plugin://video/plugin.video.veetle/
19:50:35 M: 34217984 ERROR: CGUIMediaWindow::GetDirectory(plugin://video/plugin.video.veetle/) failed
19:52:07 M: 32858112 NOTICE: -->Python Initialized<--
19:52:13 M: 29941760 NOTICE: -->Python Initialized<--
19:52:20 M: 29773824 NOTICE: -->Python Initialized<--
19:52:27 M: 29679616 NOTICE: -->Python Initialized<--
19:52:30 M: 25993216 ERROR: DNS lookup for crackle.com failed: 11001
19:52:30 M: 25989120 ERROR: Crackle: <urlopen error (4, 'getaddrinfo failed')>
19:52:30 M: 25989120 ERROR: Error Type: exceptions.AttributeError
19:52:30 M: 25989120 ERROR: Error Contents: 'bool' object has no attribute 'find'
19:52:30 M: 25989120 ERROR: Traceback (most recent call last):
File "Q:\plugins\video\plugin.video.crackle\default.py", line 87, in ?
page=page)
File "Q:\plugins\video\plugin.video.crackle\resources\lib\crackle.py", line 69, in get_channels
if html.find('>&gt;</a>') > -1:
AttributeError: 'bool' object has no attribute 'find'
19:52:30 M: 31858688 ERROR: DIRECTORY::CDirectory::GetDirectory - Error getting plugin://video/plugin.video.crackle/?genre=sci-fi&type=a&mode=list_channels&cat=114
19:52:30 M: 31858688 ERROR: CGUIMediaWindow::GetDirectory(plugin://video/plugin.video.crackle/?genre=sci-fi&type=a&mode=list_channels&cat=114) failed


on the crackle i can get various lists .. but when i select any type of media it fails.. Veetle fails imidiately.. any ideas?
bahnen Wrote:here's a paste from the log file


19:50:32 M: 31944704 NOTICE: -->Python Initialized<--
19:50:35 M: 27774976 ERROR: DNS lookup for http://www.veetle.com failed: 11001
19:50:35 M: 27774976 ERROR: Error Type: urllib2.URLError
19:50:35 M: 27774976 ERROR: Error Contents: <urlopen error (4, 'getaddrinfo failed')>
19:50:35 M: 27774976 ERROR: Traceback (most recent call last):
File "Q:\plugins\video\plugin.video.veetle\default.py", line 120, in ?
response = urllib2.urlopen(CHANNEL_LISTING)
File "Q:\system\python\python24.zlib\urllib2.py", line 130, in urlopen
File "Q:\system\python\python24.zlib\urllib2.py", line 358, in open
File "Q:\system\python\python24.zlib\urllib2.py", line 376, in _open
File "Q:\system\python\python24.zlib\urllib2.py", line 337, in _call_chain
File "Q:\system\python\python24.zlib\urllib2.py", line 1021, in http_open
File "Q:\system\python\python24.zlib\urllib2.py", line 996, in do_open
URLError: <urlopen error (4, 'getaddrinfo failed')>
19:50:35 M: 34217984 ERROR: DIRECTORY::CDirectory::GetDirectory - Error getting plugin://video/plugin.video.veetle/
19:50:35 M: 34217984 ERROR: CGUIMediaWindow::GetDirectory(plugin://video/plugin.video.veetle/) failed
19:52:07 M: 32858112 NOTICE: -->Python Initialized<--
19:52:13 M: 29941760 NOTICE: -->Python Initialized<--
19:52:20 M: 29773824 NOTICE: -->Python Initialized<--
19:52:27 M: 29679616 NOTICE: -->Python Initialized<--
19:52:30 M: 25993216 ERROR: DNS lookup for crackle.com failed: 11001
19:52:30 M: 25989120 ERROR: Crackle: <urlopen error (4, 'getaddrinfo failed')>
19:52:30 M: 25989120 ERROR: Error Type: exceptions.AttributeError
19:52:30 M: 25989120 ERROR: Error Contents: 'bool' object has no attribute 'find'
19:52:30 M: 25989120 ERROR: Traceback (most recent call last):
File "Q:\plugins\video\plugin.video.crackle\default.py", line 87, in ?
page=page)
File "Q:\plugins\video\plugin.video.crackle\resources\lib\crackle.py", line 69, in get_channels
if html.find('>&gt;</a>') > -1:
AttributeError: 'bool' object has no attribute 'find'
19:52:30 M: 31858688 ERROR: DIRECTORY::CDirectory::GetDirectory - Error getting plugin://video/plugin.video.crackle/?genre=sci-fi&type=a&mode=list_channels&cat=114
19:52:30 M: 31858688 ERROR: CGUIMediaWindow::GetDirectory(plugin://video/plugin.video.crackle/?genre=sci-fi&type=a&mode=list_channels&cat=114) failed


on the crackle i can get various lists .. but when i select any type of media it fails.. Veetle fails imidiately.. any ideas?

i assume you can't get any internet access from your xbox? looks like you have a dns problem. in other words it is a problem with your xbmc install or your network and not the plugins so i'm afraid i can't fix it Sad

t0mm0
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31