Kodi Community Forum
Play slideshow from MyPictures with "play" button ("p") - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: OS independent / Other (https://forum.kodi.tv/forumdisplay.php?fid=228)
---- Thread: Play slideshow from MyPictures with "play" button ("p") (/showthread.php?tid=104362)



Play slideshow from MyPictures with "play" button ("p") - pallevillesen - 2011-06-27

Hi,

I'm simply tired of having to enter a dir of photos, press "play" to start a slideshow - and pressing "play" on a higher level doesn't do anything...

So I would like to remab the "p" (play button, logitech harmony one remote) to start a recursive slideshow, when I stand in the mypictures window, focus on a dir (with either more dirs in it or just pictures in it) and press "p" in the "mypictures" window...

I tried adding it to keymap.xml but it seems I'm not calling the function correctly:

Code:
<keymap>
  <pictures>
    <keyboard>
      <p>XBMC.SlideShow(, "recursive")</p>
    </keyboard>
  </pictures>
</keymap>


But it doesn't work when I focus on a dir with pictures in it and press "p"...

The debug log says:

Code:
10:58:31 T:3220 M:697438208   DEBUG: SDLKeyboard: scancode: 19, sym: 0070, unicode: 0070, modifier: 0
10:58:31 T:3220 M:697438208   DEBUG: CApplication::OnKey: p (f050) pressed, action is XBMC.SlideShow(, "recursive")

but nothing happens - I don't know how to give the dir in focus as parameter - so any help is appreciated! If I use the context menu ("c") and select "recursive slideshow" everything works - so it must be possible. The requested functionality "just works" when using "mymusic" in file mode, i.e. "play" plays the selected dir of mp3s - without entering the dir.

.p


RE: Play slideshow from MyPictures with "play" button ("p") - rubpa - 2012-07-01

Surprising there is still no way to do start a picture slideshow with play button. Have been looking for the last few hours!



RE: Play slideshow from MyPictures with "play" button ("p") - Robotica - 2012-07-02

Looking at keyboard.xml there is no mapped 'p'.
https://github.com/xbmc/xbmc/blob/2046165596d4c89813ac5760147efaa9f8905ac9/system/keymaps/keyboard.xml